СДАМ ГИА






Каталог заданий. Условие выполнения цикла while
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 2001

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2001: 2004 Все


2
Задание 8 № 2002

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2002: 2003 2005 Все


3
Задание 8 № 2006

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2006: 2007 Все


4
Задание 8 № 2008

Запишите значение переменной b после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


5
Задание 8 № 2010

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


6
Задание 8 № 7753

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 47

N = 1

WHILE S > 0

S = S - 9

N = N + 4

WEND

PRINT(N)

s = 47

n = 1

while s > 0:

    s = s - 9

    n = n + 4

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 47;

    n := 1;

    while s > 0 do

    begin

        s := s - 9;

        n := n + 4

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 47

n := 1

нц пока s > 0

    s := s - 9

    n := n + 4

кц

вывод n

кон

Си

#include <stdio.h>

void main()

{

    int s, n;

    s = 47;

    n = 1;

    while (s > 0) {

        s = s – 9;

        n = n + 4;

    }

    printf("%d\n", n);

}

 

Источник: СтатГрад: Диагностическая работа по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10501.
Пояснение · ·

7
Задание 8 № 7780

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 42

N = 1

WHILE S > 0

S = S – 5

N = N + 3

WEND

PRINT(N)

s = 42

n = 1

while s > 0:

    s = s - 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 42;

    n := 1;

    while s > 0 do

    begin

        s := s – 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 42

n := 1

нц пока s > 0

    s := s — 5

    n := n + 3

кц

вывод n

кон

Си

#include <stdio.h>

void main()

{

    int s, n;

    s = 42;

    n = 1;

    while (s > 0) {

        s = s – 5;

        n = n + 3;

    }

    printf("%d\n", n);

}

 

Источник: СтатГрад: Диагностическая ра­бо­та по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10502.

8
Задание 8 № 7919

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 3

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 3

кц

вывод s

кон

Си

#include

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 3;

    }

    printf("%d", s);

    return 0;

}

 

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 27.02.2015 ва­ри­ант ИН10901.

9
Задание 8 № 7984

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

 N = 1

 S = 0

 WHILE N <= 300

    S = S + 30

    N = N * 3

 WEND

 PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 3

    кц

    вывод s

кон

Си

#include<stdio.h>

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

{

    s = s + 30;

    n = n * 3;

}

    printf("%d", s);

return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 27.02.2015 ва­ри­ант ИН10902.

10
Задание 8 № 8096

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

    s = s - 10

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 301;

    n := 0;

    while s > 0 do

    begin

        s := s - 10;

        n := n + 2;

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 301

    n := 0

    нц пока s > 0

        s := s - 10

        n := n + 2

    кц

    вывод n

кон

Си

#include <stdio.h>

int main()

{

    int s = 301, n = 0;

    while (s > 0) {

        s = s - 10;

        n = n + 2;

    }

    printf("%d\n", n);

    return 0;

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

11
Задание 8 № 8656

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 78

N = 0

WHILE N < 12

    S = S – 8

    N = N + 2

WEND

PRINT(S)

s = 78

n = 0

while n < 12:

    s = s - 8

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 78;

    n := 0;

    while n < 12 do

    begin

        s := s – 8;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 78

    n := 0

    нц пока n < 12

        s := s — 8

        n := n + 2

    кц

    вывод s

кон

Си

#include <stdio.h>

int main(void)

{

    int s, n;

    s = 78;

    n = 0;

    while (n < 12) {

        s = s – 8;

        n = n + 2;

    }

    printf("%d\n", s);

}

 

Источник: СтатГрад: Ре­пе­ти­ци­он­ная ра­бо­та по ин­фор­ма­ти­ке 01.04.2015 ИН10701

12
Задание 8 № 9160

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 56

N = 0

WHILE n < 15

    S = S - 6

    N = N + 3

WEND

PRINT(S)

s = 56

n = 0

while n < 15:

    s = s - 6

    n = n + 3

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 56;

    n := 0;

    while n < 15 do

    begin

        s := s - 6;

        n := n + 3;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 56

    n := 0

    нц пока n < 15

        s := s - 6

        n := n + 3

    кц

    вывод s

кон

Си

#include <stdio.h>

int main(void)

{

    int s, n;

    s = 56;

    n = 0;

    while (n < 15) {

        s = s - 6;

        n = n + 3;

    }

    printf("%d\n", s);

}

 

Источник: СтатГрад: Ре­пе­ти­ци­он­ная работа по информатике 01.04.2015 ИН10702

13
Задание 8 № 9192

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы, за­пи­сан­ной ниже на раз­ных язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 650

    S = S + 20

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 650:

    s = s + 20

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 650 do

    begin

        s := s + 20;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 650

        s := s + 20

        n := n * 5

    кц

    вывод s

кон

Си

#include <stdio.h>

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 650)

    {

        s = s + 20;

        n = n * 5;

    }

    printf("%d", s);

    return 0;

}

 

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10801

14
Задание 8 № 9300

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы, за­пи­сан­ной ниже на раз­ных язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 300

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си

#include <stdio.h>

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

    {

        s = s + 30;

        n = n * 5;

    }

    printf("%d", s);

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10802

15
Задание 8 № 9359

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си

#include

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

printf("%d\n", n);

return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

16
Задание 8 № 9758

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 3*S < 111

   S = S + 8

   N = N + 2

WEND

PRINT N

s = 0

n = 0

while 3*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 3*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 3*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си

#include

int main()

{ int s = 0, n = 0;

  while (3*s < 111) { s = s + 8; n = n + 2; }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 02.12.2015 ИН10203

17
Задание 8 № 9794

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S < 111

  S = S + 8

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си

#include<stdio.h>

int main()

{ int s = 0, n = 0;

while (2*s < 111) { s = s + 8; n = n + 2; }

printf("%d\n", n);

return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 02.12.2015 ИН10204

18
Задание 8 № 3241

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 101 do begin

        s := s + 7;

        n := n + 1

    end;

    write(s)

end.


19
Задание 8 № 3242

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 2;

    s := 35;

    while n <= 25 do begin

        s := s + 20;

        n := n + 5

    end;

    write(s)

end.


20
Задание 8 № 3244

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do begin

        s := s + 20;

        n := n + 2

    end;

    write(s)

end.


21
Задание 8 № 3245

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.


22
Задание 8 № 3248

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 12;

    s := 5;

    while n <= 25 do begin

        s := s + 12;

        n := n + 2

    end;

    write(s)

end.


23
Задание 8 № 3254

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­ще­го фрагмента программы:

 

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do begin

        s := s - 20;

        n := n + 1

    end;

    write(n)

end.


24
Задание 8 № 3774

Определите, что будет напечатано в результате выполнения программы:

 

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

    n := n + 1;

    end;

    write(s)

end.


25
Задание 8 № 3775

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 26 do

    begin

        s := s + 6;

        n := n + 1

    end;

    write(s)

end.


26
Задание 8 № 3842

Определите, что будет напечатано в результате выполнения программы

 

var n, s: integer;

begin

  n := 4;

  s := 0;

  while n <= 8 do

  begin

   s := s + 15;

    n := n + 1

  end;

  write(s)

end.

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.

27
Задание 8 № 3542

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

S = S + 15

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

    n := n + 1

    end;

    write(s)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 13)

    {

        s = s + 15;

        n = n + 1;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 13

    s := s + 15

    n := n + 1

кц

вывод s

кон

 


28
Задание 8 № 3547

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 20

S = S + 33

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 20 do

    begin

        s := s + 33;

        n := n + 1

    end;

    write(s)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 20)

    {

        s = s + 33;

        n = n + 1;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 20

    s := s + 33

    n := n + 1

кц

вывод s

кон

 


29
Задание 8 № 3563

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + 15

N = N + 1

WEND

PRINTS

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1

    end;

    write(s)

end.

СиАлгоритмический язык

void main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + 15;

        n = n + 1;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + 15

    n := n + 1

кц

вывод s

кон

 


30
Задание 8 № 3564

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

S = S - 20

N = N + 1

WEND

PRINT

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1

    end;

    write(n)

end.

СиАлгоритмический язык

#include<stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 512

нцпока s >= 0

    s := s - 20

    n := n + 1

кц

вывод n

кон

 


31
Задание 8 № 3565

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 14

S = 0

WHILE N <= 18

S = S + 25

N = N + 1

WEND

PRINT

var n, s: integer;

begin

    n := 14;

    s := 0;

    while n <= 18 do

    begin

        s := s + 25;

        n := n + 1

    end;

    write(s)

end.

СиАлгоритмический язык

#include<stdio.h>

void main()

{

    int n, s;

    n = 14;

    s = 0;

    while (n <= 18)

    {

        s = s + 25;

        n = n + 1;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n := 14

s := 0

нцпока n <= 18

    s := s + 25

    n := n + 1

кц

вывод s

кон

 


32
Задание 8 № 3566

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

S = S + 20

N = N + 2

WEND

PRINTS

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

    n := n + 2

    end;

    write(s)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 24;

    s = 0;

    while (n <= 28)

    {

        s = s + 20;

        n = n + 2;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n := 24

s := 0

нц пока n <= 28

    s := s + 20

    n := n + 2

кц

вывод s

кон

 


33
Задание 8 № 3810

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те выполнения программы, за­пи­сан­ной ниже на раз­ных языках программирования:

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

S = S + 7

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n : = 1;

    s : = 0;

    while n <= 101 do

    begin

        s : = s + 7;

        n : = n + 1

    end;

    write(s)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 101)

    {

        s = s + 7;

        n = n + 1;

    }

    printf("%d", s);

}

алг

нач

цел n, s

n : = 1

s : = 0

нц пока n <= 101

    s : = s + 7

    n : = n + 1

кц

вывод s

кон

 

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.

34
Задание 8 № 4557

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 35

    N = N + 1

    S = S + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 35 do

    begin

        n := n + 1;

        s := s + 4

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 35)

    {

        n = n + 1;

        s = s + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 35

    n := n + 1

    s := s + 4

кц

вывод n

кон

 

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

35
Задание 8 № 4587

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

    n := n + 1

    end;

    write(n)

end.

СиАлгоритмический язык

#include

void main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    printf("%d", n);

}

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

 


36
Задание 8 № 4691

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 50

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 512 do

    begin

        s := s + 50;

        n : = n + 1

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0 ;

    s = 0 ;

    while (s <= 512)

    {

        s = s + 50;

        n = n + 1;

}

printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 512

    s := s + 50

    n := n + 1

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 3.

37
Задание 8 № 4723

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 1

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 1;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 256

    s : = s + 25

    n : = n + 1

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 4.

38
Задание 8 № 4848

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 33

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 365 do

    begin

        s : = s + 33;

        n : = n + 10

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 33;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 365

    s : = s + 33

    n : = n + 10

кц

вывод n

кон

 

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 14.12.2012 ва­ри­ант 3.

39
Задание 8 № 4936

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 5

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 5

    end;

    write(n);

end.

СиАлгоритмический язык

#include <stdio.h>

void main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 5;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 5;

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 15.02.2013 ва­ри­ант 1.

40
Задание 8 № 4977

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 10

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

    n := n + 10

    end;

    write(n);

end.

СиАлгоритмический язык

#include<stdio.h>

void main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 10;

кц

вывод n

кон

 


41
Задание 8 № 5212

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 30

S = 25

WHILE S < 425

S = S + 40

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 30;

    s : = 25;

    while s < 425 do

    begin

        s : = s + 40;

        n : = n + 10

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 30;

    s = 25;

    while (s < 425)

    {

        s = s + 40;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n : = 30

s : = 25

нц пока s < 425

    s : = s + 40

    n : = n + 10

кц

вывод n

кон

 

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1502.

42
Задание 8 № 5244

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 60

S = 25

WHILE S < 365

S = S + 20

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 60;

    s : = 25;

    while s < 365 do

    begin

        s : = s + 20;

        n : = n + 10

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 60;

    s = 25;

    while (s < 365)

    {

        s = s + 20;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n : = 60

s : = 25

нц пока s < 365

    s : = s + 20

    n : = n + 10

кц

вывод n

кон

 

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1501.

43
Задание 8 № 5361

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s := s + 10

        n := n + 3

    кц

вывод n

кон

 

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 1.

44
Задание 8 № 5393

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 2.
Пояснение · ·

45
Задание 8 № 5457

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 2;

    }

    printf("%d", n);

}

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.

46
Задание 8 № 5489

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 325 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 325

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 1.

47
Задание 8 № 5521

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 25;

        n := n + 4;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Даль­ний Восток. Ва­ри­ант 3.

48
Задание 8 № 5553

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Даль­ний Восток. Ва­ри­ант 5.

49
Задание 8 № 5585

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 2

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 2.

50
Задание 8 № 5617

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 24

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 249 do

    begin

        s : = s + 24;

        n : = n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 24

        n : = n + 3

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 3.
Пояснение · ·

51
Задание 8 № 5713

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 5

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 5;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 256

        s : = s + 25

        n : = n + 5

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 2.

52
Задание 8 № 5745

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 512 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 512)

    {

        s = s + 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 512

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

53
Задание 8 № 5809

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 425

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 425 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 425)

    {

        s = s + 10;

        n = n + 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 425

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 5.

54
Задание 8 № 5841

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 301

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 301;

    while s > 0 do

    begin

        s : = s - 10;

        n : = n + 2;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 301;

    while (s > 0)

    {

        s = s - 10;

        n = n + 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 301

    нц пока s > 0

        s : = s - 10

        n : = n + 2

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 1.

55
Задание 8 № 5873

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S > 0

    S = S - 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 512;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 4;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s > 0)

    {

        s = s - 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 512

    нц пока s > 0

        s : = s - 25

        n : = n + 4

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 2.

56
Задание 8 № 5905

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 256

WHILE S > 0

    S = S - 25

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 256;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 3;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 256;

    while (s > 0)

    {

        s = s - 25;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

    n : = 0

    s : = 256

    нц пока s > 0

        s : = s - 25

        n : = n + 3

    кц

вывод n

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 3.

57
Задание 8 № 6003

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на четырёх язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 325 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write (n)

end.

СиАлгоритмический язык

#include stdio.h

void main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    printf ("%d", n);

}

алг

нач

целn, s

n := 0

s := 0

нц пока s <= 325

    s := s + 10

    n := n + 3

кц

вывод n

кон

 

Источник: Демонстрационная версия ЕГЭ—2014 по информатике.
Пояснение · ·

58
Задание 8 № 6188

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 7

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 7

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 7;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 7

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 08.10.2013 ва­ри­ант ИНФ10101.

59
Задание 8 № 6233

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 8

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 8

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 8;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 8

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 08.10.2013 ва­ри­ант ИНФ10102.

60
Задание 8 № 6265

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 10

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 10

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 501.

61
Задание 8 № 6305

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 20

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 20

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 20;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 20

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.

62
Задание 8 № 6337

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 10

S = 0

WHILE S <= 249

S = S + 24

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 10;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 10;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 10

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 3

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 601.

63
Задание 8 № 6422

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 40

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 40;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 40;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 40

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 602.

64
Задание 8 № 6458

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 20

S = 0

WHILE S <= 257

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 20;

    s := 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 20;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 20

s := 0

нц пока s <= 257

    s := s + 10

    n := n + 3

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 603.

65
Задание 8 № 6500

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

S = S + 24

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 10

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 10

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.

66
Задание 8 № 6576

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 15

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 15;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 15;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 15

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.

67
Задание 8 № 6778

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 37

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 37;

        n := n * 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 37;

        n = n * 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 37

    n := n * 2

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 20.02.2014 ва­ри­ант ИН10601.

68
Задание 8 № 6810

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n * 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 36

    n := n * 2

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 20.02.2014 ва­ри­ант ИН10602.

69
Задание 8 № 6892

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 18

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 18;

        n := n + 5

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 18;

        n = n + 5;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 18

    n := n + 5

кц

вывод n

кон

 

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 11.12.2013 ва­ри­ант ИНФ10301.

70
Задание 8 № 6924

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 12

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 12;

        n := n + 5

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 12;

        n = n + 5;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 12

    n := n + 5

кц

вывод n

кон

 

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 11.12.2013 ва­ри­ант ИНФ10302.

71
Задание 8 № 7202

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы.

Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на четырёх язы­ках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 70

WHILE S > 7

S = S – 7

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 70;

    while s > 7 do

    begin

        s := s – 7;

        i := i + 1

    end;

    writeln(i)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int i, s;

    i = 0;

    s = 70;

    while (s > 7)

    {

        s = s – 7;

        i++;

    }

    printf("%d\n", i);

}

алг

нач

цел i, s

i := 0

s := 70

нц пока s > 7

    s := s - 7

    i := i + 1

кц

вывод i

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

72
Задание 8 № 7269

Определите, что будет напечатано в результате работы следующего фрагмента программы:

var n, s: integer;

begin

    n := 4;

    s := 15;

    while s <= 250 do begin

        s := s + 12;

        n := n + 2

    end;

    write(n)

end.


73
Задание 8 № 7371

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы.

Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на четырёх язы­ках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 64

WHILE S > 8

S = S – 8

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 64;

    while s > 8 do

    begin

        s := s – 8;

        i := i + 1

    end;

    writeln(i)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int i, s;

    i = 0;

    s = 64;

    while (s > 8)

    {

        s = s – 8;

        i++;

    }

    printf("%d\n", i);

}

алг

нач

цел i, s

i := 0

s := 64

нц пока s > 8

    s := s - 8

    i := i + 1

кц

вывод i

кон

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

74
Задание 8 № 10284

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 3

  кц

  вывод n

кон

Си

#include<stdio.h>

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 3;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10303

75
Задание 8 № 10311

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 2

  кц

  вывод n

кон

Си

#include<stdio.h>

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 2;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10304

76
Задание 8 № 10382

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 3

  кц

  вывод n

кон

Си

#include<stdio.h>

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 3;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 18.03.2016 ИН10403

77
Задание 8 № 10409

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 2

  кц

  вывод n

кон

Си

#include<stdio.h>

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 2;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 18.03.2016 ИН10404

78
Задание 8 № 10471

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S <= 65

S = S + 5

N = N + 3

WEND

PRINT N

s = 0

n = 0

while s <= 65:

    s = s + 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s <= 65 do

    begin

        s := s + 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел n, s

s := 0

n := 0

нц пока s <= 65

    s := s + 5

    n := n + 3

кц

вывод n

кон

Си

#include <stdio.h>

int main()

{

    int s = 0, n = 0;

    while (s <= 65)

    {

        s = s + 5;

        n = n + 3;

    }

    printf("%d\n", n);

    return 0;

}

 

 

Источник: Типовые те­сто­вые за­да­ния по ин­фор­ма­ти­ке под ре­дак­ци­ей С. С. Крылова, Т. Е. Чуркиной. 2016. В. 1.

79
Задание 8 № 10498

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 65

S = S + 6

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 65:

    s = s + 6

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s < 65 do

    begin

        s := s + 6;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

  цел n, s

  s := 0

  n := 0

  нц пока s < 65

    s := s + 6

    n := n + 2

  кц

  вывод n

кон

Си

#include <stdio.h>

int main()

{

    int s = 0, n = 0;

    while (s < 65)

    {

        s = s + 6;

        n = n + 2;

    }

    printf("%d\n", n);

    return 0;

}

 

Источник: Ти­по­вые те­сто­вые за­да­ния по ин­фор­ма­ти­ке под ре­дак­ци­ей С. С. Крылова, Т. Е. Чуркиной. 2016. В. 2.

80
Задание 8 № 11109

Определите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы, за­пи­сан­ной ниже на пяти язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 251

  S = S + 25

  N = N + 1

WEND

PRINT N

n = 0

s = 0

while s <= 251:

    s = s + 25

    n = n + 1

print(n)

Алгоритмический языкПаскаль

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s <= 251

    s := s + 25

    n := n + 1

  кц

  вывод n

кон

var n, s: integer;

begin

  n := 0;

  s := 0;

  while s <= 251 do

  begin

    s := s + 25;

    n := n + 1

  end;

  write(n)

end.

Си

#include<stdio.h>

void main()

{

  int n, s;

  n = 0;

  s = 0;

  while (s <= 251)

  {

    s = s + 25;

    n = n + 1;

  }

  printf("%d", n);

}

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна

81
Задание 8 № 11237

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 5

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 5

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 5

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 5

  end;

  writeln(n)

end.

Си

#include <stdio.h>

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 5;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10503.

82
Задание 8 № 11264

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 2

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 2

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 2

  end;

  writeln(n)

end.

Си

#include <stdio.h>

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 2;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10504.

83
Задание 8 № 11304

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var s,n:integer;

begin

 s:=0;

 n:=0;

  while(s<165) do

  begin

   s:=s+15;

   n:=n+2;

  end;

 writeln(n);

end.

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

84
Задание 8 № 11344

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 150

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 150:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 150 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 150

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си

#include<stdio.h>

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 150)

    {

        s = s + 30;

        n = n * 5;

    }

    printf("%d", s);

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

85
Задание 8 № 13354

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 71

     S = S + 10

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 71:

    s = s + 10

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 71 do

begin

    s := s + 10;

    n := n + 3

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 71

    s := s + 10

    n := n + 3

кц

вывод n

кон

Си

#include

int main()

{  int s = 0, n = 0;

    while (s < 71) { s = s + 10; n = n + 3; }

    printf("%d\n", n);

    return 0;

}

 

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

86
Задание 8 № 13404

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 99

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 99:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 99 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 99

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си

#include

int main()

{  int s = 0, n = 0;

    while (s*s < 99) { s = s + 1; n = n + 2; }

    printf("%d\n", n);

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

87
Задание 8 № 13457

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 101

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 101:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 101 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 101

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си

#include<stdio.h>

int main()

{  int s = 0, n = 0;

    while (s*s < 101) { s = s + 1; n = n + 2; }

    printf("%d\n", n);

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

88
Задание 8 № 13484

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S <= 10*S

     S = S + 1

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s <= 10*s:

    s = s + 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s <= 10*s do

begin

    s := s + 1;

    n := n + 3;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s <= 10*s

    s := s + 1

    n := n + 3

кц

вывод n

кон

Си

#include

int main()

{  int s = 0, n = 0;

    while (2*s*s <= 10*s) { s = s + 1; n = n + 3; }

    printf("%d\n", n);

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

89
Задание 8 № 13511

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 10*S

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 10*s:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s < 10*s do

begin

    s := s + 1;

    n := n + 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s < 10*s

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си

#include

int main()

{  int s = 0, n = 0;

    while (2*s*s < 10*s) { s = s + 1; n = n + 2; }

    printf("%d\n", n);

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

90
Задание 8 № 13538

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 150

     S = S + 15

     N = N*2

WEND

PRINT N

s = 0

n = 1

while s < 150:

    s = s + 15

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 1;

while s < 150 do

begin

    s = s + 15;

    n = n * 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока s < 150

    s = s + 15

    n = n * 2

кц

вывод n

кон

Си

#include

int main()

{  int s = 0, n = 1;

    while (s < 150) { s = s + 15; n = n * 2; }

    printf("%d\n", n);

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

91
Задание 8 № 13565

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 165

  S = S + 15

  N = N * 2

WEND

PRINT N

s = 0

n = 1

while s < 165:

  s = s + 15

  n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 1;

  while s < 165 do

  begin

    s := s + 15;

    n := n * 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 1

  s := 0

  нц пока s < 165

    s = s + 15

    n = n * 2

  кц

  вывод n

кон

Си

#include

int main()

{

  int s = 0;

  int n = 1;

  while (s < 165) {

    s = s + 15;

    n = n * 2;

  }

  printf("%d\n", n);

  return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

92
Задание 8 № 13592

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 3

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 3

    кц

    вывод n

кон

Си

#include<stdio.h>

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 3;

    }

    printf("%d\n", n);

    return 0;

}

 

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

93
Задание 8 № 13619

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 2

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 2

    кц

    вывод n

кон

Си

#include<stdio.h>

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    printf("%d\n", n);

    return 0;

}

 

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

94
Задание 8 № 13735

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 260

WHILE S > 0

    S = S - 15

    N = N + 2

WEND

PRINT N

n = 0

s = 260

while s > 0:

    s = s - 15

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 260;

    while s > 0 do

    begin

        s := s - 15;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 260

    нц пока s > 0

        s := s - 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include

using namespace std;

int main() {

    int n, s;

    n = 0, s = 260;

    while (s > 0) {

        s = s - 15;

        n = n + 2;

    }

    count << n << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

95
Задание 8 № 14223

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 3

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 3

    кц

    вывод n

кон

Си++

#include

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

    while (s > 0) {

        s = s - 1;

        n = n + 3;

    }

    count << n << endl;

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10103

96
Задание 8 № 14267

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

    while (s > 0) {

        s = s - 1;

        n = n + 2;

    }

    count << n << endl;

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10104

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!