Каталог заданий.
Условие выполнения цикла while

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Тип 6 № 27403

Определите, при каком наибольшем введённом значении переменной s программа выведет число 64. Для Вашего удобства программа представлена на четырёх языках программирования.

 

Си++Python

#include <iostream>

using namespace std;

int main() {

    int s, n;

    cin >> s;

    s = s / 10;

    n = 1 ;

    while (s < 51) {

        s = s + 5;

        n = n * 2;

    }

    cout << n << endl;

    return 0;

}

s = int(input())

s = s // 10

n = 1

while s < 51:

    s = s + 5

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    readln (s);

    s := s div 10;

    n := 1;

    while s < 51 do

    begin

        s := s + 5;

        n := n * 2

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    ввод s

    s := div( s, 10)

    n := 1

    нц пока s < 51

        s := s + 5

        n := n * 2

    кц

    вывод n

кон

Источник: Демонстрационная версия ЕГЭ−2021 по информатике, Демонстрационная версия ЕГЭ−2022 по информатике

2
Тип 6 № 29654

Определите, при каком наименьшем введённом значении переменной s программа выведет число 128. Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

INPUT X

N = 4

WHILE S < 37

    S = S + 3

    N = N * 2

WEND

PRINT N

s = int(input())

n = 4

while s < 37:

    s = s + 3

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    readln(s);

    n := 4;

    while s < 37 do

    begin

        s := s + 3;

        n := n * 2

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    ввод s

    n := 4

    нц пока s < 37

        s := s + 3

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int s;

cin >> s;

int n = 4;

    while (s < 37) { s = s + 3; n = n * 2; }

    cout << n << endl;

    return 0;

}


3
Тип 6 № 30692

Определите, при каком наименьшем введённом значении переменной s программа выведет число 64. Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

INPUT X

N = 1

WHILE S < 51

    S = S + 5

    N = N * 2

WEND

PRINT N

s = int(input())

n = 1

while s < 51:

    s = s + 5

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    readln(s);

    n := 1;

    while s < 51 do

    begin

        s := s + 5;

        n := n * 2

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    ввод s

    n := 1

    нц пока s < 51

        s := s + 5

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int s;

cin >> s;

int n = 1;

    while (s < 51) { s = s + 5; n = n * 2; }

    cout << n << endl;

    return 0;

}


4
Тип 6 № 33085

Определите, при каком наименьшем введённом значении переменной s программа выведет число 128. Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

INPUT X

N = 2

WHILE S < 37

    S = S + 3

    N = N * 2

WEND

PRINT N

s = int(input())

n = 2

while s < 37:

    s = s + 3

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    readln(s);

    n := 2;

    while s < 37 do

    begin

        s := s + 3;

        n := n * 2

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    ввод s

    n := 2

    нц пока s < 37

        s := s + 3

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int s;

cin >> s;

int n = 2;

    while (s < 37) { s = s + 3; n = n * 2; }

    cout << n << endl;

    return 0;

}


5
Тип 6 № 33178

Определите, при каком наименьшем введённом значении переменной s программа выведет число 60. Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

INPUT S

N = 36

WHILE S < 2020

    S = S * 2

    N = N + 3

WEND

PRINT N

s = int(input())

n = 36

while s < 2020:

    s = s * 2

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    readln(s);

    n := 36;

    while s < 2020 do

    begin

        s := s * 2;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    ввод s

    n := 36

    нц пока s < 2020

        s := s * 2

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int s;

cin >> s;

int n = 36;

    while (s < 2020) { s = s * 2; n = n + 3; }

    cout << n << endl;

    return 0;

}


Пройти тестирование по этим заданиям