№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора Ф ИПИ Справка
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Посимвольная обработка чисел в разных СС
1.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 13.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A+1

    B = B + (X MOD 100)

    X = X/100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 0

while x > 0:

    a = a + 1

    b = b + x%100

    x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

        begin

            a := a+1;

            b := b+(x mod 100);

            x := x div 100;

        end;

    writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

    a := a+1

    b := b+mod(x,100)

    x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        a = a+1;

        b = b + (x%100);

        x = x/100;

    }

    cout << a << endl << b << endl;

}

 

2.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 7.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A+1

    B = B * (X MOD 100)

    X = X\100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 1

while x > 0:

    a = a + 1

    b = b * (x%100)

    x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

        begin

            a := a+1;

            b := b*(x mod 100);

            x := x div 100;

        end;

    writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x > 0

    a := a+1

    b := b*mod(x,100)

    x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        a = a+1;

        b = b * (x%100);

        x = x/100;

    }

    cout << a << endl << b endl;

}

 

3.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 5.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A+1

    B = B * (X MOD 100)

    X = X\100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 1

while x > 0:

    a = a + 1

    b = b * x%100

    x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

        begin

            a := a+1;

            b := b*(x mod 100);

            x := x div 100;

        end;

    writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x > 0

    a := a+1

    b := b*mod(x,100)

    x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        a = a+1;

        b = b * (x%100);

        x = x/100;

    }

    cout << a << endl << b << endl;

}

 

4.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 3, а потом 6.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

M = M + 1

IF X MOD 2 <> 0 THEN

    L = L + 1

ENDIF

X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        M := M + 1;

        if x mod 2 <> 0 then

            L := L + 1;

        x := x div 2;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) <> 0

            то

                L := L + 1

        все

        x := div(x,2)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        M = M + 1;

        if(x % 2 != 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M endl;

}

 

5.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 11.

Бейсик Python

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A+1

    B = B*(X MOD 1000)

    X = X\1000

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 1

while x > 0:

    a = a+1

    b = b*(x%1000)

    x = x//1000

print(a)

print(b)

Алгоритмический язык Паскаль

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x, 1000)

        x := div(x, 1000)

    кц

    вывод a, нс, b

кон

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 1000);

        x := x div 1000;

    end;

    writeln(a); write(b);

end.

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        a = a+1;

        b = b * (x%1000);

        x = x/1000;

    }

    cout << a << endl << b endl;

    return 0;

}

 

6.

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 21.

 

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0){

        a=a+1;

        b=b*(x%10);

        x= x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= (x % 10)

    x //= 10

print(a)

print(b)

 

7.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 15.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0

b = 1

while x > 0:

    a = a + 1

    b = b * (x % 10)

    x = x // 10

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b)

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 1;

    while (x > 0){

        a = a + 1;

        b = b * (x % 10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

 

8.

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает шестизначное число.

 

БейсикPython

DIM X,S,D,R AS LONG

INPUT X

S = X

R = 0

WHILE X > 0

  D = X MOD 2

  R = 10*R + D

   X = X \ 2

WEND

S = R + S

PRINT S

x = int(input())

S = x;

R = 0

while x > 0:

   d = x % 2

   R = 10*R + d

  x=x // 2

S = R + S

print(S)

ПаскальАлгоритмический язык

var x,d,R,S: longint;

begin

     readln(x);

     S := x;

     R := 0;

     while x > 0 do

     begin

       d := x mod 2;

       R := 10*R + d;

       x := x div 2;

     end;

     S := R + S;

     writeln(S);

end.

алг

нач

     цел x, d, R, S

     ввод x

     S := x

     R := 0

     нц пока x > 0

         d := mod(x, 2)

         R := 10*R + d

         x := div(x, 2)

     кц

     S := R + S

    вывод S

кон

Си++

#include <iostream>

using namespace std;

int main()

{

     long x,d,R,S;

     cin >> x;

     S = x;

     R = 0;

     while (x > 0){

         d = x % 2;

         R = 10*R + d;

         x = x / 2;

       }

     S = R + S

     cout << S << endl;

    return 0;

}

 

9.

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает пятизначное число.

 

БейсикPython

DIM X,S,D,R AS LONG

INPUT X

S = X

R = 0

WHILE X > 0

  D = X MOD 2

  R = 10*R + D

   X = X \ 2

WEND

S = R + S

PRINT S

x = int(input())

S = x;

R = 0

while x > 0:

   d = x % 2

   R = 10*R + d

  x=x / / 2

S = R + S

print(S)

ПаскальАлгоритмический язык

var x,d,R,S: longint;

begin

     readln(x);

     S := x;

     R := 0;

     while x > 0 do

     begin

       d := x mod 2

       R := 10*R + d;

       x := x div 2

     end;

     S := R + S

     writeln(s);

end.

алг

нач

     цел x, d, R, S

     ввод x

     S := x

     R := 0

     нц пока x > 0

         d := mod(x, 2)

         R := 10*R + d

         x := div(x, 2)

     кц

     S := R + S

    вывод S

кон

Си++

#include <iostream>

using namespace std;

int main()

{

     long x,d,R,S;

     cin >> x;

     S = x;

     R = 0;

     while (x > 0){

         d = x % 2;

         R = 10*R + d;

         x = x / 2;

       }

     S = R + S

     cout << S << endl;

    return 0;

}

 

10.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 5, а потом 7.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

     IF X MOD 2 <> 0 THEN

      L = L + 1

     END IF

X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

     M = M + 1

     if x % 2 != 0:

      L = L + 1

     x = x // 2

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

     readln(x);

     L := 0;

     M := 0;

     while x>0 do

    begin

         M :=M+1;

         if x mod 2 <> 0 then

            L := L + 1;

         x := x div 2;

    end;

    writeln(L)

    writeln(M)

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        M := M + 1

         если mod(x,2) <> 0

            то

             L := L + 1

        все

        x := div(x,2)

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(){

     int x, L, M;

     cin >> x;

     L = 0;

     M = 0;

     while (x > 0) {

          M = M + 1;

          if(x % 2 != 0) {

             L = L + 1;

          }

          x = x / 2;

        }

        cout << L << endl << M << endl;

        return 0;

}

 

11.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 4.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 = 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0) a += 1;

        else                

        b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

12.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 1, а потом 6.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 = 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0)

        a += 1;

        else                

        b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

13.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 8.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0

b=0

while x > 0:

    if x%2 > 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)>0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 > 0)

            a += 1;

        else

            b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

14.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 6.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 6

    END IF

    X = X \ 6

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=0

while x > 0:

    if x%2 > 0:

        a += 1

    else:

        b += x%6

    x = x//6

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + 1

        else

            b := b + x mod 6;

        x := x div 6;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)>0

            то a := a+1

            иначе b := b + mod(x,6)

        все x := div(x,6)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 > 0)

        a += 1;

        else                

        b += x%6;

        x = x / 6;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

15.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 10.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + X MOD 12

    ELSE

        B = B * (X MOD 12)

    END IF

    X = X \ 12

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=1

while x > 0:

    if x%2 > 0:

        a += x%12

    else:

        b *= x%12

    x = x // 12

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + x mod 12

        else

            b := b * (x mod 12);

        x := x div 12;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        если mod(x,2)>0

            то a := a + mod(x,12)

            иначе b:=b*mod(x,12)

        все x := div(x,12)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        if (x%2 > 0)

            a += x%12;

        else

            b *= x%12;

        x = x / 12;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

16.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 10.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + X MOD 12

    ELSE

        B = B * (X MOD 12)

    END IF

    X = X \ 12

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=1

while x > 0:

    if x%2 > 0:

        a += x%12

    else:

        b *= x%12

    x = x // 12

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + x mod 12

        else

            b := b * (x mod 12);

        x := x div 12;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        если mod(x,2)>0

            то a := a + mod(x,12)

            иначе b := b*mod(x,12)

        все x := div(x,12)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        if (x%2 > 0)

            a += x%12;

        else

            b *= x%12;

        x = x / 12;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

17.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 5, а потом 16.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + X MOD 12

    ELSE

        B = B * (X MOD 12)

    END IF

    X = X \ 12

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=1

while x > 0:

    if x%2 > 0:

        a += x%12

    else:

        b *= x%12

    x = x // 12

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + x mod 12

        else

            b := b * (x mod 12);

        x := x div 12;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        если mod(x,2)>0

            то a := a + mod(x,12)

            иначе b:=b*mod(x,12)

        все x := div(x,12)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        if (x%2 > 0)

            a += x%12;

        else

            b *= x%12;

        x = x / 12;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

18.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 12.

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    IF X MOD 2 > 0 THEN

        A = A + X MOD 12

    ELSE

        B = B * (X MOD 12)

    END IF

    X = X \ 12

WEND

PRINT A

PRINT B

 

x = int(input())

a=0; b=1

while x > 0:

    if x%2 > 0:

        a += x%12

    else:

        b *= x%12

    x = x // 12

print(a, b)

 

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do begin

        if x mod 2 > 0 then

            a := a + x mod 12

        else

            b := b * (x mod 12);

        x := x div 12;

    end;

    writeln(a); write(b);

end.

 

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        если mod(x,2)>0

            то a := a + mod(x,12)

            иначе b:=b*mod(x,12)

        все x := div(x,12)

    кц

    вывод a, нс, b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0) {

        if (x%2 > 0)

            a += x%12;

        else

            b *= x%12;

        x = x / 12;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

 

19.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем выводит одно число. Укажите наименьшее возможное значение x, при вводе которого алгоритм выведет число 7.

 

 

БейсикPython

DIM X, A, B, D AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    D = X MOD 6

    IF D > A THEN A = D

    IF D < B THEN B = D

    X = X \ 6

WEND

PRINT A+B

 

x = int(input())

a=0; b=10

while x > 0:

    d = x % 6

    if d > a: a = d

    if d < b: b = d

    x = x // 6

print(a+b)

 

ПаскальАлгоритмический язык

var x, a, b, d: longint;

begin

    readln(x);

    a := 0; b := 10;

    while x > 0 do begin

        d := x mod 6

        if d > a then a := d;

        if d < b then b := d;

        x := x div 6

    end;

    writeln(a+b)

end.

 

алг

нач

    цел x, a, b, d

    ввод x

    a := 0; b := 10

    нц пока x > 0

        d := mod(x,6)

        если d > a то a := d все

        если d < b то b := d все

        x := div(x,6)

    кц

    вывод a+b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, d;

    cin >> x;

    a = 0; b = 10;

    while (x > 0) {

        d = x % 6;

        if (d > a) a = d;

        if (d < b) b = d;

        x = x / 6;

    }

    cout << a+b << endl;

    return 0;

}

 

 

20.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем выводит одно число. Укажите наименьшее возможное значение x, при вводе которого алгоритм выведет число 8.

 

 

БейсикPython

DIM X, A, B, D AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    D = X MOD 6

    IF D > A THEN A = D

    IF D < B THEN B = D

    X = X \ 6

WEND

PRINT A+B

 

x = int(input())

a=0; b=10

while x > 0:

    d = x % 6

    if d > a: a = d

    if d < b: b = d

    x = x // 6

print(a+b)

 

ПаскальАлгоритмический язык

var x, a, b, d: longint;

begin

    readln(x);

    a := 0; b := 10;

    while x > 0 do begin

        d := x mod 6

        if d > a then a := d;

        if d < b then b := d;

        x := x div 6

    end;

    writeln(a+b)

end.

 

алг

нач

    цел x, a, b, d

    ввод x

    a := 0; b := 10

    нц пока x > 0

        d := mod(x,6)

        если d > a то a := d все

        если d < b то b := d все

        x := div(x,6)

    кц

    вывод a+b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, d;

    cin >> x;

    a = 0; b = 10;

    while (x > 0) {

        d = x % 6;

        if (d > a) a = d;

        if (d < b) b = d;

        x = x / 6;

    }

    cout << a+b << endl;

    return 0;

}

 

 

21.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем печатает числа: L и M. Укажите наименьшее из таких чисел x, при вводе которого после выполнения алгоритма будет напечатано сначала 5, а потом 6.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 <> 0 THEN

        L = L + 1

    END IF

    X = X \ 2

WEND

PRINT L

PRINT M

 

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

 

ПаскальАлгоритмический язык

var x, L, M: longint;

begin

    readln(x);

    L := 0; M := 0;

    while x > 0 do begin

        M := M + 1;

        if x mod 2 <> 0

            then L := L + 1;

        x := x div 2;

    end;

    writeln(L); write(M);

end.

 

алг

нач

    цел x, L, M

    ввод x

    L := 0; M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) <> 0 то L := L + 1 все

        x := div(x,2)

    кц

    вывод L

    вывод M

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0; M = 0;

    while (x > 0) {

        M = M + 1;

        if(x % 2 != 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M;

}

 

 

22.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 5, а потом 6.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 <> 0 THEN

        L = L + 1

    END IF

    X = X \ 2

WEND

PRINT L

PRINT M

 

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

 

ПаскальАлгоритмический язык

var x, L, M: integer;;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        M := M + 1;

        if x mod 2 <> 0

            then L := L + 1;

        x := x div 2;

    end;

    writeln(L);

    writeln(M);

end.

 

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) <> 0 то

            L := L + 1

        все

        x := div(x,2)

    кц

    вывод L

    вывод M

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0) {

        M = M + 1;

        if(x % 2 != 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M << endl;

    return 0;

}

 

 

23.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем выводит одно число. Укажите наименьшее возможное значение x, при вводе которого алгоритм выведет число 11.

 

 

БейсикPython

DIM X, A, B, D AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    D = X MOD 9

    IF D > A THEN A = D

    IF D < B THEN B = D

    X = X \ 9

WEND

PRINT A+B

 

x = int(input())

a=0; b=10

while x > 0:

    d = x % 9

    if d > a: a = d

    if d < b: b = d

    x = x // 9

print(a+b)

ПаскальАлгоритмический язык

var x, a, b, d: longint;

begin

    readln(x);

    a := 0; b := 10;

    while x > 0 do begin

        d := x mod 9;

        if d > a then a := d;

        if d < b then b := d;

        x := x div 9

    end;

    writeln(a+b);

end.

 

алг

нач

    цел x, a, b, d

    ввод x

    a := 0; b := 10

    нц пока x > 0

        d := mod(x,9)

        если d > a то a := d все

        если d < b то b := d все

        x := div(x,9)

    кц

    вывод a+b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, d;

    cin >> x;

    a = 0; b = 10;

    while (x > 0) {

        d = x % 9;

        if (d > a) a = d;

        if (d < b) b = d;

        x = x / 9;

    }

    cout << a+b << endl;

    return 0;

}

 

 

24.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем выводит одно число. Укажите наименьшее возможное значение x, при вводе которого алгоритм выведет число 18.

 

 

БейсикPython

DIM X, A, B, D AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    D = X MOD 9

    IF D > A THEN A = D

    IF D < B THEN B = D

    X = X \ 9

WEND

PRINT A*B

 

x = int(input())

a=0; b=10

while x > 0:

    d = x % 9

    if d > a: a = d

    if d < b: b = d

    x = x // 9

print(a*b)

ПаскальАлгоритмический язык

var x, a, b, d: longint;

begin

    readln(x);

    a := 0; b := 10;

    while x > 0 do begin

        d := x mod 9;

        if d > a then a := d;

        if d < b then b := d;

        x := x div 9

    end;

    writeln(a*b);

end.

 

алг

нач

    цел x, a, b, d

    ввод x

    a := 0; b := 10

    нц пока x > 0

        d := mod(x,9)

        если d > a то a := d все

        если d < b то b := d все

        x := div(x,9)

    кц

    вывод a*b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, d;

    cin >> x;

    a = 0; b = 10;

    while (x > 0) {

        d = x % 9;

        if (d > a) a = d;

        if (d < b) b = d;

        x = x / 9;

    }

    cout << a*b << endl;

    return 0;

}

 

 

25.

Ниже на пяти языках программирования записан алгоритм, который вводит натуральное число x, выполняет преобразования, а затем выводит одно число. Укажите наименьшее возможное значение x, при вводе которого алгоритм выведет число 12.

 

 

БейсикPython

DIM X, A, B, D AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    D = X MOD 6

    IF D > A THEN A = D

    IF D < B THEN B = D

    X = X \ 6

WEND

PRINT A*B

 

x = int(input())

a=0; b=10

while x > 0:

    d = x % 6

    if d > a: a = d

    if d < b: b = d

    x = x // 6

print(a*b)

ПаскальАлгоритмический язык

var x, a, b, d: longint;

begin

    readln(x);

    a := 0; b := 10;

    while x > 0 do begin

        d := x mod 6;

        if d > a then a := d;

        if d < b then b := d;

        x := x div 6

    end;

    writeln(a*b);

end.

 

алг

нач

    цел x, a, b, d

    ввод x

    a := 0; b := 10

    нц пока x > 0

        d := mod(x,6)

        если d > a то a := d все

        если d < b то b := d все

        x := div(x,6)

    кц

    вывод a*b

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, d;

    cin >> x;

    a = 0; b = 10;

    while (x > 0) {

        d = x % 6;

        if (d > a) a = d;

        if (d < b) b = d;

        x = x / 6;

    }

    cout << a*b << endl;

    return 0;

}

 

 

26.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 <> 0 THEN

        L = L + 1

    END IF

    X = X \ 2

WEND

PRINT L

PRINT M

 

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

 

ПаскальАлгоритмический язык

var x, L, M: integer;;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        M := M + 1;

        if x mod 2 <> 0

            then L := L + 1;

        x := x div 2;

    end;

    writeln(L);

    writeln(M);

end.

 

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) <> 0 то

            L := L + 1

        все

        x := div(x,2)

    кц

    вывод L

    вывод M

кон

 

С++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0) {

        M = M + 1;

        if(x % 2 != 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M << endl;

    return 0;

}

 

 

27.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 6, а потом 7.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 = 0 THEN

        L = L + 1

    ENDIF

    X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 == 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        M := M + 1;

        if x mod 2 = 0 then

            L := L + 1;

        x := x div 2;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        M := M + 1

        если mod(x,2) = 0

            то

                L := L + 1

        все

        x := div(x,2)

    кц

    вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        M = M + 1;

        if(x % 2 == 0){

            L = L + 1;

        }

        x = x / 2;

    }

    cout << L << endl << M << endl;

    return 0;

}

 

28.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число натуральное десятичное x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 2, а потом 3.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 <> 0 THEN

        L = L + X MOD 8

    ENDIF

    X = X \ 8

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0 :

    M = M+1

     if (x % 2) != 0:

         L = L + x % 8

     x = x // 8

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L:=0; M:=0;

    while x > 0 do begin

        M:=M + 1;

        if (x mod 2) <> 0 then

            L:= L + x mod 8;

        x:= x div 8;

    end;

    writeln(L); write(M);

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        M := M + 1

         если mod(x,2) <> 0

            то

             L:= L + mod (x,8);

        x := div(x,8)

        все

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(void) {

    int L, M, x;

    cin >> x;

     L = 0; M = 0;

    while (x > 0) {

         M = M + 1;

        if (x % 2 != 0) {

             L = L + x % 8;

        }

        x = x / 8;

    }

     cout << L << “ “ << M;

}

 

29.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число натуральное десятичное x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 12, а потом 3.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

    M = M + 1

    IF X MOD 2 = 0 THEN

        L = L + X MOD 8

    ENDIF

    X = X \ 8

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0 :

    M = M+1

     if (x % 2) == 0:

         L = L + x % 8

     x = x // 8

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L:=0; M:=0;

    while x > 0 do begin

        M:=M + 1;

        if (x mod 2) = 0 then

            L:= L + x mod 8;

        x:= x div 8;

    end;

    writeln(L); write(M);

end.

алг

нач

     цел x, L, M

     ввод x

     L := 0

     M := 0

    нц пока x > 0

        M := M + 1

         если mod(x,2) = 0

            то

             L:= L + mod (x,8);

        x := div(x,8)

        все

     кц

     вывод L, нс, M

кон

Си++

#include <iostream>

using namespace std;

 

int main(void) {

    int L, M, x;

    cin >> x;

     L = 0; M = 0;

    while (x > 0) {

         M = M + 1;

        if (x % 2 == 0) {

             L = L + x % 8;

        }

        x = x / 8;

    }

     cout << L << “ “ << M;

}