№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИПИ Справка
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Две линейные функции
1.

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 2

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 2

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 2;

    }

    cout « s « endl;

}

 

2.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 47

N = 1

WHILE S > 0

S = S - 9

N = N + 4

WEND

PRINT(N)

s = 47

n = 1

while s > 0:

    s = s - 9

    n = n + 4

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 47;

    n := 1;

    while s > 0 do

    begin

        s := s - 9;

        n := n + 4

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 47

n := 1

нц пока s > 0

    s := s - 9

    n := n + 4

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s, n;

    s = 47;

    n = 1;

    while (s > 0) {

        s = s – 9;

        n = n + 4;

    }

    cout << n << endl;

}

 

3.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 42

N = 1

WHILE S > 0

S = S – 5

N = N + 3

WEND

PRINT(N)

s = 42

n = 1

while s > 0:

    s = s - 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 42;

    n := 1;

    while s > 0 do

    begin

        s := s – 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 42

n := 1

нц пока s > 0

    s := s — 5

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s, n;

    s = 42;

    n = 1;

    while (s > 0) {

        s = s – 5;

        n = n + 3;

    }

    cout << n << endl;

}

 

4.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 3

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 3

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 3;

    }

    cout « s « endl;

    return 0;

}

 

5.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

 N = 1

 S = 0

 WHILE N <= 300

    S = S + 30

    N = N * 3

 WEND

 PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

{

    s = s + 30;

    n = n * 3;

}

    cout « s « endl;

return 0;

}

 

6.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

    s = s - 10

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 301;

    n := 0;

    while s > 0 do

    begin

        s := s - 10;

        n := n + 2;

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 301

    n := 0

    нц пока s > 0

        s := s - 10

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 301, n = 0;

    while (s > 0) {

        s = s - 10;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

7.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 78

N = 0

WHILE N < 12

    S = S – 8

    N = N + 2

WEND

PRINT(S)

s = 78

n = 0

while n < 12:

    s = s - 8

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 78;

    n := 0;

    while n < 12 do

    begin

        s := s – 8;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 78

    n := 0

    нц пока n < 12

        s := s — 8

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 78;

    n = 0;

    while (n < 12) {

        s = s – 8;

        n = n + 2;

    }

    cout << s << endl;

}

 

8.

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 56

N = 0

WHILE n < 15

    S = S - 6

    N = N + 3

WEND

PRINT(S)

s = 56

n = 0

while n < 15:

    s = s - 6

    n = n + 3

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 56;

    n := 0;

    while n < 15 do

    begin

        s := s - 6;

        n := n + 3;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 56

    n := 0

    нц пока n < 15

        s := s - 6

        n := n + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 56;

    n = 0;

    while (n < 15) {

        s = s - 6;

        n = n + 3;

    }

    cout << s << endl;

}

 

9.

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 650

    S = S + 20

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 650:

    s = s + 20

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 650 do

    begin

        s := s + 20;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 650

        s := s + 20

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 650)

    {

        s = s + 20;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 

10.

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 300

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

    {

        s = s + 30;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 

11.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 

12.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 3*S < 111

   S = S + 8

   N = N + 2

WEND

PRINT N

s = 0

n = 0

while 3*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 3*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 3*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

  while (3*s < 111) { s = s + 8; n = n + 2; }

  cout << n << endl;

  return 0;

}

 

13.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S < 111

  S = S + 8

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (2*s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 

14.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 26

WHILE S <= 205

    S = S + 20

    N = N * 2

WEND

PRINT N

n = 1

s = 26

while s <= 205:

    s += 20

    n *= 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 26;

    while s <= 205 do

    begin

        s := s + 20;

        n := n * 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 1

    s := 26

    нц пока s <= 205

        s := s + 20

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 26;

    while (s <= 205) {

        s = s + 20;

        n = n * 2;

    }

    cout << n << endl;

    return 0;

}

 

15.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

    S = S + 7

    N = N + 1

WEND

PRINT S

n = 1

s = 0

while n <= 101:

    s += 7

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 101 do

    begin

        s := s + 7;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 101

        s := s + 7

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 0;

    while (n <= 101) {

        s = s + 7;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

16.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 6

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 1;

    s : = 6;

    while s <= 365 do

    begin

        s : = s + 36;

        n : = n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 6;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 1

s : = 6

нц пока s <= 365

    s : = s + 36

    n : = n * 2

кц

вывод n

кон

Python

n = 1

s = 6

while s <= 365:

    s += 36

    n *= 2

print(n)

 

17.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 2

S = 35

WHILE N <= 25

    S = S + 20

    N = N + 5

WEND

PRINT S

n = 2

s = 35

while n <= 25:

    s += 20

    n += 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 2;

    s := 35;

    while n <= 25 do

    begin

        s := s + 20;

        n := n + 5;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 2

    s := 35

    нц пока n <= 25

        s := s + 20

        n := n + 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 2, s = 35;

    while (n <= 25) {

        s = s + 20;

        n = n + 5;

    }

    cout << s << endl;

    return 0;

}

 

18.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 30

    S = 1

    WHILE S < 500

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n := 30;

    s := 1;

    while s < 500 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 1;

    while (s < 500)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 30

s : = 1

нц пока s < 500

    s := s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 30

s = 1

while s < 500:

    s *= 2

    n += 10

print(n)

 

19.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

    S = S + 20

    N = N + 2

WEND

PRINT S

n = 24

s = 0

while n <= 28:

    s += 20

    n += 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

        n := n + 2;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 24

    s := 0

    нц пока n <= 28

        s := s + 20

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 24, s = 0;

    while (n <= 28) {

        s = s + 20;

        n = n + 2;

    }

    cout << s << endl;

    return 0;

}

 

20.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 50

    S = 1

    WHILE S < 1000

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n : = 50;

    s := 1;

    while s < 1000 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 50;

    s = 1;

    while (s < 1000)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 50

s : = 1

нц пока s < 1000

    s : = s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 50

s = 1

while s < 1000:

    s *= 2

    n += 10

print(n)

 

21.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 128

N = N * 2

WEND

PRINT N

program B05;

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 128;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 128;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 128

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 128

    n *= 2

print(n)

 

22.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 256

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 256;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 256;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 256

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 256

    n *= 2

print(n)

 

23.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 2

N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 2;

        n := n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 2;

        n = n + 2;

    }

    cout << n << endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 2

    n := n + 2

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 2

    n += 2

print(n)

 

24.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 12

S = 5

WHILE N <= 25

    S = S + 12

    N = N + 2

WEND

PRINT S

n = 12

s = 5

while n <= 25:

    s += 12

    n += 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 12;

    s := 5;

    while n <= 25 do

    begin

        s := s + 12;

        n := n + 2;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 12

    s := 5

    нц пока n <= 25

        s := s + 12

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 12, s = 5;

    while (n <= 25) {

        s = s + 12;

        n = n + 2;

    }

    cout << s << endl;

    return 0;

}

 

25.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 3

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 3;

        n := n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 3;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 3

    n := n + 3

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 3

    n += 3

print(n)

 

26.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 512;

    while (s >= 0) {

        s = s - 20;

        n = n + 1;

    }

    cout << n << endl;

    return 0;

}

 

27.

Определите, что будет напечатано в результате выполнения программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 13:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 13

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 13) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

28.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 26

    S = S + 6

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 26:

    s += 6

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 26 do

    begin

        s := s + 6;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 26

        s := s + 6

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 26) {

        s = s + 6;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

29.

Определите, что будет напечатано в результате выполнения программы

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

30.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

S = S + 15

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

    n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 13)

    {

        s = s + 15;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 13

    s := s + 15

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 13:

    s += 15

    n += 1

print(s)

 

31.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 20

S = S + 33

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 20 do

    begin

        s := s + 33;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 20)

    {

        s = s + 33;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 20

    s := s + 33

    n := n + 1

кц

вывод s

кон

Python

n = 1

s = 0

while n <= 20:

    s += 33

    n += 1

print(s)

 

32.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + 15

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + 15;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + 15

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += 15

    n += 1

print(s)

 

33.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

S = S - 20

N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 512

нцпока s >= 0

    s := s - 20

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

 

34.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 14

S = 0

WHILE N <= 18

S = S + 25

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 14;

    s := 0;

    while n <= 18 do

    begin

        s := s + 25;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 14;

    s = 0;

    while (n <= 18)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 14

s := 0

нцпока n <= 18

    s := s + 25

    n := n + 1

кц

вывод s

кон

Python

n = 14

s = 0

while n <= 18:

    s += 25

    n += 1

print(s)

 

35.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

S = S + 20

N = N + 2

WEND

PRINT S

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

    n := n + 2

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 24;

    s = 0;

    while (n <= 28)

    {

        s = s + 20;

        n = n + 2;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 24

s := 0

нц пока n <= 28

    s := s + 20

    n := n + 2

кц

вывод s

кон

Python

n = 24

s = 0

while n <= 28:

    s += 20

    n += 2

print(s)

 

36.

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования:

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

S = S + 7

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n : = 1;

    s : = 0;

    while n <= 101 do

    begin

        s : = s + 7;

        n : = n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 101)

    {

        s = s + 7;

        n = n + 1;

    }

    cout << s << endl;

}

алг

нач

цел n, s

n : = 1

s : = 0

нц пока n <= 101

    s : = s + 7

    n : = n + 1

кц

вывод s

кон

Python

n = 1

s = 0

while n <= 101:

    s += 7

    n += 1

print(s)

 

37.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 35

    N = N + 1

    S = S + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 35 do

    begin

        n := n + 1;

        s := s + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 35)

    {

        n = n + 1;

        s = s + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 35

    n := n + 1

    s := s + 4

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 35:

    n += 1

    s += 4

print(n)

 

38.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

    n := n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

 

39.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 50

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 512 do

    begin

        s := s + 50;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0 ;

    s = 0 ;

    while (s <= 512)

    {

        s = s + 50;

        n = n + 1;

}

cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 512

    s := s + 50

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 512:

    s += 50

    n += 1

print(n)

 

40.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 256

    s : = s + 25

    n : = n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 256:

    s += 25

    n += 1

print(n)

 

41.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 33

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 365 do

    begin

        s : = s + 33;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 33;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 365

    s : = s + 33

    n : = n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 33

    n += 10

print(n)

 

42.

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 5

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 5

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 5;

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 5

print(n)

 

43.

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 10

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

    n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 10;

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 10

print(n)

 

44.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 30

S = 25

WHILE S < 425

S = S + 40

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 30;

    s : = 25;

    while s < 425 do

    begin

        s : = s + 40;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 25;

    while (s < 425)

    {

        s = s + 40;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 30

s : = 25

нц пока s < 425

    s : = s + 40

    n : = n + 10

кц

вывод n

кон

Python

n = 30

s = 25

while s < 425:

    s += 40

    n += 10

print(n)

 

45.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 60

S = 25

WHILE S < 365

S = S + 20

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 60;

    s : = 25;

    while s < 365 do

    begin

        s : = s + 20;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 60;

    s = 25;

    while (s < 365)

    {

        s = s + 20;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 60

s : = 25

нц пока s < 365

    s : = s + 20

    n : = n + 10

кц

вывод n

кон

Python

n = 60

s = 25

while s < 365:

    s += 20

    n += 10

print(n)

 

46.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s := s + 10

        n := n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

47.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

48.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 2;

    }

    cout « n « endl;

}

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 2

print(n)

 

49.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 325 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 325

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 325:

    s += 10

    n += 3

print(n)

 

50.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 25;

        n := n + 4;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 25

    n += 4

print(n)

 

51.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

52.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 25

    n += 2

print(n)

 

53.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 24

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 249 do

    begin

        s : = s + 24;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 24

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 24

    n += 3

print(n)

 

54.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 256

        s : = s + 25

        n : = n + 5

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 256:

    s += 25

    n += 5

print(n)

 

55.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 512 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 512)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 512

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 512:

    s += 25

    n += 4

print(n)

 

56.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 425

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 425 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 425)

    {

        s = s + 10;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 425

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 425:

    s += 10

    n += 2

print(n)

 

57.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 301

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 301;

    while s > 0 do

    begin

        s : = s - 10;

        n : = n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 301;

    while (s > 0)

    {

        s = s - 10;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 301

    нц пока s > 0

        s : = s - 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 301

while s > 0:

    s -= 10

    n += 2

print(n)

 

58.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S > 0

    S = S - 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 512;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 4;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s > 0)

    {

        s = s - 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 512

    нц пока s > 0

        s : = s - 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 512

while s > 0:

    s -= 25

    n += 4

print(n)

 

59.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 256

WHILE S > 0

    S = S - 25

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 256;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

void main()

{

    int n, s;

    n = 0;

    s = 256;

    while (s > 0)

    {

        s = s - 25;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 256

    нц пока s > 0

        s : = s - 25

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 256

while s > 0:

    s -= 25

    n += 3

print(n)

 

60.

Запишите число, которое будет напечатано в результате выполнения программы (для Вашего удобства программа представлена на четырёх языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 325 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write (n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

целn, s

n := 0

s := 0

нц пока s <= 325

    s := s + 10

    n := n + 3

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 325:

    s += 10

    n += 3

print(n)

 

61.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 7

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 7

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 7;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 7

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 7

print(n)

 

62.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 8

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 8

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 8;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 8

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 8

print(n)

 

63.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 267:

    s += 25

    n += 10

print(n)

 

64.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 20

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 20

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 20;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 20

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 267:

    s += 25

    n += 20

print(n)

 

65.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 10

S = 0

WHILE S <= 249

S = S + 24

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 10;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 10;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 10

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 3

кц

вывод n

кон

Python

n = 10

s = 0

while s <= 249:

    s += 24

    n += 3

print(n)

 

66.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 40

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 40;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 40;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 40

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

Python

n = 40

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

67.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 20

S = 0

WHILE S <= 257

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 20;

    s := 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 20;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 20

s := 0

нц пока s <= 257

    s := s + 10

    n := n + 3

кц

вывод n

кон

Python

n = 20

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

68.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

S = S + 24

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 24

    n += 10

print(n)

 

69.

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 15

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 15;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 15;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 15

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

Python

n = 15

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

70.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 37

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 37;

        n := n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 37;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 37

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 365:

    s += 37

    n *= 2

print(n)

 

71.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 36

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 365:

    s += 36

    n *= 2

print(n)

 

72.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 18

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 18;

        n := n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 18;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 18

    n := n + 5

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 18

    n += 5

print(n)

 

73.

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 12

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 12;

        n := n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 12;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 12

    n := n + 5

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 12

    n += 5

print(n)

 

74.

Определите число, которое будет напечатано в результате выполнения программы.

Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 70

WHILE S > 7

S = S – 7

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 70;

    while s > 7 do

    begin

        s := s – 7;

        i := i + 1

    end;

    writeln(i)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int i, s;

    i = 0;

    s = 70;

    while (s > 7)

    {

        s = s – 7;

        i++;

    }

    cout << i << endl ;

}

алг

нач

цел i, s

i := 0

s := 70

нц пока s > 7

    s := s - 7

    i := i + 1

кц

вывод i

кон

Python

i = 0

s = 70

while s > 7:

    s -= 7

    i += 1

print(i)

 

75.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 15

WHILE S <= 250

    S = S + 12

    N = N + 2

WEND

PRINT N

n = 4

s = 15

while s <= 250:

    s += 12

    n += 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 15;

    while s <= 250 do

    begin

        s := s + 12;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 4

    s := 15

    нц пока s <= 250

        s := s + 12

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 15;

    while (s <= 250) {

        s = s + 12;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

76.

Определите число, которое будет напечатано в результате выполнения программы.

Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 64

WHILE S > 8

S = S – 8

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 64;

    while s > 8 do

    begin

        s := s – 8;

        i := i + 1

    end;

    writeln(i)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int i, s;

    i = 0;

    s = 64;

    while (s > 8)

    {

        s = s – 8;

        i++;

    }

    cout << i << endl;

}

алг

нач

цел i, s

i := 0

s := 64

нц пока s > 8

    s := s - 8

    i := i + 1

кц

вывод i

кон

Python

i = 0

s = 64

while s > 8:

    s -= 8

    i += 1

print(i)

 

77.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 3

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 3;

  }

  cout << n << endl;

  return 0;

}

 

78.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 2;

  }

  cout << n << endl;

  return 0;

}

 

79.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 3

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 3;

  }

  cout << n << endl;

  return 0;

}

 

80.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 2;

  }

  cout « n « endl;

  return 0;

}

 

81.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S <= 65

S = S + 5

N = N + 3

WEND

PRINT N

s = 0

n = 0

while s <= 65:

    s = s + 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s <= 65 do

    begin

        s := s + 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел n, s

s := 0

n := 0

нц пока s <= 65

    s := s + 5

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 0;

    while (s <= 65)

    {

        s = s + 5;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

82.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 65

S = S + 6

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 65:

    s = s + 6

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s < 65 do

    begin

        s := s + 6;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

  цел n, s

  s := 0

  n := 0

  нц пока s < 65

    s := s + 6

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 0;

    while (s < 65)

    {

        s = s + 6;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

83.

Определите число, которое будет напечатано в результате выполнения программы, записанной ниже на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 251

  S = S + 25

  N = N + 1

WEND

PRINT N

n = 0

s = 0

while s <= 251:

    s = s + 25

    n = n + 1

print(n)

Алгоритмический языкПаскаль

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s <= 251

    s := s + 25

    n := n + 1

  кц

  вывод n

кон

var n, s: integer;

begin

  n := 0;

  s := 0;

  while s <= 251 do

  begin

    s := s + 25;

    n := n + 1

  end;

  write(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int n, s;

  n = 0;

  s = 0;

  while (s <= 251)

  {

    s = s + 25;

    n = n + 1;

  }

  cout « n « endl;

}

 

84.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 5

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 5

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 5

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 5

  end;

  writeln(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 5;

  }

  cout << n << endl;

  return 0;

}

 

85.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 2

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 2

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 2

  end;

  writeln(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 2;

  }

  cout << n << endl;

  return 0;

}

 

86.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

S = 0

N = 0

WHILE S < 165

    S = S + 15

    N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s += 15

    n += 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    s := 0;

    n := 0;

    while s < 165 do

    begin

        s := s + 15;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    s := 0

    n := 0

    нц пока s < 165

        s := s + 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 0;

    while (s < 165) {

        s = s + 15;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

87.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 150

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 150:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 150 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 150

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 150)

    {

        s = s + 30;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 

88.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 71

     S = S + 10

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 71:

    s = s + 10

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 71 do

begin

    s := s + 10;

    n := n + 3

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 71

    s := s + 10

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s < 71) { s = s + 10; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

89.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 99

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 99:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 99 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 99

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s*s < 99) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

90.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 101

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 101:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 101 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 101

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s*s < 101) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

91.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S <= 10*S

     S = S + 1

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s <= 10*s:

    s = s + 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s <= 10*s do

begin

    s := s + 1;

    n := n + 3;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s <= 10*s

    s := s + 1

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s <= 10*s) { s = s + 1; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

92.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 10*S

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 10*s:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s < 10*s do

begin

    s := s + 1;

    n := n + 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s < 10*s

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s < 10*s) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

93.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 150

     S = S + 15

     N = N*2

WEND

PRINT N

s = 0

n = 1

while s < 150:

    s = s + 15

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 1;

while s < 150 do

begin

    s = s + 15;

    n = n * 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока s < 150

    s = s + 15

    n = n * 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 1;

    while (s < 150) { s = s + 15; n = n * 2; }

    cout << n << endl;

    return 0;

}

 

94.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 165

  S = S + 15

  N = N * 2

WEND

PRINT N

s = 0

n = 1

while s < 165:

  s = s + 15

  n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 1;

  while s < 165 do

  begin

    s := s + 15;

    n := n * 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 1

  s := 0

  нц пока s < 165

    s = s + 15

    n = n * 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0;

  int n = 1;

  while (s < 165) {

    s = s + 15;

    n = n * 2;

  }

  cout << n << endl;

  return 0;

}

 

95.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 3

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

 

96.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 2

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

 

97.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 260

WHILE S > 0

    S = S - 15

    N = N + 2

WEND

PRINT N

n = 0

s = 260

while s > 0:

    s = s - 15

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 260;

    while s > 0 do

    begin

        s := s - 15;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 260

    нц пока s > 0

        s := s - 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 260;

    while (s > 0) {

        s = s - 15;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

98.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 3

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

99.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

100.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 22

N = 0

WHILE S < S*S

    S = S - 1

    N = N + 3

WEND

PRINT N

s = 22

n = 0

while s < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 22;

    n := 0;

    while s < s*s do begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    n := 0

    s := 22

    нц пока s < s*s

        s := s - 1;

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 22, n = 0;

    while (s < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

101.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 0

WHILE S < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while s < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while s < s*s do begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока s < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 0;

    while (s < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n;

    return 0;

}

 

102.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 1

WHILE N < 11

S = S - 1

N = N + 2

WEND

PRINT S

s = 25

n = 1

while n < 11:

    s = s - 1

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 1;

    while n < 11 do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 25

    n := 1

    нц пока n < 11

        s := s - 1

        n := n + 2

    кц

    вывод s

кон

С++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 1;

    while (n < 11) {

        s = s - 1;

        n = n + 2;

    }

    cout << s;

    return 0;

}

 

 

103.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 1

WHILE N < 21

S = S - 1

N = N + 2

WEND

PRINT S

s = 25

n = 1

while n < 21:

    s = s - 1

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 1;

    while n < 21 do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 25

    n := 1

    нц пока n < 21

        s := s - 1

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 1;

    while (n < 21) {

        s = s - 1;

        n = n + 2;

    }

    cout << s;

    return 0;

}

 

 

104.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 26

WHILE N > S

S = S + 1

N = N − 1

WEND

PRINT S

s = 0

n = 26

while n > s:

    s = s + 1

    n = n − 1

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 26;

    while n > s do

    begin

        s := s + 1;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 26

    нц пока n > s

        s := s + 1

        n := n − 1

    кц

    вывод s

кон

C++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 26;

    while (n > s) {

        s = s + 1;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 

105.

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 32

WHILE N > S

S = S + 1

N = N − 1

WEND

PRINT N

s = 0

n = 32

while n > s:

    s = s + 1

    n = n − 1

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 32;

    while n > s do

    begin

        s := s + 1;

        n := n − 1;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 0

    n := 32

    нц пока n > s

        s := s + 1

        n := n − 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 32;

    while (n > s) {

        s = s + 1;

        n = n − 1;

    }

    cout << n;

    return 0;

}