№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора Ф ИПИ Справка
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Посимвольная обработка десятичных чисел
1.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 = 0 THEN

    M = M + (X MOD 10) \ 2

ENDIF

X = X \ 10

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L += 1

    if x % 2 == 0:

        M = M + (x % 10) // 2

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 0 then

            M := M + (x mod 10) div 2;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 0

            то

                M := M + div(mod(x,10), 2)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 0){

            M = M + (x % 10) / 2;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

2.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает числа: a и b. Укажите наибольшее четырехзначное число x, при вводе которого алгоритм печатает сначала 5, а потом 7.

 

БейсикPython

DIM X, Y, A, B AS INTEGER

A = 10

B = 0

INPUT X

WHILE X > 0

    Y = X MOD 10

    X = X \ 10

    IF Y < A THEN A = Y

    IF Y > B THEN B = Y

WEND

PRINT A

PRINT B

a = 10

b = 0

x = int(input())

while x > 0:

    y = x % 10

    x = x // 10

    if y < a:

        a = y

    if y > b:

        b = y

print(a)

print(b)

ПаскальАлгоритмический язык

var x, y, a, b: integer;

begin

    a := 10;

    b := 0;

    readln(x);

    while x > 0 do

        begin

            y := x mod 10;

            x := x div 10;

            if y < a then

                a := y;

            if y > b then

                b := y;

        end;

writeln(a);

writeln(b)

end.

алг

нач

цел x, y, a, b

a := 10

b := 0

ввод x

нц пока x > 0

    y := mod(x, 10)

    x := div(x, 10)

    если y < a

        то a := y

    все

    если y > b

        то b := y

    все

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, y, a, b;

    a = 10;

    b = 0;

    cin >> x;

    while (x > 0)

    {

        y = x % 10;

        x = x / 10;

        if (y < a)

            a = y;

        if (y > b)

            b = y;

    }

    cout << a << endl << b << endl;

}

 

3.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает числа: a и b.

Укажите наименьшее положительное пятизначное число x, при котором после выполнения алгоритма будет напечатано сначала 4, а потом 2.

 

Бейсик Python

DIM X, Y, A, B AS INTEGER

A = 0

B = 0

INPUT X

WHILE X > 0

    Y = X MOD 10

    IF Y > 3 THEN A = A + 1

    IF Y < 8 THEN B = B + 1

    X = X \ 10

WEND

PRINT A

PRINT B

a = 0

b = 0

x = int(input())

while x > 0:

    y = x % 10

    if y > 3:

        a = a+1

    if y < 8:

        b = b+1

    x = x // 10

print(a)

print(b)

Алгоритмический языкПаскаль

алг

нач

    цел x, y, a, b

    a := 0

    b := 0

    ввод x

    нц пока x > 0

        y := mod(x, 10)

        если y > 3

            то a := a + 1

        все

        если y < 8

            то b := b + 1

        все

        x := div(x, 10)

    кц

    вывод a, нс, b

кон

var x, y, a, b: integer;

begin

    a := 0;

    b := 0;

    readln(x);

    while x > 0 do

    begin

        y := x mod 10;

        if y > 3 then

            a := a + 1;

        if y < 8 then

            b := b + 1;

        x := x div 10

    end;

    writeln(a);

    writeln(b)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, y, a, b;

    a = 0;

    b = 0;

    cin >> x;

    while (x > 0)

    {

        y = x % 10;

        if (y > 3)

            a = a + 1;

        if (y < 8)

            b = b + 1;

        x = x / 10;

    }

    cout << a << endl << b << endl;

}

 

4.

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 48, а потом 6.

 

БейсикПаскаль

DIM X, A, B, C AS INTEGER

INPUT X

A = 1: B = 0

WHILE X > 0

  C = X MOD 10

  A = A * C

  IF C > B THEN B = C

  X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b, c: integer;

begin

  readln(x);

  a := 1; b := 0;

  while x>0 do

  begin

    c := x mod 10;

    a := a*c;

    if c>b then b := c;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

Си++Алгоритмический язык

 

#include <iostream>

using namespace std;

int main()

{

  int x, a, b, c;

  cin >> x;

  a = 1; b = 0;

  while (x>0) {

    c = x%10;

    a = a*c;

    if (c>b)

      b = c;

    x = x/10;

  }

  cout << a << endl << b << endl;

}

алг

нач

  цел x, a, b, c

  ввод x

  a := 1; b := 0

  нц пока x>0

    c := mod(x,10)

    a := a*c

    если c>b

      то b := c

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Python

x = int(input())

a = 1

b = 0

while x > 0:

    c = x % 10

    a = a*c

    if c > b:

        b = c

    x //= 10

print(a)

print(b)

 

5.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает числа: a и b. Укажите наименьшее положительное пятизначное число x, при вводе которого алгоритм печатает сначала 6, а потом 3.

 

БейсикPython

DIM X, Y, A, B AS INTEGER

A = 0

B = 10

INPUT X

WHILE X > 0

    Y = X MOD 10

    X = X \ 10

    IF Y > A THEN A = Y

    IF Y < B THEN B = Y

WEND

PRINT A

PRINT B

a = 0

b = 10

x = int(input())

while x > 0:

    y = x % 10

    x = x // 10

    if y > a:

        a = y

    if y < b:

        b = y

print(a)

print(b)

ПаскальАлгоритмический язык

var x, y, a, b: longint;

begin

    a := 0;

    b := 10;

    readln(x);

    while x > 0 do

        begin

            y := x mod 10;

            x := x div 10

            if y > a then

                    a := y;

            if y < b then

                    b := y;

        end;

writeln(a);

writeln(b)

end.

алг

нач

цел x, y, a, b

a := 0

b := 10

ввод x

нц пока x > 0

y := mod(x, 10)

x := div(x, 10)

если y > a

то a := y

все

если y < b

то b := y

все

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, y, a, b;

    a = 0;

    b = 10;

    cin >> x;

    while (x > 0)

    {

        y = x % 10;

        x = x / 10;

        if (y > a)

            a = y;

        if (y < b)

            b = y;

    }

    cout << a << endl << b << endl;

}

 

6.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 0.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 = 0 THEN

    M = M + x mod 10

x = x \ 10

ENDIF

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L += 1

    if x % 2 == 0:

        M = M + x % 10

    x //= 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 0 then

            M := M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 0

            то

                M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 0){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

7.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x AND x mod 2 = 0 THEN

     M = x mod 10

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x and x % 2 == 0:

        M = x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if (M < x) and (x mod 2 = 0) then

            M:=x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x и mod(x,2) = 0 то

            M := mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x && x % 2 == 0){

            M = x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

8.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 72.

 

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B * (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b : integer;

begin

readln(x);

a := 0; b := 1;

while x > 0 do

    begin

        a := a + 1;

        b := b * (x mod 10);

        x := x div 10;

    end;

writeln(a); write(b);

end.

Си++ Алгоритмический
#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a + 1;

        b = b *(x%10);

        x= x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 1

нц пока x > 0

    a := a+1

    b := b * mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

 

9.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF x mod 2 = 1 THEN

     M = M + (x mod 10) \ 2

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if x % 2 == 1:

        M = M + (x % 10) // 2

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if (x mod 2 = 1) then

            M:= M + (x mod 10) div 2;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 1 то

            M := M + div(mod(x,10), 2)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 1){

            M = M + (x % 10) / 2;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

10.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x THEN

     M = M + (x mod 10) * 2

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x:

        M = M + (x % 10) * 2

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if M < x then

            M:= M + (x mod 10) * 2;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x то

            M := M + mod(x,10) * 2

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x){

            M = M + (x % 10) * 2;

        }

        x = x / 10;

    }

    cout << L << endl << M << endl;

}

 

11.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF x mod 2 = 0 THEN

     M = M + x mod 10

ENDIF

x = x \ 10

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if x % 2 == 0:

        M = M + x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 0 then

            M:= M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 0 то

            M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 0){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M << endl;

}

 

12.

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF M < x THEN

     M = x mod 10

ENDIF

x = x \ 10

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L = L + 1

    if M < x:

        M = x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if M < x then

            M:= x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если M < x то

            M := mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(M < x){

            M = x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M endl;

}

 

13.

Ниже на 4-х языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6, а потом 9.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 2

    B = B + (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            a := a + 2;

            b := b + (x mod 10);

            x:= x div 10;

        end;

    writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a + 2;

        b = b + (x%10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

    a := a + 2

    b := b+mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 2

    b += (x % 10)

    x //= 10

print(a)

print(b)

 

14.

Ниже на четырёх языках записан алгоритм. Получив на вход число , этот алгоритм печатает два числа: и . Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 2, а потом 3. Допускается диапазон значений для величин целого типа: от −231 до 231 — 1.

 

БейсикПаскаль

DIM X, А, В, С AS INTEGER

INPUT X

А = 0: В = 0

WHILE X > 0

    С = X MOD 2

    IF C = 0 THEN

        A = A + 1

    ELSE

        B = B + 1

    END IF

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            с := x mod 2;

            if c = 0 then

                a := a + 1

            else

                b := b + 1

            x := x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0) {

        с = x % 2;

        if (c == 0) a = a + 1;

        else b = b + 1;

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b, с

ввод X

а := 0; b := 0

нц пока х>0

    с := mod(х, 2)

    если с = 0

        то a := a + 1

    иначе b := b + 1

все

х := div(х, 10)

кц

вывод а, не, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    с = x % 2

    if c == 0:

        a += 1

    else:

        b += 1

    x //= 10

print(a)

print(b)

 

15.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 11, а потом 5.

 

 

БейсикПаскаль

DIM X, А, В, С AS INTEGER

INPUT X

А = 0: В = 10

WHILE X > 0

    С = X MOD 10

    А = А + С

    IF С < В THEN В = С

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 10;

    while x>0 do

        begin

            с := x mod 10;

            a := a+c;

            if c < b then b := c;

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0;

    b = 10;

    while (x > 0) {

        с = x%10;

        a = a+c;

        if (c < b)

            b = c;

        x = x /10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b, с

ввод X

а := 0; b := 10

нц пока х>0

    с := mod(х, 10)

    а := а+с

    если с < b

        то b := с

все

х := div(х, 10)

кц

вывод а, не, b

кон

Python

x = int(input())

a = 0

b = 10

while x > 0:

    с = x % 10

    a += c

    if c < b:

        b = c

    x //= 10

print(a)

print(b)

 

16.

Ниже на 4-х языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 10.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

    A = A+1

    B = B +(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=0;

    while x>0 do

        begin

            a:=a + 1;

            b:=b + (x mod 10);

            x:=x div 10;

        end;

writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=0;

    while (x>0){

        a = a+1;

        b = b +(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x>0

    a:=a+1

    b:=b+mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b += x % 10

    x = x // 10

print(a)

print(b)

17.

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 13, а потом 5.

 

БейсикПаскаль

DIM X, A, B, C AS INTEGER

INPUT X

A = 0: B = 10

WHILE X > 0

    C = X MOD 10

    A = A + C

    IF C < B THEN B = C

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b, c: integer;

begin

    readln(x);

    a := 0; b := 10;

    while x>0 do

        begin

            c := x mod 10;

            a := a+c;

            if c < b then b := c;

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0; b = 10;

    while (x>0) {

        c = x%10;

        a = a+c;

        if (c<b)

            b = c;

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b, c

ввод x

a := 0; b := 10

нц пока x>0

    c := mod(x,10)

    a := a+c

    если c<b

        то b := c

    все

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 10

while x > 0:

    с = x % 10

    a += c

    if c < b:

        b = c

    x //= 10

print(a)

print(b)

 

18.

Ниже на четырёх языках записан алгоритм. Получив на вход число , этот алгоритм печатает два числа: и . Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 2. Допускается диапазон значений для величин целого типа: от −231 до 231 — 1.

 

БейсикПаскаль

DIM X, A, B, C AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    C = X MOD 2

    IF C = 0 THEN

        A = A + 1

    ELSE

        B = B + 1

    END IF

    X = X / 10

WEND

PRINT A

PRINT B

var a, b, c: integer;

x: LongInt;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

    begin

        c := x mod 2;

        if c = 0 then

            a := a + 1

        else

            b := b + 1;

        x := x div 10;

    end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

 

int main()

{

    int x, a, b, c;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        c = x%2;

        if (c == 0) a = a + 1;

        else b = b + 1;

        x = x / 10;

    }

    cout << a << endl << b << endl;

}

 

 

алг

нач

цел x, a, b, c

ввод x

a := 0; b := 0

нц пока x > 0

    c := mod(x, 2)

    если c = 0

    то a := a + 1

    иначе b := b + 1

все

x := div(x, 10)

кц

вывод а, нс b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    c = x % 2

    if c == 0:

        a += 1

    else:

        b += 1

    x = x // 10

print(a)

print(b)

 

19.

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает

сначала 3, а потом 25.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 1

    IF (X MOD 2) <> 0 THEN

        B = B+(X MOD 10)

    END IF

    X = X\10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

        begin

            a := a + 1;

            if(x mod 2) <> 0 then

                b := b+(x mod 10);

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a+1;

        if ((x%2)!=0){

            b = b+(x%10);

        }

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 0

нц пока x > 0

    a := a+1

    если mod(x,2) <> 0 то

        b := b+mod(x,10)

    все

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    if (x % 2) != 0:

        b += (x % 10)

    x //= 10

print(a)

print(b)

 

20.

Ниже записана программа. Получив на вход число , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 8.

 

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

L = L + 1

IF X MOD 2 = 1 THEN

    M = M + X MOD 10

ENDIF

X = X \ 10

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    L += 1

    if x % 2 == 1:

        M = M + x % 10

    x = x // 10

print(L)

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := 0;

    M := 0;

    while x > 0 do

    begin

        L := L + 1;

        if x mod 2 = 1 then

            M := M + x mod 10;

        x := x div 10;

    end;

    writeln(L);

    writeln(M);

end.

алг

нач

    цел x, L, M

    ввод x

    L := 0

    M := 0

    нц пока x > 0

        L := L + 1

        если mod(x,2) = 1

            то

                M := M + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод L, нс, M

кон

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = 0;

    M = 0;

    while (x > 0){

        L = L + 1;

        if(x % 2 == 1){

            M = M + x % 10;

        }

        x = x / 10;

    }

    cout << L << endl << M << endl;

}

 

21.

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 1

    IF (X MOD 2) <> 0 THEN

        B = B+(X MOD 10)

    END IF

    X = X\10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

        begin

            a := a + 1;

            if(x mod 2) <> 0 then

                b := b+(x mod 10);

            x := x div 10;

        end;

writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a+1;

        if ((x%2)!=0){

            b = b+(x%10);

        }

        x = x/10;

    }

cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 0

нц пока x > 0

    a := a+1

    если mod(x,2) <> 0 то

        b := b+mod(x,10)

    все

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    if x % 2 != 0:

         b += x % 10

    x = x // 10

print(a)

print(b)

 

22.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 20.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF (X MOD 2) = 0 THEN

    B = B+(X MOD 10)

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a=a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a)

print(b)

ПаскальАлгоритмический язык

program B20;

var x, a, b: integer;

begin

  readln(x);

  a:= 0; b:= 0;

  while x > 0 do

  begin

    a:= a + 1;

    if x mod 2 = 0 then

      b:= b+ x mod 10;

    x:=x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0 то

      b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b+x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b << endl;

  return 0;

}

 

23.

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 18.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF (X MOD 2) = 0 THEN

    B = B+(X MOD 10)

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a=a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a)

print(b)

ПаскальАлгоритмический язык

program B20;

var x, a, b: integer;

begin

  readln(x);

  a := 0; b := 0;

  while x > 0 do

  begin

    a := a + 1;

    if x mod 2 = 0 then

      b := b+ x mod 10;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0 то

      b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b+x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b endl;

  return 0;

}

 

24.

Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 16. Если таких чисел x несколько, укажите наименьшее из них.

 

БейсикPython

DIM X,D,R AS LONG

INPUT X

R = 0

WHILE X>0

    D = X MOD 10

    R = 10*R + D

    X = X \ 10

WEND

PRINT R

x = int(input())

R = 0

while x>0:

    d = x % 10

    R = 10*R + d

    x = x // 10

print(R)

ПаскальАлгоритмический язык

var

    x,d,R: longint;

begin

    readln(x);

    R := 0;

    while x>0 do

        begin

            d := x mod 10;

            R := 10*R + d;

            x := x div 10

        end;

    writeln(R)

end.

алг

нач

    цел x, d, R

    ввод x

    R := 0

    нц пока x>0

        d := mod(x, 10)

        R := 10*R + d

        x := div(x, 10)

    кц

    вывод R

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    long x,d,R;

    cin >> x;

    R = 0;

    while (x>0)

        {

            d = x % 10;

            R = 10*R + d;

            x = x / 10;

        }

    cout << R << endl;

    return 0;

}

 

25.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 14.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0

B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

   B = B + X MOD 10

   END IF

   X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0; b = 0

while x > 0:

  a = a + 1

  if (x % 2 ==0):

    b += x%10

  x=x / / 10

print(a, b)

ПаскальАлгоритмический язык

program b20;

var x, a, b: integer;

begin

    readln(x);

    a := 0

    b := 0;

    while x > 0 do

    begin

      a := a + 1;

      if x mod 2 = 0 then

         b := b + x mod 10;

       x := x div 10;

    end;

    writeln(a);

    write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0

    b := 0

    нц пока x > 0

        a := a + 1

        если mod(x,2)=0 то

          b := b + mod(x,10)

         все

         x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0){

        a = a + 1;

         if (x%2 == 0) {

           b = b+x%10;

        }

        x = x / 10

      }

    cout << a << endl << b endl;

    return 0;

}

 

26.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 16

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0

B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

   B = B + X MOD 10

   END IF

   X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0; b = 0

while x > 0:

  a = a + 1

  if (x % 2 ==0):

    b += x%10

  x=x / / 10

print(a, b)

ПаскальАлгоритмический язык

program b20;

var x, a, b: integer;

begin

    readln(x);

    a := 0

    b := 0;

    while x > 0 do

    begin

      a := a + 1;

      if x mod 2 = 0 then

         b := b + x mod 10;

       x := x div 10;

    end;

    writeln(a);

    write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0

    b := 0

    нц пока x > 0

        a := a + 1

        если mod(x,2)=0 то

          b := b + mod(x,10)

         все

         x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 0;

    while (x > 0){

        a = a + 1;

         if (x%2 == 0) {

           b = b+x%10;

        }

        x = x / 10

      }

    cout << a << endl << b << endl;

    return 0;

}

 

27.

Ниже на различных языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 24?

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

A = A + 1

B = B*(X MOD 10)

X = X\10

WEND

PRINT A

PRINT B

x=int(input())

a=0; b=1

while x>0:

    a=a+1

    b=b*(x%10)

    x=x//10

print(a,"\n",b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

     while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 10);

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x,10)

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a+1;

        b = b*(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

    return 0;

}

 

28.

Ниже на различных языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Сколько существует таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 0?

 

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

A = A + 1

B = B*(X MOD 10)

X = X\10

WEND

PRINT A

PRINT B

x=int(input())

a=0; b=1

while x>0:

    a=a+1

    b=b*(x%10)

    x=x//10

print(a,"\n",b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

     while x > 0 do

    begin

        a := a+1;

        b := b*(x mod 10);

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 1

    нц пока x > 0

        a := a+1

        b := b*mod(x,10)

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a+1;

        b = b*(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

    return 0;

}

 

29.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 12.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

    B = B + X MOD 10

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a = a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a, b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

  readln(x);

  a := 0; b := 0;

  while x > 0 do

  begin

    a := a + 1;

    if x mod 2= 0 then

      b := b + x mod 10;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0

      то b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b + x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b << endl;

  return 0;

}

 

30.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 14.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

  A = A + 1

  IF X MOD 2 = 0 THEN

    B = B + X MOD 10

  END IF

  X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x>0:

  a = a+1

  if x%2==0:

    b += x%10

  x = x//10

print(a, b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

  readln(x);

  a := 0; b := 0;

  while x > 0 do

  begin

    a := a + 1;

    if x mod 2= 0 then

      b := b + x mod 10;

    x := x div 10;

  end;

  writeln(a); write(b);

end.

алг

нач

  цел x, a, b

  ввод x

  a := 0; b := 0

  нц пока x > 0

    a := a+1

    если mod(x,2)=0

      то b := b + mod(x,10)

    все

    x := div(x,10)

  кц

  вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, a, b;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    a = a+1;

    if (x%2 == 0) {

      b = b + x%10;

    }

    x = x / 10;

  }

  cout << a << endl << b << endl;

  return 0;

}

 

31.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 4.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 10

    END IF

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%10

    x = x//10

print(a, b)

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

    begin

        if x mod 2= 0 then

            a := a + 1

        else

            b := b + x mod 10;

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0) a += 1;

        else b += x%10;

        x = x / 10;

    }

    cout << a << endl << b << endl;

    return 0;

}

 

32.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 4.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    IF X MOD 2 = 0 THEN

        A = A + 1

    ELSE

        B = B + X MOD 10

    END IF

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a=0; b=0

while x > 0:

    if x%2 == 0:

        a += 1

    else:

        b += x%10

    x = x//10

print(a, b)

ПаскальАлгоритмический язык

var x, a, b: longint;

begin

    readln(x);

    a := 0; b := 0;

    while x > 0 do

    begin

        if x mod 2= 0 then

            a := a + 1

        else

            b := b + x mod 10;

        x := x div 10;

    end;

    writeln(a); write(b);

end.

алг

нач

    цел x, a, b

    ввод x

    a := 0; b := 0

    нц пока x > 0

        если mod(x,2)=0

            то a := a+1

            иначе b := b + mod(x,10)

        все

        x := div(x,10)

    кц

    вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0) {

        if (x%2 == 0) a += 1;

        else b += x%10;

        x = x / 10;

    }

    cout << a << endl << b << endl;

    return 0;

}