≡ информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 8 № 7692

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 200

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 200:

    s = s + 30

    n = n * 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

n := 1;

s := 0;

while n <= 200 do

begin

s := s + 30;

n := n * 2

end;

write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 200

s := s + 30

n := n * 2

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int n, s;

n = 1;

s = 0;

while (n <= 200)

{

s = s + 30;

n = n * 2;

}

cout « s « endl;

}