СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Каталог заданий
Версия для печати и копирования в MS Word
1
Задания Д 19 № 3806

В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

z = A(n)

FOR i = 0 TO n

    IF A(i) > z THEN s = s + 1

NEXT i

s: = 0;

z: = A[n];

for i: = 0 to n do

    begin

        if A[i] > z then

            s: = s + 1;

    end

Си++Алгоритмический язык
s = 0;

z = A[n];

for (i = 0; i <= n; i++){

    if (A[i] > z)

        s++;

}

s: = 0

z: = A[n]

нц для i от 0 до n

если A[i] > z то

    s: = s + 1

все

кц

Python

s = 0

z = A[n]

for i in range(0, n+1):

    if A[i] > z:

        s = s + 1;

 

 

 

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

 

1) Минимальному элементу в массиве A

2) Количеству элементов массива A, больших последнего элемента массива

3) Индексу последнего элемента массива А, который меньше A[0]

4) Количеству элементов массива A, меньших последнего элемента массива


Аналоги к заданию № 3806: 4583 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.