СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 19 № 3360

Значения элементов двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR n = 1 TO 100

    A(n) = n - 50

NEXT n

FOR n = 1 TO 100

    B(101-n) = A(n)*A(n);

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 50

for n in range(1, 101):

    B[101-n] = A[n]*A[n]

ПаскальАлгоритмический язык

 

for n : = 1 to 100

    do A[n] : = n - 50;

for n : = 1 to 100 do begin

    B[101-n]:= A[n]*A[n];

end;

 

нц для n от 1 до 100

    A[n] : = n - 50

кц

нц для n от 1 до 100

    B[101-n]:=A[n]*A[n]

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 50;

}

for (n = 1; n <= 100; n++) {

    B[101-n] = A[n]*A[n];

}

 

 

Какой элемент массива B будет наименьшим?

 

1) B[1]

2) B[50]

3) B[51]

4) B[100]


Аналоги к заданию № 3358: 3360 Все

Решение · Прототип задания · ·