≡ информатика
сайты - меню - вход - новости




Каталог заданий
Сумма двух линейных функций

Пройти тестирование по 10 заданиям
Пройти тестирование по всем заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 15624

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 170

WHILE S + N < 325

    S = S + 25

    N = N - 5

WEND

PRINT S

s = 0

n = 170

while s + n < 325:

    s = s + 25

    n = n - 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 170;

while s + n < 325 do

begin

    s := s + 25;

    n := n - 5

end;

writeln(s)

end.

алг

нач

    цел n, s

    s := 0

    n := 170

    нц пока s + n < 325

        s := s + 25

        n := n - 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

int s = 0, n = 170;

while (s + n < 325) {

    s = s + 25;

    n = n - 5;

}

cout << s << endl;

return 0;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

2
Задание 8 № 15848

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

 DIM S, N AS INTEGER

 S = 150

 N = 0

 WHILE S + N < 300

     S = S − 5

     N = N + 25

 WEND

 PRINT N

s = 150

n = 0

while s + n < 300:

    s = s − 5

    n = n + 25

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 150;

n := 0;

while s + n < 300 do

begin

    s := s − 5;

    n := n + 25

end;

writeln(n)

end.

алг

нач

    цел n, s

    s := 150

    n := 0

    нц пока s + n < 300

        s := s − 5

        n := n + 25

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

int s = 150, n = 0;

while (s + n < 300) {

    s = s − 5;

    n = n + 25;

}

cout << n << endl;

return 0;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

3
Задание 8 № 15976

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 80

N = 0

WHILE S + N < 150

S = S − 5

N = N + 15

WEND

PRINT N

s = 80

n = 0

while s + n < 150:

    s = s − 5

    n = n + 15

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 80;

    n := 0;

    while s + n < 150 do

    begin

        s := s − 5;

        n := n + 15;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 80

    n := 0

    нц пока s + n < 150

        s := s − 5

        n := n + 15

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 80, n = 0;

    while (s + n < 150) {

        s = s − 5;

        n = n + 15;

    }

    cout << n;

    return 0;

}

 

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна, вариант А. Имаева — «Котолис».

4
Задание 8 № 16035

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 0

N = 75

WHILE S + N < 150

    S = S + 15

    N = N − 5

WEND

PRINT N

s = 0

n = 75

while s + n < 150:

    s = s + 15

    n = n − 5

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    s := 0;

    n := 75;

    while s + n < 150 do

    begin

        s := s + 15;

        n := n − 5;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    s := 0

    n := 75

    нц пока s + n < 150

        s := s + 15

        n := n − 5

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    s = 0, n = 75;

    while (s + n < 150) {

        s = s + 15;

        n = n − 5;

    }

    cout << n << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2019 по информатике.

5
Задание 8 № 16383

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 40

WHILE S + N < 100

S = S + 20

N = N − 5

WEND

PRINT S

s = 0

n = 40

while s + n < 100:

    s = s + 20

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 40;

    while s + n < 100 do

    begin

        s := s + 20;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 40

    нц пока s + n < 100

        s := s + 20

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 40;

    while (s + n < 100) {

        s = s + 20;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


6
Задание 8 № 16437

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 40

WHILE S + N < 100

S = S + 25

N = N − 5

WEND

PRINT S

s = 0

n = 40

while s + n < 100:

    s = s + 25

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 40;

    while s + n < 100 do

    begin

        s := s + 25;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 40

    нц пока s + n < 100

        s := s + 25

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 40;

    while (s + n < 100) {

        s = s + 25;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


7
Задание 8 № 16811

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 20

WHILE S + N <= 100

S = S + 25

N = N − 5

WEND

PRINT S

s = 0

n = 20

while s + n <= 100:

    s = s + 25

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 20;

    while s + n <= 100 do

    begin

        s := s + 25;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 20

    нц пока s + n <= 100

        s := s + 25

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 20;

    while (s + n <= 100) {

        s = s + 25;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


8
Задание 8 № 16884

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 25

WHILE S + N <= 100

S = S + 20

N = N − 5

WEND

PRINT S

s = 0

n = 25

while s + n <= 100:

    s = s + 20

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 25;

    while s + n <= 100 do

    begin

        s := s + 20;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 25

    нц пока s + n <= 100

        s := s + 20

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 25;

    while (s + n <= 100) {

        s = s + 20;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


9
Задание 8 № 17326

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 100

N = 300

WHILE S + N <= 500

S = S + 30

N = N − 20

WEND

PRINT S

s = 100

n = 300

while s + n <= 500:

    s = s + 30

    n = n − 20

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 100;

    n := 300;

    while s + n <= 500 do

    begin

        s := s + 30;

        n := n − 20;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 100

    n := 300

    нц пока s + n <= 500

        s := s + 30

        n := n − 20

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 100, n = 300;

    while (s + n <= 500) {

        s = s + 30;

        n = n − 20;

    }

    cout << s;

    return 0;

}

 

 


Пройти тестирование по этим заданиям