СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий
Условие выполнения цикла while

Пройти тестирование по 10 заданиям
Пройти тестирование по всем заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 2001

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2001: 2004 Все


2
Задание 8 № 2002

За­пи­ши­те зна­че­ние пе­ре­мен­ной а после вы­пол­не­ния фраг­мен­та ал­го­рит­ма:

 

*При­ме­ча­ние: зна­ком := обо­зна­че­на опе­ра­ция при­сва­и­ва­ния. В бланк от­ве­тов впи­ши­те толь­ко число.


Аналоги к заданию № 2002: 2003 2005 Все


3
Задание 8 № 2006

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2006: 2007 Все


4
Задание 8 № 2008

Запишите значение переменной b после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


5
Задание 8 № 2010

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


6
Задание 8 № 3243

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 80

    S = S + 2*K

    K = K + 4

WEND

PRINT S

s = 0

k = 0

while s < 80:

    s += 2*k

    k += 4

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 80 do begin

            s:=s+2*k;

            k:=k+4;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 80

        s := s + 2*k

        k := k + 4

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 80) {

        s = s + 2*k;

        k = k + 4;

    }

    cout << s << endl;

    return 0;

}

 


7
Задание 8 № 9643

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 20

b = 15

b = 3 * b - a

IF a > b THEN

c = 2 * a + b

ELSE

c = 2 * a - b

END IF

a := 20;

b := 15;

b := 3 * b - a;

if a > b then

c := 2 * a + b

else

c := 2 * a - b;

Си++Алгоритмический язык

a = 20;

b = 15;

b = 3 * b - a;

if (a > b)

c = 2 * a + b;

else

c = 2 * a - b;

a := 20

b := 15

b := 3 * b - a

если a > b

то c := 2 * a + b

иначе c := 2 * a - b

все

Python

a = 20

b = 15

b = 3 * b - a

if a > b:

    c = 2 * a + b

else:

    c = 2 * a - b

 


8
Задание 8 № 9689

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 17

b = 20

a = 3 * a - b

IF a > b THEN

  c = 5 * a - b

ELSE

  c = 5 * a + b

END IF

a := 17;

b := 20;

a := 3 * a - b;

if a > b then

  c := 5 * a - b

else

  c := 5 * a + b;

Си++Алгоритмический язык

a = 17;

b = 20;

a = 3 * a - b;

if (a > b)

  c = 5 * a - b;

else

  c = 5 * a + b;

a := 17

b := 20

a := 3 * a - b

если a > b

  то c := 5 * a - b

  иначе c := 5 * a + b

все

Python

a = 17

b = 20

a = 3 * a - b

if a > b:

    c = 5 * a - b

else:

    c = 5 * a + b

 


9
Задание 8 № 3253

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 12

    S = S + 2*K

    K = K + 3

WEND

PRINT S

s = 0

k = 0

while k < 12:

    s += 2*k

    k += 3

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 12 do begin

            s:=s+2*k;

            k:=k+3;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 12

        s := s + 2*k

        k := k + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 12) {

        s = s + 2*k;

        k = k + 3;

    }

    cout << s << endl;

    return 0;

}

 


10
Задание 8 № 3240

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 1

K = 0

WHILE K < 13

    S = S + 2 * K

    K = K + 4

WEND

PRINT K+S

s = 1

k = 0

while k < 13:

    s += 2*k

    k += 4

print(k+s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=1;

       k:=0;

      while k < 13 do begin

            s:=s+2*k;

             k:=k+4;

       end;

      write(s+k);

end.

алг

нач

    цел k, s

    s := 1

    k := 0

    нц пока k < 13

        s := s + 2 * k

        k := k + 4

    кц

    вывод s+k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 1, k = 0;

    while (k < 13) {

        s = s + 2 * k;

        k = k + 4;

    }

    cout << s+k << endl;

    return 0;

}

 


11
Задание 8 № 17372

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 100

N = 300

WHILE S + N <= 600

S = S + 40

N = N − 20

WEND

PRINT S

s = 100

n = 300

while s + n <= 600:

    s = s + 40

    n = n − 20

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 100;

    n := 300;

    while s + n <= 600 do

    begin

        s := s + 40;

        n := n − 20;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 100

    n := 300

    нц пока s + n <= 600

        s := s + 40

        n := n − 20

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 100, n = 300;

    while (s + n <= 600) {

        s = s + 40;

        n = n − 20;

    }

    cout << s;

    return 0;

}

 

 


12
Задание 8 № 18077

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM K, S AS INTEGER

S = 230

K = 0

WHILE S > 0

    S = S – 15

    K = K + 2

WEND

PRINT K

s = 230

k = 0

while s > 0:

    s = s − 15

    k = k + 2

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

    s:=230;

    k:=0;

    while s > 0 do begin

        s := s – 15;

        k := k + 2;

    end;

    write(k);

end.

алг

нач

    цел s, k

    s := 230

    k := 0

    нц пока s > 0

        s := s − 15

        k := k + 2

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

 

int main() {

    int s , k;

    s = 230;

    k = 0;

    while(s > 0){

        s = s − 15;

        k = k + 2;

    }

    cout << k << endl;

}

 

 

Источник: ЕГЭ — 2019. До­сроч­ная волна. Вариант 1.

13
Задание 8 № 18436

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM N, S AS INTEGER

S = 230

N = 0

WHILE S > 0

    S = S – 15

    N = N + 2

WEND

PRINT N

s = 230

n = 0

while s > 0:

    s = s − 15

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    s:=230;

    n:=0;

    while s > 0 do begin

        s := s – 15;

        n := n + 2;

    end;

    write(n);

end.

алг

нач

    цел s, n

    s := 230

    n := 0

    нц пока s > 0

        s := s − 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

 

int main() {

    int s = 230, n = 0;

    while(s > 0) { s = s - 15; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

 

Источник: ЕГЭ — 2019. До­сроч­ная волна. Вариант 2.

14
Задание 8 № 18489

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 300

N = 100

WHILE S - N >= 100

    S = S + 20

    N = N + 30

WEND

PRINT S

s = 300

n = 100

while s - n >= 100:

    s = s + 20

    n = n + 30

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 300;

    n := 100;

    while s - n >= 100 do

    begin

        s := s + 20;

        n := n + 30

    end;

writeln(s)

end.

алг

нач

    цел s, n

    s := 300

    n := 100

    нц пока s - n >= 100

        s := s + 20

        n := n + 30

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 300, n = 100;

    while (s - n >= 100) {

        s = s + 20;

        n = n + 30;

    }

    cout << s;

    return 0;

}

 

 


Аналоги к заданию № 18489: 18620 Все


15
Задание 8 № 18556

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 500

N = 200

WHILE S \ N >= 2

    S = S + 5

    N = N + 5

WEND

PRINT S

s = 500

n = 200

while s // n >= 2:

    s = s + 5

    n = n + 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 500;

    n := 200;

    while s div n >= 2 do begin

        s := s + 5;

        n := n + 5

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 500

    n := 200

    нц пока div(s,n) >= 2

        s := s + 5

        n := n + 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 500, n = 200;

    while (s / n >= 2) {

        s = s + 5;

        n = n + 5;

    }

    cout << s;

    return 0;

}

 

 


16
Задание 8 № 18584

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 300

N = 100

WHILE S \ N >= 2

    S = S + 5

    N = N + 5

WEND

PRINT S

s = 300

n = 100

while s // n >= 2:

    s = s + 5

    n = n + 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 300;

    n := 100;

    while s div n >= 2 do begin

        s := s + 5;

        n := n + 5

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 300

    n := 100

    нц пока div(s,n) >= 2

        s := s + 5

        n := n + 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 300, n = 100;

    while (s / n >= 2) {

        s = s + 5;

        n = n + 5;

    }

    cout << s;

    return 0;

}

 

 


17
Задание 8 № 18710

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 76

WHILE S < 71

S = S + 10

N = N − 2

WEND

PRINT N

s = 0

n = 76

while s < 71:

    s = s + 10

    n = n − 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 76;

    while s < 71 do

    begin

        s := s + 10;

        n := n − 2;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 0

    n := 76

    нц пока s < 71

        s := s + 10

        n := n − 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 76;

    while (s < 71) {

        s = s + 10;

        n = n − 2;

    }

    cout << n;

    return 0;

}

 

 

Источник: ЕГЭ по информатике 13.06.2019. Основная волна, Восток. Вариант Имаева-Зубовой — «Котолис».

18
Задание 8 № 18787

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 100

S = S + 20

N = N * 3

WEND

PRINT N

s = 0

n = 1

while s < 100:

    s = s + 20

    n = n * 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 1;

    while s < 100 do

    begin

        s := s + 20;

        n := n * 3;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 0

    n := 1

    нц пока s < 100

        s := s + 20

        n := n * 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 1;

    while (s < 100) {

        s = s + 20;

        n = n * 3;

    }

    cout << n;

    return 0;

}

 

 

Источник: ЕГЭ по информатике 13.06.2019. Основная волна, Центр. Вариант Имаева-Зубовой — «Котолис».

19
Задание 8 № 18814

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S*S <= 125

     S = S + 3

     N = N * 2

WEND

PRINT N

s = 0

n = 1

while s*s <= 125:

    s = s + 3

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 1;

while s*s <= 125 do

begin

    s := s + 3;

    n := n * 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока s*s <= 125

    s := s + 3

    n := n * 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 1;

    while (s*s <= 125) { s = s + 3; n = n * 2; }

    cout << n << endl;

    return 0;

}

Источник: ЕГЭ по информатике 13.06.2019. Основная волна, Юг-Центр.

20
Задание 8 № 19057

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 51

    S = S + 11

    N = N * 2

WEND

PRINT N

s = 0

n = 1

while s < 51:

    s = s + 11

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 1;

    while s < 51 do

    begin

        s := s + 11;

        n := n * 2

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 0

    n := 1

    нц пока s < 51

        s := s + 11

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 1;

    while (s < 51) { s = s + 11; n = n * 2; }

    cout << n << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2020 по информатике.

Пройти тестирование по этим заданиям