СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Варианты заданий

Алгебраические операции с элементами массива, двумерные массивы

Версия для печати и копирования в MS Word
1
Задания Д 19 № 3354

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

A(0) = 1

FOR i = 1 TO 10

    A(i) = 2 + A[i-1]

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(i)-1

NEXT i

 

A[0] = 1

for i in range(1, 11):

    A[i] = 2 + A[i-1]

for i in range(0, 6):

    A[10-i] = A[i]-1

ПаскальАлгоритмический язык

A[0] : = 1;

for i : = 1 to 10

    do A[i] : = 2 + A[i-1];

for i : = 0 to 5 do begin

    A[10-i] : = A[i] - 1;

end;

A[0] : = 1

нц для i от 1 до 10

    A[i] : = 2 + A[i-1]

кц

нц для i от 0 до 5

    A[10-i] : = A[i] - 1

кц

 

Си++

A[0] = 1;

for (i = 1; i <= 10; i++) {

    A[i] = 2+A[i-1];

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[i]-1;

}

 

 

Чему будут равны элементы этого массива?

 

1) 1 3 5 7 9 10 8 6 4 2 0

2) 1 3 5 7 9 11 13 15 17 19 21

3) 1 3 5 7 9 11 9 7 5 3 1

4) 1 3 5 7 9 11 8 6 4 3 0


2
Задания Д 19 № 3364

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 0 TO 10

    A(i) = 2 + i

NEXT i

FOR i = 0 TO 4

    A(i) = A(10-i) - 1

    A(10-i) = A(i) + 3

NEXT i

 

 

for i in range(0, 11):

    A[i] = 2 + i

for i in range(0, 5):

    A[i] = A[10-i] - 1

    A[10-i] = A[i] + 3

ПаскальАлгоритмический язык

 

for i : = 0 to 10

    do A[i] : = 2 + i;

for i : = 0 to 4 do begin

    A[i]:= A[10-i]-1;

    A[10-i]:= A[i]+3;

end;

 

нц для i от 0 до 10

    A[i] : = 2 + i

кц

нц для i от 0 до 4

    A[i]:=A[10-i]-1

    A[10-i]:=A[i]+3

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 2 + i;

}

for (i = 0; i <= 4; i++) {

    A[i] = A[10-i] - 1;

    A[10-i] = A[i]+3;

}

 

 

Чему будут равны элементы этого массива?

 

1) 11 10 9 8 7 5 6 7 8 9

2) 11 10 9 8 7 7 5 6 7 8 9

3) 11 10 9 8 7 7 10 11 12 13 14

4) 11 10 9 8 7 10 11 12 13 14


3
Задания Д 19 № 3366

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 1 TO 10

    A(i) = 3*i

NEXT i

FOR i = 1 TO 10

    A(i) = A(i) MOD 3;

NEXT i

 

 

for i in range(0, 11):

    A[i] = 3*i

for i in range(1, 11):

    A[i] = A[i] % 3

ПаскальАлгоритмический язык

 

for i : = 1 to 10

    do A[i] : = 3*i;

for i : = 1 to 10 do begin

    A[i]:= A[i] mod 3;

end;

 

нц для i от 1 до 10

    A[i] : = 3*i

кц

нц для i от 1 до 10

    A[i]:= mod(A[i], 3)

кц

 

Си++

 

for (i = 1; i <= 10; i++) {

    A[i] = 3*i;

}

for (i = 1; i <= 10; i++) {

    A[i] = A[i] % 3;

}

 

 

Чему будут равны элементы этого массива?

 

1) Все элементы будут равны 3.

2) Все элементы будут равны 1.

3) Все элементы будут равны 0.

4) Все элементы будут равны своим индексам.


4
Задания Д 19 № 7264

Значения элементов двумерного массива А были равны 0. Затем значения некоторых элементов были изменены (см. представленный фрагмент программы):

 

 

БейсикPython

n = 0

FOR i = 1 TO 5

    FOR j = 1 TO 6-i

        n = n + 1

        A(i,j) = n

    NEXT j

NEXT i

 

n = 0

for i in range(1, 6):

    for j in range(1, 7-i):

        n += 1

        A[i,j] = n

ПаскальАлгоритмический язык

n:=0;

for i:=1 to 5 do

    for j:=1 to 6-i do begin

        n := n + 1;

        A[i,j] := n;

    end;

n:=0

нц для i от 1 до 5

    нц для j от 1 до 6-i

        n := n + 1

        A[i,j] := n

    кц

кц

 

Си++

n = 0;

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 6-i; j++) {

        n += 1;

        A[i][j] = n;

    }

}

 

 

Какой элемент массива будет иметь в результате максимальное значение?

 

1) A[1,1]

2) A[1,5]

3) A[5,1]

4) A[5,5]


5
Задания Д 19 № 3372

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

n = 100

FOR i = 1 TO n

    A(i)=(i-75)*(i-75)

NEXT i

FOR i = 1 TO n

    B(101-i)=A(i)

NEXT i

 

n = 100

for i in range(1, n+1):

     A[i]=(i-75)*(i-75)

for i in range(1, n+1):

    B[101-i]=A[i]

ПаскальАлгоритмический язык

n:=100;

for i : = 1 to n

    do A[i]:=(i-75)*(i-75);

for i : = 1 to n do begin

    B[101-i]:=A[i];

end;

n:=100

нц для i от 1 до n

    A[i]:=(i-75)*(i-75)

кц

нц для i от 1 до n

    B[101-i]:=A[i]

кц

 

Си++

n = 100;

for (i = 1; i <= n; i++) {

    A[i]=(i-75)*(i-75);

}

for (i = 1; i <= n; i++) {

    B[101-i]=A[i];

}

 

 

Какой элемент массива B будет наибольшим?

 

1) B[1]

2) B[26]

3) B[75]

4) B[100]


6
Задания Д 19 № 3379

Элементы двухмерного массива A размером NxN первоначально были равны 1000. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

k = 0

FOR i = 1 TO N

    FOR j = N-i+1 TO N

        k += 1

        A(i,j) = k

    NEXT j

NEXT i

 

k = 0

for i in range(1, n+1):

    for j in range(n-i+1, n+1):

        k = k + 1

        A[i,j] = k

 

ПаскальАлгоритмический язык

k := 0;

for i:= 1 to n do

    for j:=N-i+1 to n do begin

        k:= k + 1;

        A[i,j]:= k;

    end;

k := 0

нц для i от 1 до n

    нц для j от n-i+1 до n

        k:= k + 1

        A[i,j]:= k

    кц

кц

Си++

k = 0;

for (i = 1; i <= n; i++) {

    for (j = n-i+1; j <= n; j++) {

        k = k + 1;

        A[i][j] = k;

    }

}

 

 

Какой элемент массива в результате будет иметь минимальное значение?

 

1) A[1,1]

2) A[1,N]

3) A[N,1]

4) A[N,N]


7
Задания Д 19 № 3388

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 0 TO 10

    A(i) = 2*i

NEXT i

FOR i = 0 TO 4

    A(10-i) = A(i) - 1;

    A(i) = A(10-i) - 1;

NEXT i

 

 

for i in range(0, 11):

    A[i] = 2*i

for i in range(0, 5):

    A[10-i] = A[i] - 1

    A[i] = A[10-i] - 1

ПаскальАлгоритмический язык

 

for i : = 0 to 10

    do A[i] : = 2*i;

for i : = 0 to 4 do begin

    A[10-i]:= A[i] - 1;

    A[i] : = A[10-i]-1;

end;

 

нц для i от 0 до 10

    A[i] : = 2*i

кц

нц для i от 0 до 4

    A[10-i]:= A[i] - 1

    A[i]:= A[10-i] - 1

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 2*i;

}

for (i = 0; n <= 4; i++) {

    A[10-i] = A[i] - 1;

    A[i] = A[10-i] - 1;

}

 

 

Чему будут равны элементы этого массива?

 

1) 0 2 4 6 8 10 12 14 16 18 20

2) 19 17 15 13 11 10 -1 1 3 5 7

3) -2 0 2 4 6 10 7 5 3 1 -1

4) -1 1 3 5 7 9 11 13 15 17 19


8
Задания Д 19 № 3838

В программе описан одномерный целочисленный массив с индексами от 0 до n (т.е. первый элемент имеет индекс 0, последний - индекс n). Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

 

БейсикПаскаль

s = n

z = A(0)

FOR i = 1 TO n

    IF A(i) = z THEN s = s - 1

NEXT i

s: = n;

z: = A[0];

for i: = 1 to n do

begin

    if A[i] = z then

        s: = s - 1;

end

Си++Алгоритмический язык

s = n;

z = A[0];

for (i = 1; i <= n; i++){

    if (A[i] == z)

        s--;

}

s: = n

z: = A[0]

нц для i от 1 до n

если A[i] = z то

    s: = s - 1

все кц

Python

s = n

z = A[0]

for i in range(1, n+1):

    if A[i] == z:

        s: -= 1

 

 

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

 

1) Количеству элементов массива A, больших первого элемента массива

2) Количеству элементов массива A, не превосходящих первого элемента массива

3) Количеству элементов массива A, не равных первому элементу массива

4) Количеству элементов массива A, равных первому элементу массива

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.

9
Задания Д 19 № 5050

В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

n = 10

FOR i = 1 TO n

    A (n+1-i) = 2*A(i)

NEXT i

 

n = 10

for i in range(1, n+1):

        A [n+1-i] = 2*A[i]

ПаскальАлгоритмический язык

n:= 10;

for i:=1 to n do

        A [n+1-i] := 2*A[i];

n:= 10

нц для i от 1 до n

        A [n+1-i] := 2*A[i]

кц

 

Си++

n = 10;

for (i = 1; i <= n; i++) {

        A [n+1-i] = 2*A[i];

}

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, т.е. А[1] = 1; А[2] = 2 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы имеет два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) такого значения нет

2) 10

3) 8

4) 4


10
Задания Д 19 № 5082

В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

n = 10

FOR i = 1 TO n

    A (n+1-i) = 2*A(i)

NEXT i

 

n = 10

for i in range(1, n+1):

        A [n+1-i] = 2*A[i]

ПаскальАлгоритмический язык

n:= 10;

for i:=1 to n do

        A [n+1-i] := 2*A[i];

n:= 10

нц для i от 1 до n

        A [n+1-i] := 2*A[i]

кц

 

Си++

n = 10;

for (i = 1; i <= n; i++) {

        A [n+1-i] = 2*A[i];

}

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[1] = 2; А[2] = 4 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) 8

2) 16

3) 20

4) такого значения нет


11
Задания Д 19 № 5206

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

    s = A(n + 1 - i) * (n + 1 - i)

    A(n + 1 - i) = A(i) * (n + 1 - i)

    A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

    s : = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] : = A[i] * (n + 1 - i);

    A[i] : = s;

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

    s = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] = A[i] * (n + 1 - i);

    A[i] = s;

}

n : = 10

нц для i от 1 до n

    s := A[n+1-i]*(n+1-i)

    A[n+1-i] := A[i]*(n+1-i)

    A[i] := s

кц

Python

n = 10

for i in range(1, n+1):

    s = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] = A[i] * (n + 1 - i);

    A[i] = s;

 

 

Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет верно после выполнения указанного фрагмента программы при изменении индекса от 1 до 10.

 

1) значения массива постоянны

2) значения массива сначала возрастают, а потом убывают

3) значения массива возрастают

4) значения массива убывают


12
Задания Д 19 № 5238

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

s = A(n + 1 - i) * i

A(n + 1 - i) = A(i) * i

A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

s : = A[n + 1 - i] * i;

A[n + 1 - i] : = A[i] * i;

A[i] : = s;

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

s = A[n + 1 - i] * i;

A[n + 1 - i] = A[i] * i;

A[i] = s;

}

n : = 10

нц для i от 1 до n

s : = A[n + 1 - i] * i

A[n + 1 - i] : = A[i] * i

A[i] : = s

кц

Python

n = 10

for i in range(1, n+1):

    s = A[n + 1 - i] * i

    A[n + 1 - i] = A[i] * i

    A[i] = s

 

 

Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет верно после выполнения указанного фрагмента программы при изменении индекса от 1 до 10.

 

1) значения массива возрастают

2) значения массива убывают

3) значения массива постоянны

4) значения массива сначала возрастают, а потом убывают


13
Задания Д 19 № 5271

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

А (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++) {

A [n+1-i] = 2*A[i];

}

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

Python

n = 10

for i in range(1, n+1):

    A [n+1-i] = 2*A[i]

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наименьшее из них.

 

1) такого значения нет

2) 2

3) 8

4) 4


14
Задания Д 19 № 5303

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

A (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++) {

A [n+1-i] = 2*A[i];

}

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

Python

n = 10

for i in range(1, n+1):

    A [n+1-i] = 2*A[i]

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) такого значения нет

2) 8

3) 32

4) 128

Пояснение · ·

15
Задания Д 19 № 6452

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям индексов от 1 до n.

 

БейсикПаскаль

FOR i = 1 TO n

    c = A(i,i)

    A(i,i) = A(i,n–i+1)

    A(i,n–i+1) = c

NEXT i

for i := 1 to n do

begin

    c := A[i,i];

    A[i,i] := A[i,n–i+1];

    A[i,n–i+1] := c

end;

Си++Алгоритмический язык

for (i = 1; i <= n; i++) {

    c = A[i][i];

    A[i][i] = A[i][n-i+1];

    A[i][n-i+1] = c;

}

нц для i от 1 до n

    c := A[i,i]

    A[i,i] := A[i,n–i+1]

    A[i,n–i+1] := c

кц

Python

for i in range(1, n+1):

    c = A[i,i]

    A[i,i] = A[i,n–i+1]

    A[i,n–i+1] = c

 

 

Представим рассмотренный фрагмент массива в виде квадратной таблицы, в которой для элемента массива A[i, j] величина i является номером строки, а величина j — номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

 

1) два столбца в таблице

2) две строки в таблице

3) элементы двух диагоналей таблицы

4) элементы диагонали и строки таблицы

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 603.

16
Задания Д 19 № 6494

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A целочисленный двумерный. В программе рассмотрен фрагмент массива, соответствующий значениям индексов от 1 до n; n >= 3.

 

БейсикПаскаль

FOR i = n TO 1 STEP -1

    FOR j = n TO 1 STEP -1

        A(i,j) = i-j

    NEXT j

NEXT i

for i := n downto 1 do

    for j := n downto 1 do

        A[i,j] := i-j;

Си++Алгоритмический язык

for (i = n; i >= 1; i--) {

    for (j = n; j >= 1; j--) {

        A[i][j] = i-j;

    }

}

нц для i от n до 1 шаг -1

    нц для j от n до 1 шаг -1

        A[i,j] := i-j

    кц

кц

Python

for i in range(n, 0, -1):

    for j in range(n, 0, -1):

        A[i,j] = i-j

 

 

Чему будет равно максимальное из значений элементов рассмотренного фрагмента массива посе выполнения фрагмента программы?

 

1) n – 1

2) 1– n

3) n

4) 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.

Алгоритмы с использованием условного оператора

Версия для печати и копирования в MS Word
1
Задания Д 19 № 3361

Дан фрагмент программы, обрабатывающий массив А из 10 элементов:

 

 

Бейсик Python

j = 1

FOR i = 1 TO 10

    IF A(i) = A(j) THEN

        j = i

    ENDIF

NEXT i

s = j

j = 1

for i in range(1, 11):

    if A[i] == A[j]:

        j = i

s = j

Алгоритмический язык Паскаль

j := 1

нц для i от 1 до 10

    если A[i] = A[j] то

        j := i

    все

кц

s := j

j := 1;

for i := 1 to 10 do

    if A[i] = A[j] then j := i;

s := j;

Си++

j = 1;

for (i = 1; i <= 10; i++)

    if (A[i] == A[j])

    {

        j = i;

    }

s = j;

 

Чему будет равно значение переменной s после выполнения этого алгоритма?

 

1) 1

2) 10

3) индексу элемента, равного первому, и имеющему наибольший индекс

4) индексу элемента, равного последнему, и имеющему наименьший индекс


2
Задания Д 19 № 3363

Дан фрагмент программы, обрабатывающий двухмерный массив A размером nxn.

 

 

БейсикPython

FOR i = 1 TO n-1

    FOR j = i+1 TO n

        IF A[i,1] < A[j,1] THEN

            k=A(i,1)

            A(i,1)=A(j,1)

            A(j,1)=k

    NEXT j

NEXT i

for i in range(1, n):

    for j in range(i+1, n+1):

        if A[i,1] < A[j,1]:

            k=A[i,1]

            A[i,1]=A[j,1]

            A[j,1]=k

ПаскальАлгоритмический язык

for i:= 1 to n-1 do

    for j:=i+1 to n do

        if A[i,1] < A[j,1] then begin

            k:=A[i,1];

            A[i,1]:=A[j,1];

            A[j,1]:=k;

        end;

нц для i от 1 до n-1

    нц для j от i+1 до n

        если A[i,1] < A[j,1] то

            k:=A[i,1]

            A[i,1]:=A[j,1]

            A[j,1]:=k

    кц

кц

Си++

for (i = 1; i <= n-1; i++) {

    for (j = i+1; j <= n; j++) {

        if (A[i][1] < A[j][1]){

            k=A[i][1];

            A[i][1]=A[j][1];

            A[j][1]=k;

        }

    }

}

 

 

В этом фрагменте:

 

1) упорядочивается первая строка массива по убыванию

2) упорядочивается первый столбец массива по убыванию

3) заменяются элементы k-ого столбца таблицы

4) заменяются элементы k-ой строки таблицы


3
Задания Д 19 № 3380

В программе описан одномерный целочисленный массив A с индексами от 1 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 1 TO 10

    A(i) = 5*i

NEXT i

FOR i = 1 TO 10

    k = A(i) - 2

    A(10-i+1) = k

NEXT i

 

 

for i in range(1, 11):

    A[i] = 5*i

for i in range(1, 11):

    k = A[i]-2

    A[10-i+1]=k

ПаскальАлгоритмический язык

 

for i : = 1 to 10

    do A[i] : = 5*i;

for i : = 1 to 10 do begin

    k:=A[i]-2;

    A[10-i+1]:=k;

end;

 

нц для i от 1 до 10

    A[i] : = 5*i

кц

нц для i от 1 до 10

    k:=A[i]-2

    A[10-i+1]:=k

кц

 

Си++

 

for (i = 1; i <= 10; i++) {

    A[i] = 5*i;

}

for (i = 1; i <= 10; i++) {

    k=A[i]-2;

    A[10-i+1]=k;

}

 

 

 

Чему будут равны элементы этого массива?

 

1) 1 6 11 16 21 23 18 13 8 3

2) 3 8 13 18 23 28 33 38 43 48

3) 48 43 38 33 28 23 18 13 8 3

4) 1 6 11 16 21 26 31 36 41 46


4
Задания Д 19 № 3806

В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

z = A(n)

FOR i = 0 TO n

    IF A(i) > z THEN s = s + 1

NEXT i

s: = 0;

z: = A[n];

for i: = 0 to n do

    begin

        if A[i] > z then

            s: = s + 1;

    end

Си++Алгоритмический язык
s = 0;

z = A[n];

for (i = 0; i <= n; i++){

    if (A[i] > z)

        s++;

}

s: = 0

z: = A[n]

нц для i от 0 до n

если A[i] > z то

    s: = s + 1

все

кц

Python

s = 0

z = A[n]

for i in range(0, n+1):

    if A[i] > z:

        s = s + 1;

 

 

 

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

 

1) Минимальному элементу в массиве A

2) Количеству элементов массива A, больших последнего элемента массива

3) Индексу последнего элемента массива А, который меньше A[0]

4) Количеству элементов массива A, меньших последнего элемента массива


Аналоги к заданию № 3806: 4583 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.

5
Задания Д 19 № 5997

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

 

БейсикПаскаль

J = 1

FOR I = 1 TO n

    IF A(I) < A(J) THEN J =I NEXT I

s = J

j :=1;

for i: = 1 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

Си++Алгоритмический язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]) {

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

    если A[i] < A[j] то

        j := i

    все

кц

s := j

Python

j = 1

for i in range(1, n+1):

    if A[i] < A[j]:

        j = i

s = j

 

 

Чему будет равно значение переменной s после выполнения данного фрагмента программы?

 

1) минимальному элементу в массиве A

2) индексу минимального элемента в массиве A (наименьшему из таких индексов, если минимальных элементов несколько)

3) индексу минимального элемента в массиве A (наибольшему из таких индексов, если минимальных элементов несколько)

4) количеству элементов, равных минимальному в массиве A

Источник: Демонстрационная версия ЕГЭ—2014 по информатике.

6
Задания Д 19 № 5355

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

 

Массив А одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

Бейсик

Паскаль

J = 1

FOR I = 1 to n

    IF A(I) < A(J) THEN J = I

NEXT I

s = J

j := 1;

for i := 1 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

Си++

Алгоритмический язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]){

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

если A[i] < A[j] то

    j := i

все

кц

s := j

Python

j = 1

for i in range(1, n+1):

    if A[i] < A[j]:

        j = i

s = j

 

 

Чему будет равно значение переменной s после выполнения данного фрагмента программы?

 

1) индексу минимального элемента в массиве А (наименьшему из таких индексов, если минимальных элементов несколько)

2) минимальному элементу в массиве А

3) количеству элементов, равных минимальному в массиве А

4) индексу минимального элемента в массиве А (наибольшему из таких индексов, если минимальных элементов несколько)

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 1.

7
Задания Д 19 № 6570

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

БейсикПаскаль

s = 0

FOR i = 1 TO n

    IF A(i)<0 THEN s = s – A(i)

NEXT i

s := 0;

for i := 1 to n do

    begin

        if A[i]<0 then

            s := s – A[i]

    end;

Си++Алгоритмический язык

s = 0;

for (i = 1; i <= n; i++) {

    if (A[i] < 0) {

        s = s - A[i];

    }

}

s := 0

нц для i от 1 до n

    если A[i]<0 то

        s := s – A[i]

все

кц

Python

s = 0

for i in range(1, n+1):

    if A[i]<0:

        s = s - A[i]

 

 

Чему будет равно значение переменной s после выполнения данного фрагмента программы?

 

1) модулю суммы всех отрицательных элементов массива A

2) количеству отрицательных элементов в массиве A

3) сумме всех отрицательных элементов массива A

4) среднему арифметическому всех отрицательных элементов в массиве A

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.

Алгоритмы, меняющие элементы массива местами

Версия для печати и копирования в MS Word
1
Задания Д 19 № 3355

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(i)

   A(i) = A(10 - i)

   A(10 - i) = k

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[i]

    A[i] = A[10 - i]

    A[10 - i] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[i];

    A[i] : = A[10-i];

    A[10-i] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

        k : = A[i];

        A[i] : = A[10-i];

        A[10-i] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[i];

    A[i] = A[10-i];

    A[10-i] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


Аналоги к заданию № 3355: 3386 Все


2
Задания Д 19 № 3356

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 1 TO 11

    A(i - 1) = A(11 - i)

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(1, 12):

    A[i - 1] = A[11 - i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do

    A[i] : = i;

for i : = 1 to 11 do

    A[i-1] : = A[11-i];

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 1 до 11

        A[i-1] := A[11-i]

кц

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 1; i <= 11; i++) {

     A[i-1] = A[11-i];

}

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 10 9 8 7 6 5 6 7 8 9 10

4) 11 10 9 8 7 6 7 8 9 10 11

Пояснение · ·

3
Задания Д 19 № 3362

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(2*i)

    A(2*i) = A(2*i+1)

    A(2*i+1) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[2*i]

    A[2*i] = A[2*i+1]

    A[2*i+1] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[2*i];

    A[2*i] : = A[2*i+1];

    A[2*i+1] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[2*i];

        A[2*i] : = A[2*i+1];

        A[2*i+1] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[2*i];

    A[2*i] = A[2*i+1];

    A[2*i+1] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


4
Задания Д 19 № 3371

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 10 TO 1 STEP -1

    A(i-1) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i-1

for i in range(10, 0, -1):

    A[i-1] = A[i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=10 downto 1 do

    A[i-1]:=A[i];

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 10 до 1 шаг -1

    A[i-1]: = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 10; i <= 1; i--) {

    A[i-1] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 9 9 9 9 9 9 9 9 9 9

2) 0 1 2 3 4 5 6 7 8 9 9

3) 0 1 2 3 4 5 6 7 8 9 10

4) -1 -1 0 1 2 3 4 5 6 7 8


5
Задания Д 19 № 3382

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(10-i)

    A(10-i) = A(i)

    k = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[10-i]

    A[10-i] = A[i]

    k = A[i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[10-i];

    A[10-i] : = A[i];

    k : = A[i];

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[10-i];

        A[10-i] : = A[i];

    k : = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[10-i];

    A[10-i] = A[i];

    k = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


6
Задания Д 19 № 3370

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленная переменная i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 9

    A(i) = A(i+1)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 10):

    A[i] = A[i+1]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i;

for i:=0 to 9 do

    A[i]:=A[i+1];

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 9

    A[i]: = A[i+1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 9; i++) {

    A[i] = A[i+1];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 0 1 2 3 4 5 6 7 8 9

2) 1 2 3 4 5 6 7 8 9 10 10

3) 0 0 1 2 3 4 5 6 7 8 9

4) 1 2 3 4 5 6 7 8 9 10 0


7
Задания Д 19 № 3376

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i+1

NEXT i

FOR i = 0 TO 10

    A(i) = A(10-i)

NEXT i

 

for i in range(0, 11):

    A[i] = i+1

for i in range(0, 11):

    A[i] = A[10-i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i+1;

for i:=0 to 10 do

    A[i]:=A[10-i];

нц для i от 0 до 10

    A[i] : = i+1

кц

нц для i от 0 до 10

    A[i]: = A[10-i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i+1;

}

for (i = 0; i <= 10; i++) {

    A[i] = A[10-i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 11 10 9 8 7 6 7 8 9 10 11

4) 10 9 8 7 6 5 6 7 8 9 10


8
Задания Д 19 № 3384

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(i)

    A(i) = A(i+5)

    A(i+5) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[i]

    A[i] = A[i+5]

    A[i+5] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[i];

    A[i] : = A[i+5];

    A[i+5]: = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[i];

    A[i] : = A[i+5];

    A[i+5]: = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[i];

    A[i] = A[i+5];

    A[i+5] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


9
Задания Д 19 № 3359

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i+1

NEXT i

FOR i = 1 TO 10

    A(i) = A(i-1)

NEXT i

 

for i in range(0, 11):

    A[i] = i+1

for i in range(1, 11):

    A[i] = A[i-1]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i+1;

for i:=1 to 10 do

    A[i]:=A[i-1];

нц для i от 0 до 10

    A[i] : = i+1

кц

нц для i от 1 до 10

    A[i]: = A[i-1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i+1;

}

for (i = 1; i <= 10; i++) {

    A[i] = A[i-1];

}

 

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, сдвигаются на 1 элемент вправо

2) все элементы, кроме первого, сдвигаются на 1 элемент влево

3) все элементы окажутся равны 1

4) все элементы окажутся равны своим индексам


10
Задания Д 19 № 3381

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = 10

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = 10

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=1 to 10 do

    A[i-1]:=A[i];

A[10] := 10;

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 1 до 10

    A[i-1]: = A[i];

кц

A[10]: = 10;

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

 

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, сдвигаются на один элемент вправо

4) все элементы, кроме последнего, уменьшаются на единицу


11
Задания Д 19 № 3383

В программе обрабатывается двумерный целочисленный массив A [0..n,0..n]. Первый индекс элемента обозначает номер строки, а второй – номер столбца. Дан фрагмент программы:

 

 

БейсикPython

FOR i = 0 TO n

    c = A(i,n-i)

    A(i,n-i) = A(1,i)

    A(1,i) = c

NEXT i

 

for i in range(0, n+1):

    c = A[i,n-i]

    A[i,n-i] = A[1,i]

    A[1,i] = c

ПаскальАлгоритмический язык

 

for i:=0 to n do begin

    c:=A[i,n-i];

    A[i,n-i]:=A[1,i];

    A[1,i]:=c;

end;

 

нц для i от 0 до n

    c:=A[i,n-i]

    A[i,n-i]:=A[1,i]

    A[1,i]:=c

кц

Си++

 

for (i = 0; i <= n; i++) {

    c= A[i][n-i];

    A[i][n-i]= A[1][i];

    A[1][i]= c;

}

 

 

Что меняет этот фрагмент программы?

 

1) два столбца в таблице

2) строку и столбец в таблице

3) элементы диагонали и строки в таблице

4) элементы диагонали и столбца в таблице


12
Задания Д 19 № 3387

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = 10-i

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(5-i)

    A(5+i) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = 10-i

for i in range(0, 6):

    A[10-i] = A[5-i]

    A[5+i] = A[i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do

    A[i] : = 10-i;

for i : = 0 to 5 do begin

    A[10-i] : = A[5-i];

    A[5+i]: = A[i];

end;

нц для i от 0 до 10

    A[i] : = 10-i

кц

нц для i от 0 до 5

    A[10-i] : = A[5-i];

    A[5+i] : = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 10-i;

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[5-i];

    A[5+i] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 8 7 6 5 10 9 8 7 6 10

2) 10 9 8 7 6 5 6 7 8 9 10

3) 10 9 8 7 6 10 9 8 7 6 10

4) 5 6 7 8 9 10 9 8 7 6 5


13
Задания Д 19 № 3389

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

    t = A(0)

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = t

 

for i in range(0, 11):

    A[i] = i

    t = A[0]

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = t

ПаскальАлгоритмический язык

for i : = 0 to 10

    do A[i] : = i;

    t : = A[0];

for i : = 1 to 10 do begin

    A[i-1] : = A[i];

end;

A[10] : = t;

нц для i от 0 до 10

    A[i] : = i

    t : = A[0]

кц

нц для i от 1 до 10

    A[i-1] : = A[i];

кц

A[10] : = t;

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

    t = A[0];

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = t;

 

 

Чему будут равны элементы этого массива?

 

1) 10 10 10 10 10 10 10 10 10 10

2) 1 2 3 4 5 6 7 8 9 10 0

3) 0 0 0 0 0 0 0 0 0 0

4) 1 2 3 4 5 6 7 8 9 10 1


14
Задания Д 19 № 3392

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(9-i)

    A(i) = A(i+1)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 6):

    A[10-i] = A[9-i]

    A[i] = A[i+1]

ПаскальАлгоритмический язык

for i : = 0 to 10

    do A[i] : = i;

for i : = 0 to 5 do begin

    A[10-i] : = A[9-i];

    A[i] : = A[i+1];

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 5

    A[10-i] : = A[9-i];

    A[i] : = A[i+1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[9-i];

    A[i] = A[i+1];

}

 

 

Чему будут равны элементы этого массива?

 

1) 0 1 2 3 4 5 6 7 8 9 10

2) 0 1 2 3 4 5 6 7 8 9 9

3) 1 2 3 4 5 5 5 6 7 8 9

4) 1 2 3 4 5 6 5 4 3 2 1


15
Задания Д 19 № 4551

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикПаскаль

FOR i=0 TO 10

    A(i)=i-1

NEXT i

FOR i=1 TO 10

    A(i-1)=A(i)

NEXT i

A(10)=10

for i:=0 to 10 do

    A[i]:=i-1;

for i:=1 to 10 do

    A[i-1]:=A[i];

A[10]:=10;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

нц для i от 0 до 10

    A[i]:=i-1

кц

нц для i от 1 до 10

    A[i-1]:=A[i]

кц

A[10]:=10

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = 10

 

 

Как изменятся элементы этого массива после выполнения фрагмента программы?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, будут сдвинуты на один элемент вправо

4) все элементы, кроме последнего, уменьшатся на единицу

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

16
Задания Д 19 № 5451

В программе описаны одномерный целочисленный массив А с индексами от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(9)

FOR i = 8 TO 0 STEP -1

A(i+1) = A(i)

NEXT i

A(0) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[9]

for i := 8 downto 0 do

    A[i+1] := A[i];

A[0] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[9];

for (i = 8; i >= 0; i--) {

    A[i+1] = A[i];

}

A[0] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[9]

нц для i от 8 до 0 шаг -1

    A[i+1] := A[i]

кц

A[0] := t

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[9]

for i in range(8, -1, -1):

    A[i+1] = A[i]

A[0] = t

 

 


Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 10 3 4 5 6 7 8 9 10 10

2) 10 10 10 10 10 10 10 10 10 10

3) 10 1 1 1 1 1 1 1 1 1

4) 10 1 2 3 4 5 6 7 8 9


Аналоги к заданию № 5451: 5707 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.

17
Задания Д 19 № 5739

В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(0)

FOR i = 0 TO 8

A(i) = A(i+1)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0]

for i := 0 to 8 do

    A[i] := A[i+1];

A[9] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[0]

for (i = 0; i <= 8; i++) {

    A[i] = A[i+1];

}

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 0 до 8

    A[i] := A[i+1]

кц

A[9] := t

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[0]

for i in range(0, 9):

    A[i] = A[i+1]

A[9] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1


Аналоги к заданию № 5739: 5835 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

18
Задания Д 19 № 5387

В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

 

Бейсик

Паскаль

FOR i = 0 ТО 10

    A (i) = i-1

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = 10

 

for i = 0 to 10 do

    a[i] := i-1;

for i := 1 to 10 do

    a[i-1] := a[i];

a[10] := 10;

 

 

Си++

Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

 

 

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 1 до 10

    A[i-1] := A[i]

кц

А[10] := 10

 

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 10):

    A[i-1] = A[i]

A[10] = 10

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 10

4) 0 1 2 3 4 5 6 7 8 9 10


Аналоги к заданию № 5387: 6259 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 2.

19
Задания Д 19 № 6299

В программе описан одномерный целочисленный массив A с индексами от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

    A(i) = i+1

NEXT i

t = A(0)

FOR i = 1 TO 9

    A(i-1) = A(i)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0];

for i := 1 to 9 do

    A[i-1] := A[i];

A[9] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[0];

for (i = 1; i <= 9; i++) {

    A[i-1] = A[i];

}

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 1 до 9

    A[i-1] := A[i]

кц

A[9] := t

кц

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[0]

for i in range(1, 10):

    A[i-1] = A[i]

A[9] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.

20
Задания Д 19 № 6331

В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i

NEXT i

t = A(10)

FOR i = 10 TO 1 STEP -1

    A(i) = A(i-1)

NEXT i

A(0) = t

for i := 0 to 10 do

    A[i] := i;

t := A[10];

for i := 10 downto 1 do

    A[i] := A[i-1];

A[0] := t;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

t = A[10];

for (i = 10; i >= 1; i--) {

    A[i] = A[i-1];

}

A[0] = t;

нц для i от 0 до 10

    A[i] := i

кц

t := A[10]

нц для i от 10 до 1 шаг -1

    A[i] := A[i-1]

кц

A[0] := t

кц

Python

 

for i in range(0, 11):

    A[i] = i

t = A[10]

for i in range(10, 0, -1):

    A[i] = A[i-1]

A[0] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 10 10 10 10 10 10 10 10 10 10 10

2) 10 0 1 2 3 4 5 6 7 8 9

3) 10 0 0 0 0 0 0 0 0 0 0

4) 10 2 3 4 5 6 7 8 9 10 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 601.

21
Задания Д 19 № 6416

В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 0 TO 9

    A(i) = A(i+1)

NEXT i

A(10) = 10

for i := 0 to 10 do

    A[i] := i-1;

for i := 0 to 9 do

    A[i] := A[i+1];

A[10] := 10;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 0; i <= 9; i++) {

    A[i] = A[i+1];

}

A[10] = 10;

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 0 до 9

    A[i] := A[i+1]

кц

A[10] := 10

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(0, 10):

    A[i] = A[i+1]

A[10] = 10

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) –1 –1 –1 –1 –1 –1 –1 –1 –1 –1 10

4) 0 1 2 3 4 5 6 7 8 9 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 602.