≡ информатика
сайты - меню - вход - новости




Варианты заданий

Алгоритмы, меняющие элементы массива местами

Версия для печати и копирования в MS Word
1
Задание 19 № 7764

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9 соответственно, т.е. A[0] = 5; A[1] = 1 и т.д. Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

    ELSE

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

    else:

        c = c + 1

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

        begin

            t := A[i];

            A[i] := A[i - 1];

            A[i - 1] := t

        end

    else

        c := c + 1;

c := 0

нц для i от 1 до 9

если A[i - 1] >= A[i] то

    t := A[i]

    A[i] := A[i - 1]

    A[i - 1] := t

иначе

    c := c + 1

все

кц

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i-1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

    }

    else

        c++;

 


Аналоги к заданию № 7764: 7791 Все


2
Задание 19 № 11355

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т. е. A[0] = 1, A[1] = 2 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

j = 5

WHILE A(j) < A(j-1)

    t = A(j)

    A(j) = A(j-1)

    A(j-1) = t

    j = j - 1

WEND

j = 5

while A[j] < A[j-1]:

    A[j],A[j-1]=A[j-1],A[j]

    j -= 1

ПаскальАлгоритмический язык

j := 5;

while A[j] < A[j-1] do

    begin

        t := A[j];

        A[j] := A[j-1];

        A[j-1] := t;

        j := j - 1;

    end;

j := 5

нц пока A[j] < A[j-1]

    t := A[j]

    A[j] := A[j-1]

    A[j-1] := t

    j := j - 1

кц

Си++

j = 5;

while (A[j] < A[j-1])

    {

        t = A[j];

        A[j] = A[j-1];

        A[j-1] = t;

        j -= 1;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

3
Задание 19 № 13365

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент этой программы.

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s = 0

n = 10

for i in range(n):

    s = s + A[i] – A[i+1]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=0 to n-1 do begin

  s := s + A[i] - A[i+1];

end;

s := 0

n := 10

нц для i от 0 до n-1

  s := s + A[i] - A[i+1]

кц

Си++

s = 0;

n = 10;

for (i = 0; i < n; i++) {

  s = s + A[i] - A[i+1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 27, 17, 7, 0, 7, 17, 27, 17, 10, 7, 0, т.е. A[0] = 27, A[1] = 17 и т. д. Чему будет равно значение переменной s после выполнения данного фрагмента программы?

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

4
Задание 19 № 13415

В программе используется фрагмент одномерного целочисленного массива A с индексами от 1 до 10. Значения элементов равны 6, 7, 3, 8, 4, 1, 2, 0, 9, 5 соответственно, т. е. A[1] = 6, A[2] = 7 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

5
Задание 19 № 13468

В программе используется фрагмент одномерного целочисленного массив A с индексами от 1 до 10. Значения элементов равны 3, 14, 15, 92, 6, 2, 7, 18, 28, 17 соответственно, т. е. A[1] = 3, A[2] = 14 и т. д.

Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

6
Задание 19 № 13495

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 18, 8, 14, 9, 23, 7, 51, 99 соответственно, то есть A[0] = 1, A[1] = 2 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10:

     i += 1

while A[j] > 10:

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

7
Задание 19 № 13522

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5, 28, 8, 14, 9, 23, 6, 18, 51, 99 соответственно, то есть A[0] = 5, A[1] = 28 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

8
Задание 19 № 13549

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 16, 24, 35, 18, 4, 72, 10, 99, 44 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

      c = c + 1

      t = A(i+1)

      A(i+1) = A(i)

      A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

      c = c + 1

      t = A[i+1]

     A[i+1] = A[i]

     A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] mod 10 = A[0] then

  begin

      c := c + 1;

      t := A[i+1];

      A[i+1] := A[i];

      A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

      c := c + 1

      t := A[i+1]

      A[i+1] := A[i]

      A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

      c++;

      t = A[i+1];

      A[i+1] = A[i];

      A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

9
Задание 19 № 13576

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 8, 3, 16, 24, 35, 18, 4, 72, 8, 99, 44 соответственно, т. е. A[0] = 8, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

if A[i] mod 10 = A[0] then

  begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

10
Задание 19 № 13603

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, т. е. A[1]=1, A[2]=12 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

11
Задание 19 № 13630

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 11, 22, 33, 44, 55, 66, 77, 88, 99, т. е. A[1]=1, A[2]=11 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

12
Задание 19 № 13746

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 3, 0, 4, 6, 5, 1, 8, 2, 9, 7 соответственно, т. е. A[0] = 3, A[1] = 0 и т. д. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования)

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) > A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] > A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i-1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] > A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++) {

     if (A[i-1] > A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

13
Задание 19 № 14234

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 2, 3, 4, 5, 4, 3, 2, 1 (то есть A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.


14
Задание 19 № 14278

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 4, 9, 6, 5, 6, 8, 4, 1 (т.е. A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.


15
Задание 19 № 14705

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 8, 10, 7, 4, 6, 12, 15 (т.е. A[1] = 2, A[2] = 3, …, A[10] = 15).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10203

16
Задание 19 № 14780

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 8, 13, 19 (т.е. A[1] = 7, A[2] = 4, …, A[10] = 19).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 


17
Задание 19 № 15114

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 10, 7, 4, 6, 12, 9 (т. е. A[1] = 2, A[2] = 3, …, A[10] = 9). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


18
Задание 19 № 15141

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 3, 13, 10 (т. е. A[1] = 7, A[2] = 4, …, A[10] = 10). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


19
Задание 19 № 15635

Ниже представлен фрагмент программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9; 5 соответственно, т. е. A[0]=5; A[1]=1 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы.

 

БейсикPython

S = 0

FOR i = 0 TO 9

    S = S + A(i+1) – A(i);

NEXT i

s = 0

for i in range(10):

     s = s + A[i+1] - A[i]

ПаскальАлгоритмический язык

s := 0;

for i:=0 to 9 do begin

    s := s + A[i+1] - A[i]

end;

s := 0

нц для i от 0 до 9

     s := s + A[i+1] - A[i]

     все

кц

Си++

s = 0;

for (i=0; i<10; i++)

      s = s + A[i+1] - A[i];

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

20
Задание 19 № 15804

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 4, 4, 10, 4, 5, 6, 12, 9 (т.е. A[1] = 2, A[2] = 3, .., A[10] = 9). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] = A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


21
Задание 19 № 15831

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 8, 8, 1, 2, 2, 3, 3, 8, 5 (т.е. A[1] = 7, A[2] = 8, …, A[10] = 5). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] = A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


22
Задание 19 № 15859

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 3, 0, 9, 7, 8, 1, 5, 10, 2, 6, 4 соответственно, т.е. A[0] = 3, A[1] = 0 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.

 

БейсикPython

с = 0

FOR i = 1 TO 10

    IF A(i − 1) > A(i) THEN

        c = c + 1

        t = A(i)

        A(i) = A(i − 1)

        A(i − 1) = t

    END IF

NEXT i

c = 0

for i in range(1, 11):

    if A[i − 1] > A[i]:

        c = c + 1

        t = A[i]

        A[i] = A[i − 1]

        A[i − 1] = t

ПаскальАлгоритмический язык

c := 0;

for i:=1 to 10 do

    if A[i − 1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

    end;

c := 0

нц для i от 1 до 10

    если A[i − 1] > A[i] то

        c := c + 1

        t := A[i]

        A[i] := A[i − 1]

        A[i − 1] := t

     все

кц

Си++

c = 0;

for (i=1; i<11; i++)

      if (A[i − 1] > A[i])

      {

        c++;

        t = A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

      }

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

23
Задание 19 № 15929

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 3, 6, 6, 6, 6, 1, 3, 2 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 2). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(1,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

n := 9;

s := 0;

for i:=1 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i-1] + 1

        s := s + 1

    end

end;

 

n := 9

s := 0

нц для i от 1 до n

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 1; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 


24
Задание 19 № 15956

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 9, 8, 1, 2, 3, 3, 10, 8, 6 (т. е. A[0] = 7, A[1] = 9, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

s = 0

for i in range(1, 10):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

s := 0;

for i:=1 to 9 do begin

    if A[i-1] < A[i] then begin

        A[i] = A[i-1] + 1

        s := s + 1

    end

end;

 

s := 0

нц для i от 1 до 9

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

s = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 


25
Задание 19 № 15987

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 7, 8, 4, 2, 5, 1 (т. е. A[0] = 2, A[1] = 3, …, A[9] = 1). Определите значение переменной b после выполнения фрагмента.

 

 

БейсикPython

b = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        t = A(i)

        A(i) = A(i-1)

        A(i-1) = t

        b = b + 1

    END IF

NEXT i

 

b = 0

for i in range(1,10):

    if A[i-1] < A[i]:

        t = A[i]

        A[i] = A[i-1]

        A[i-1] = t

        b = b + 1

 

 

 

ПаскальАлгоритмический язык

b := 0;

for i:=1 to 9 do begin

    if A[i-1] < A[i] then begin

        t := A[i];

        A[i] := A[i-1];

        A[i-1] := t;

        b := b + 1

    end

end;

 

b := 0

нц для i от 1 до 9

    если A[i-1] < A[i] то

        t := A[i]

        A[i] := A[i-1]

        A[i-1] := t

        b := b + 1

    все

кц

С++

b = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

        b += 1;

    }

}

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна, вариант А. Имаева — «Котолис».

26
Задание 19 № 16046

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 2, 4, 3, 6, 3, 7, 8, 2, 9, 1 соответственно, т.е. A[0] = 2, A[1] = 4 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] < A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i-1] < A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] < A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++) {

     if (A[i-1] < A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2019 по информатике.

Алгебраические операции с элементами массива, двумерные массивы

Версия для печати и копирования в MS Word
1
Задание 19 № 7676

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-3

    s = s+A(i)-A(i+2)

NEXT i

s = 0

n = 10

for i in range(0,n-2):

    s = s + A[i] - A[i+2]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:=0 to n-3 do begin

    s:=s+A[i]-A[i+2]

end;

s:=0

n:=10

нц для i от 0 до n-3

    s:=s+A[i]-A[i+2]

кц

Си++

s = 0;

n=10;

for (i = 0; i <= n-3; i++) {

    s=s+A[i]-A[i+2];

}

 

В начале выполнения этого фрагмента в массиве находились трёхзначные натуральные числа. Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все


2
Задание 19 № 8107

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 8

    IF A(j) > A(j+1) THEN

        s = s + 1

        t = A(j)

        A(j) = A(j+1)

        A(j+1) = t

    ENDIF

NEXT j

s = 0

for j in range(9):

    if A[j] > A[j+1]:

        s = s + 1

        t = A[j]

        A[j] = A[j+1]

        A[j+1] = t

ПаскальАлгоритмический язык

s := 0;

for j := 0 to 8 do

    if A[j] > A[j+1] then

    begin

        s := s + 1;

        t := A[j];

        A[j] := A[j+1];

        A[j+1] := t;

end;

s := 0

нц для j от 0 до 8

    если A[j] > A[j+1] то

        s := s + 1

        t := A[j]

        A[j] := A[j+1]

        A[j+1] := t

    все

кц

Си++

s = 0;

for (j = 0; j < 9; j++) {

    if (A[j] > A[j+1])

    {

        s++;

        t = A[j];

        A[j] = A[j+1];

        A[j+1] = t;

    }

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

3
Задание 19 № 3368

Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикПаскаль

FOR i= 1 TO 100

    FOR k=1 TO 100

    IF i > k THEN A(i,k) = i

    ELSE

        A(i,k) = -k

    NEXT k

NEXT i

for i:=1 to 100 do

    for k:=1 to 100 do

        if i > k then

        A[i,k] := i

    else A[i,k] := -k;

Си++Алгоритмический язык

for (i=1;i<=100;i++) {

    for (k=1;k<=100;k++) {

        if (i > k) {

            A[i,k] = i;

        }

        else A[i,k] = -k;

    }

}

нц для i от 1 до 100

    нц для k от 1 до 100

        если i > k

        то A[i,k] := i

        иначе A[i,k] := -k

    кц

кц

Python

 

for i in range(1, 101):

    for k in range(1, 101):

        if i > k:

            A[i][k] = i

        else:

            A[i][k] = -k

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


Аналоги к заданию № 3368: 3391 Все


4
Задание 19 № 3357

Значения элементов двух массивов А и В размером 1 х 100 задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = 50 - i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i) + 49;

NEXT i

 

 

for i in range(1, 101):

    A[i] = 50 - i

for i in range(1, 101):

    B[i] = A[i] + 49

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = 50 - i;

for i : = 1 to 100 do begin

    B[i]:= A[i] + 49;

end;

 

нц для i от 1 до 100

    A[i] : = 50 - i

кц

нц для i от 1 до 100

    B[i]:=A[i] + 49

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = 50 - i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i] + 49;

}

 

 

Сколько элементов массива В будут иметь отрицательные значения?


5
Задание 19 № 3358

Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR n = 1 TO 100

    A(n) = n - 10

NEXT n

FOR n = 1 TO 100

    B(n) = A(n)*n;

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 10

for n in range(1, 101):

    B[n] = A[n]*n

ПаскальАлгоритмический язык

 

for n : = 1 to 100

    do A[n] : = n - 10;

for n : = 1 to 100 do begin

    B[n]:= A[n]*n;

end;

 

нц для n от 1 до 100

    A[n] : = n - 10

кц

нц для n от 1 до 100

    B[n]:=A[n]*n

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 10;

}

for (n = 1; n <= 100; n++) {

    B[n] = A[n]*n;

}

 

 

Сколько элементов массива B будут иметь положительные значения?

 

Примечание. Нуль является ни положительным, ни отрицательным числом.


Аналоги к заданию № 3358: 3360 Все


6
Задание 19 № 3365

Дан фрагмент программы, обрабатывающей двухмерный массив A[1..5,1..4]:

 

 

БейсикPython

k = 4

FOR m = 1 TO 4

    k = k + 1

    FOR n = 1 TO 5

        k = m - k

        A(n,m) = n*n+m*m-2*k

    NEXT n

NEXT m

 

k = 4

for m in range(1, 5):

    k += 1

    for n in range(1, 6):

        k=m-k

        A[n][m]=n*n+m*m-2*k

ПаскальАлгоритмический язык

k:=4;

for m:=1 to 4 do begin

    k:=k+1;

    for n:=1 to 5 do begin

        k:=m-k;

        A[n,m]:=n*n+m*m-2*k;

    end;

end;

k:=4

нц для m от 1 до 4

    k:=k+1

    нц для n от 1 до 5

        k:=m-k

        A[n,m]:=n*n+m*m-2*k

    кц

кц

 

Си++

k = 4;

for (m = 1; m <= 4; m++) {

    k = k + 1;

    for (n = 1; n <= 5; n++) {

        k=m-k;

        A[n][m]=n*n+m*m-2*k;

    }

}

 

 

Чему будет равно значение A[3,1]?


7
Задание 19 № 3367

Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = 1 TO n+1

        A(n,k) = A(n,k) - 1

        A(n,k+1) = A(n,k) - 1

    NEXT k

NEXT n

for n in range(1, 5):

    for k in range(1, n+2):

        A[n,k] = A[n,k]-1

        A[n,k+1] = A[n,k]-1

ПаскальАлгоритмический язык

for n:= 1 to 4 do

    for k:=1 to n+1 do begin

        A[n,k]:= A[n,k]-1;

        A[n,k+1]:= A[n,k]-1;

    end;

нц для n от 1 до 4

    нц для k от 1 до n+1

        A[n,k]:= A[n,k]-1

        A[n,k+1]:= A[n,k]-1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = 1; k <= n+1; k++) {

        A[n][k]= A[n][k]-1;

        A[n][k+1]= A[n][k]-1;

    }

}

 

 

Сколько элементов массива в результате будут равны 0?


8
Задание 19 № 3373

В программе описан двухмерный целочисленный массив A [1..6,1..6]. Ниже представлен фрагмент этой программы, в котором изменяются значения элементов массива.

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 6

        A(n,m) = A(m,n)+2*n-m

    NEXT m

NEXT n

for n in range(1, 7):

    for m in range(1, 7):

        A[n,m] = A[m,n]+2*n-m

ПаскальАлгоритмический язык

for n:= 1 to 6 do

    for m:=1 to 6 do begin

        A[n,m]:= A[m,n]+2*n-m;

    end;

нц для n от 1 до 6

    нц для m от 1 до 6

        A[n,m]:= A[m,n]+2*n-m

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 6; m++) {

        A[n][m]= A[m,n]+2*n-m;

    }

}

 

 

До выполнения данного фрагмента программы значение A[4,3] было равно 10, а значение A[3,4] было равно 15. Чему будет равно значение A[4,3] после выполнения этого фрагмента программы?


9
Задание 19 № 3374

Значения двумерного массива задаются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR k = 1 TO 5

        B(n,k) = n + k

    NEXT k

NEXT n

for n in range(1, 6):

    for k in range(1, 6):

        B[n,k] = n + k

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for k:=1 to 5 do begin

        B[n,k]:= n + k;

    end;

нц для n от 1 до 5

    нц для k от 1 до 5

        B[n,k]:= n + k

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (k = 1; k <= 5; k++) {

        B[n][k]= n + k;

    }

}

 

 

 

Чему будет равно значение B[2,4]?


10
Задание 19 № 3375

Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR i = 1 TO 5

    FOR j = 1 TO 5

        A(i,j) = i*j

    NEXT j

NEXT i

for i in range(1, 6):

    for j in range(1, 6):

        A[i,j] = i*j

ПаскальАлгоритмический язык

for i:= 1 to 5 do

    for j:=1 to 5 do begin

        A[i,j]:= i*j;

    end;

нц для i от 1 до 5

    нц для j от 1 до 5

        A[i,j]:= i*j

    кц

кц

Си++

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]= i*j;

    }

}

 

 

Сколько элементов массива будут иметь значения больше 10?


11
Задание 19 № 3378

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 4. Затем выполняется следующий фрагмент программы:

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 1 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

for i in range(1, 5):

    for j in range(1, 6):

        A[i,j] = A[i,j]+4

        A[j,i] = A[j,i]+5

ПаскальАлгоритмический язык

for i:= 1 to 4 do

    for j:=1 to 5 do begin

        A[i,j]:=A[i,j]+4;

        A[j,i]:=A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 1 до 5

        A[i,j]:=A[i,j]+4

        A[j,i]:=A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]=A[i][j]+4;

        A[j][i]=A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


12
Задание 19 № 3385

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR m = 1 TO 5

        C(n,m) = (m – n)*(m – n)

    NEXT m

NEXT n

 

for n in range(1, 6):

    for m in range(1, 6):

        C[n][m] = (m – n)*(m – n)

 

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for m:=1 to 5 do begin

        C[n,m] : = (m – n)*(m – n);

    end;

нц для n от 1 до 5

    нц для m от 1 до 5

        C[n,m] := (m – n)*(m – n)

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m] = (m – n)*(m – n);

    }

}

 

 

Сколько элементов массива С будут равны 1?


13
Задание 19 № 3390

Все элементы двумерного массива A размером 10х10 элементов первоначально были равны 0. Затем значения элементов меняются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = n TO 4

        A(n,k) = A(n,k) + 1

        A(k,n) = A(k,n) + 1

 

    NEXT k

NEXT n

 

for n in range(1, 5):

    for k in range(n, 5):

        A[n][k] = A[n][k] + 1

        A[k][n] = A[k][n] + 1

ПаскальАлгоритмический язык

for n:=1 to 4 do

    for k:=n to 4 do begin

        A[n,k] : = A[n,k] + 1;

        A[k,n] : = A[k,n] + 1;

    end;

нц для n от 1 до 4

    нц для k от n до 4

        A[n,k] : = A[n,k] + 1

        A[k,n] : = A[k,n] + 1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = n; k <= 4; k++) {

        A[n][k] = A[n][k] + 1;

        A[k][n] = A[k][n] + 1;

    }

}

 

 

Сколько элементов массива в результате будут равны 1?


14
Задание 19 № 3393

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 0. Затем выполняется следующий фрагмент программы:

 

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 2 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

 

for i in range(1, 5):

    for j in range(2, 6):

        A[i,j] = A[i,j]+4

        A[j,i] = A[j,i]+5

ПаскальАлгоритмический язык

for i:=1 to 4 do

    for j:=2 to 5 do begin

        A[i,j] : = A[i,j]+4;

        A[j,i] : = A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 2 до 5

        A[i,j] : = A[i,j]+4

        A[j,i] : = A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 2; j <= 5; j++) {

        A[i][j] = A[i][j]+4;

        A[j][i] = A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


15
Задание 19 № 3394

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = i*i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i)-100

NEXT i

 

 

for i in range(1, 101):

    A[i] = i*i

for i in range(1, 101):

    B[i] = A[i]-100

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = i*i;

for i : = 1 to 100 do begin

    B[i] : = A[i]-100;

end;

 

нц для i от 1 до 100

    A[i] : = i*i

кц

нц для i от 1 до 100

    B[i] : = A[i]-100

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = i*i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i]-100;

}

 

 

Сколько положительных значений будет в массиве B?

Пояснение · ·

16
Задание 19 № 4685

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i - 1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++){

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е. А[0]=0, А[1]=10 и т.д. Чему будет равно значение переменной s после выполнения данной программы?


17
Задание 19 № 4717

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i-1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++) {

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


18
Задание 19 № 6772

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

БейсикПаскаль

n = 10

FOR i = 0 TO n

    K = A(i)

    A(K) = 0

NEXT i

n:=10;

for i:=0 to n do begin

    K := A[i];

    A[K] := 0;

end;

Си++Алгоритмический язык

n=10;

for (i = 0; i <= n; i++){

    K = A[i];

    A[K] = 0;

}

n:=10

нц для i от 0 до n

    K := A[i]

    A[K] := 0

кц

Python

n = 10

for i in range(0, n+1):

    K = A[i];

    A[K] = 0

 

 

В начале выполнения этого фрагмента в массиве находились числа 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 10, A[1] = 9 и т. д. Сколько элементов массива после выполнения программы будут иметь ненулевые значения?


Аналоги к заданию № 6772: 6804 Все


19
Задание 19 № 6886

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s:=0;

n:=10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1];

end;

Си++Алгоритмический язык

s = 0;

n=10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1];

}

s:=0

n:=10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]

кц

Python

s = 0

n = 10

for i in range(0, n):

    s=s+A[i]-A[i+1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 15, 10, 5, 0, 5, 10, 15, 10, 5, 0, 5, т. е. A[0]=15, A[1]=10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6886: 6918 Все

Пояснение · ·

20
Задание 19 № 6951

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 21.

 

БейсикПаскаль

s = 0

n = 21

FOR i = 2 TO n

    s = s+2*(A(i)-A(i-1))

NEXT i

s:=0;

n:=21;

for i:= 2 to n do begin

    s:=s+2*(A[i]-A[i-1]);

end;

Си++Алгоритмический язык

s = 0;

n = 21;

for (i = 2; i <= n; i++) {

    s=s+2*(A[i]-A[i-1]);

}

s:=0

n:=21

нц для i от 2 до n

    s:= s+2*(A[i]-A[i-1])

кц

Python

s = 0

n = 21

for i in range(2, n+1):

     s=s+2*(A[i]-A[i-1])

 

 

В начале выполнения этого фрагмента в элементе массива с индексом i находилось число i (i = 1, …, 21), т. е. A[1] = 1, A[2] = 2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6951: 6983 Все


21
Задание 19 № 7196

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

        A(n,k)=n+k+1

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=n+k+1

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++) {

        A[n][k]=n+k+1;

       }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=n+k+1

    кц

кц

Python

for n in range(1, 10):

    for k in range(1, 10):

        A[n,k] = n+k+1

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

22
Задание 19 № 7263

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 5

        C(n,m)=C(n,m)+(2*n-m)

    NEXT m

NEXT n

 

for n in range(1, 7):

    for m in range(1, 6):

        C[n,m]=C[n,m]+(2*n-m)

ПаскальАлгоритмический язык

for n:=1 to 6 do

    for m:=1 to 5 do begin

        C[n,m]:=C[n,m]+(2*n-m);

    end;

нц для n от 1 до 6

    нц для m от 1 до 5

        C[n,m]:=C[n,m]+(2*n-m)

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m]=C[n][m]+(2*n-m);

    }

}

 

 

Чему будет равно значение элемента двумерного массива С[4,3], если до выполнения этих команд С[4,3]=10?


23
Задание 19 № 7301

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 25.

 

БейсикПаскаль

n = 25

A(1) = 2

FOR i = 2 TO n

    A(i) = 2*A(i–1) MOD 10

NEXT i

n:=25;

A[1]:=2;

for i:= 2 to n do begin

    A[i] := 2*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=25;

A[1] = 2;

for (i = 2; i <= n; i++) {

    A[i] = 2*A[i–1] % 10;

}

n:=25

A[1] := 2

нц для i от 2 до n

    A[i] = mod (2*A[i–1], 10)

кц

Python

n = 25

A[1] = 2

for i in range(2, n+1):

    A[i] = 2*A[i–1] % 10

 

 

Чему будет равно значение элемента A[25] (то есть элемента массива с индексом 25) после выполнения фрагмента программы?


24
Задание 19 № 7333

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 24.

 

БейсикПаскаль

n = 24

A(1) = 4

FOR i = 2 TO n

    A(i) = 4*A(i–1) MOD 10

NEXT i

n:=24;

A[1]:=4;

for i:= 2 to n do begin

    A[i] := 4*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=24;

A[1] = 4;

for (i = 2; i <= n; i++) {

    A[i] = 4*A[i–1] % 10;

}

n:=24

A[1] := 4

нц для i от 2 до n

    A[i] = mod (4*A[i–1], 10)

кц

Python

n = 24

A[1] = 4

for i in range(2, n+1):

    A[i] = 4*A[i–1] % 10

 

 

Чему будет равно значение элемента A[24] (то есть элемента массива с индексом 24) после выполнения фрагмента программы?


25
Задание 19 № 7365

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

    A(n,k)=2*n+k

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=2*n+k

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++)

        A[n][k]=2*n+k;

    }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=2*n+k

кц

кц

Python

 

for n in range(1, 10):

    for k in range(1, 10):

            A[n,k] = 2*n+k

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

Алгоритмы с использованием условного оператора

Версия для печати и копирования в MS Word
1
Задание 19 № 8667

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4; 2; 6; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[0] = 4; A[1] = 2 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

Бейсик Python

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

        c = c + 1

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 9

    если A[i - 1] >= A[i] то

        t := A[i]

        A[i] := A[i - 1]

        A[i - 1] := t

        c := c + 1

    все

кц

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

    begin

        t := A[i];

        A[i] := A[i - 1];

        A[i - 1] := t;

        c := c + 1;

    end;

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i - 1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

        c++;

    }


Аналоги к заданию № 8667: 9171 Все


2
Задание 19 № 9203

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10.

 

Бейсик Python

s = 27

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)+2

NEXT i

s = 27

n = 10

for i in range(0,n):

    s = s + A[i] - A[i+1]+2

Алгоритмический язык Паскаль

s := 27

n := 10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]+2

кц

s := 27;

n := 10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1]+2

end;

Си++

s = 27;

n = 10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1]+2;

}

 

Известно, что в начале выполнения этого фрагмента в массиве находилась возрастающая последовательность чисел, то есть A[0] < A[1] < … < A[10].

Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 9203: 9311 Все


3
Задание 19 № 9370

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 7, 3, 8, 5, 0, 1, 2, 9, 6 соответственно, т.е. A[0] = 4, A[1] = 7 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

 c = 0

 FOR i = 1 TO 9

    IF A(i) < A(0) THEN

        c = c + 1

        t = A(i)

        A(i) = A(0)

        A(0) = t

    ENDIF

 NEXT i

 c = 0

 for i in range(1,10):

    if A[i] < A[0]:

        c = c + 1

        t = A[i]

        A[i] = A[0]

        A[0] = t

ПаскальАлгоритмический язык

 c := 0;

 for i := 1 to 9 do

    if A[i] < A[0] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[0];

        A[0] := t;

    end;

 c := 0

 нц для i от 1 до 9

    если A[i] < A[0] то

        c := c + 1

        t := A[i]

        A[i] := A[0]

        A[0] := t

    все

 кц

Си++

 c = 0;

 for (i = 1;i < 10;i++)

    if (A[i] < A[0])

    {

        c++;

        t = A[i];

        A[i] = A[0];

        A[0] = t;

    }

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

4
Задание 19 № 9654

В программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т. е. A[1] = 7; A[2] = 3 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикПаскаль

j = 0

FOR k = 2 TO 10

  IF A(k) <= A(1) THEN

    A(1) = A(k)

    j = j + k

  END IF

NEXT k

j := 0;

for k := 2 to 10 do

begin

  if A[k] <= A[1] then

    begin

      A[1] := A[k];

      j := j + k

    end

end;

Си++Алгоритмический язык

j = 0;

for (k = 2; k<= 10; k++) {

  if (A[k] <= A[1]) {

    A[1] = A[k];

    j = j + k;

  }

}

j := 0

нц для k от 2 до 10

  если A[k] <= A[1] то

    A[1] := A[k]

    j := j+k

  все

кц

Python

j = 0

for k in range(2, 11):

    if A[k] <= A[1]:

        A[1] = A[k]

        j = j + k

 


Аналоги к заданию № 9654: 9700 Все


5
Задание 19 № 9769

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


6
Задание 19 № 3369

Значения элементов двумерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR i = 1 TO 100

    FOR k = 1 TO 100

        IF i = k THEN A(i,k)= 1

        ELSE A(i,k)= -1

    NEXT k

NEXT i

for i in range(1, 101):

    for k in range(1, 101):

        if i == k:

            A[i][k] = 1

        else:

            A[i][k] = -1

ПаскальАлгоритмический язык

for i:= 1 to 100 do

    for k:=1 to 100 do

        if i = k then

            A[i,k] := 1

        else A[i,k] := -1;

нц для i от 1 до 100

    нц для k от 1 до 100

        если i = k то

            A[i,k] := 1

        иначе A[i,k] := -1

    все

    кц

кц

Си++

for (i = 1; i <= 100; i++) {

    for (k = 1; k <= 100; k++) {

        if (i == k)

            A[i][k] = 1;

        else

            A[i][k] = -1;

    }

}

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


7
Задание 19 № 4842

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    IF i = n - i THEN

        s = s + A(i) + A (i + 1)

    END IF

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

    begin

        if i = n - i then

            s : = s + A[i] + A[i + 1];

    end

Си++Алгоритмический язык
s = 0;

n = 10;

for (i = 1; i <= n; i++){

    if (i == n - i)

        s = s + A[i] + A[i + 1];

}

s: = 0

n : = 10

нц для i от 1 до n

если i = n - i

    то s := s + A[i] + A[i + 1]

все

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    if i == n - i:

        s = s + A[i] + A[i + 1];

 

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. элемент А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


8
Задание 19 № 4930

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования,фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s=0

n = 10

FOR i = 0 TO n

    IF A(n − i)-A(i) > A(i) THEN

        s = s + A(i)

    END IF

NEXT i

s := 0;

n := 10;

for i:=0 to n do begin

    if A[n - i] - A[i] > A[i] then

        s := s + A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 0; i <= n; i++ ) {

    if(A[n - i]-A[i] > A[i]) {

        s = s+ A[i];

    }

}

s := 0

n:=10

нц для i от 0 до n

    если A[n - i] - A[i] > A[i]

        то s := s + A[i]

все

кц

Python

s = 0

n = 10

for i in range(0, n+1):

    if A[n - i]-A[i] > A[i]:

        s = s+ A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80. 90, 100, т.е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 4930: 4971 Все


9
Задание 19 № 6182

В программе описан одномерный целочисленный массив с индексами от 0 до 12. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s = 0

n = 12

FOR i = 0 TO n

    IF A(n–i) – A(i) = A(i) THEN

        s = s+2*A(i)

    END IF

NEXT i

s := 0;

n := 12;

for i:=0 to n do begin

    if A[n–i] – A[i] = A[i] then

        s:=s+2*A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 12;

for (i = 0; i <= n; i++) {

    if (A[n–i] – A[i] == A[i])

        s = s+2*A[i];

}

s := 0

n := 12

нц для i от 0 до n

    если A[n–i] – A[i] = A[i]

        то s := s+2*A[i]

все

кц

Python

s = 0

n = 12

for i in range(0, n+1):

    if A[n–i] – A[i] == A[i]:

        s = s+2*A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, т. е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6182: 6227 Все


10
Задание 19 № 10322

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

  s = s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(1,n):

  s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

  s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

  s:=s + A[i]*A[i]-A[i-1]*A[i-1]

кц

Си++

s = 0;

n=10;

for (i = 1; i < n; i++) {

  s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

В начале выполнения этого фрагмента в массиве находились числа 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, то есть A[1] = 1, A[2] = 2 и так далее Чему будет равно значение переменной s после выполнения данной программы?


11
Задание 19 № 11120

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 9

  IF A(j) <=4 THEN

    s = j

  ENDIF

NEXT j

s = 0

for j in range(10):

    if A[j] <= 4:

      s = j

Алгоритмический языкПаскаль

s := 0

нц для j от 0 до 9

  если A[j] <= 4 то

    s := j

  все

кц

s := 0;

for j := 0 to 9 do

  if A[j] <= 4 then

    s := j;

Си++

s = 0;

for (j = 0; j <= 9; j++) {

    if (A[j] <= 4) {

      s = j;

    }

}

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Пояснение · ·

12
Задание 19 № 11248

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 6, 8, 5, 8, 4, 2, 10, 9, 4 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д. Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

Алгоритмический языкПаскаль

c := 0

нц для i от 1 до 9

  если A[i] = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

c := 0;

for i := 1 to 9 do begin

  if A[i] = A[0] then begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 


Аналоги к заданию № 11248: 11275 Все


13
Задание 19 № 11315

В программе описан одномерный целочисленный массив с индексами от 0 до 9. Ниже представлен фрагмент программы, обрабатывающей данный массив:

 

 

Бейсик Python

c = 0

FOR i = 1 TO 8

    IF A(i)=A(0) THEN

        c = c + 1

        t=A(i+1)

        A(i+1)= A(i)

        A(i)= t

    ENDIF

NEXT i

PRINT c

c = 0

for i in range(1, 9):

    if A[i] == A[0]:

        c += 1

        t=A[i+1]

        A[i+1]= A[i]

        A[i]= t

print(c)

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 8

    если A[i] = A[0] то

        c := c + 1

        t:=A[i+1]

        A[i+1]:= A[i]

        A[i]:= t

    все

кц

вывод c

c := 0;

for i := 1 to 8 do

    if A[i] = A[0] then

    begin

        inc(c);

        t:=A[i+1];

        A[i+1]:= A[i];

        A[i]:= t;

    end;

writeln(c);

Си++

c = 0;

for (i = 1; i <= 8; i++)

    if (A[i] == A[0])

    {

        c++;

        t=A[i+1];

        A[i+1]= A[i];

        A[i]= t;

    }

cout « c « endl;

 

В начале выполнения этого фрагмента в массиве находились числа 3, 2, 4, 6, 3, 10, 12, 14, 16, 18 т. е. А[0]=3, А[1]=2 и т. д. Чему будет равно значение переменной с после выполнения данной программы?

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

14
Задание 19 № 16394

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 1, 6, 2, 7, 3, 2, 2, 1 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] = 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] = 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 


15
Задание 19 № 16448

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 1, 1, 5, 2, 9, 4, 3, 2, 1 (т. е. A[0] = 3, A[1] = 1, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] := 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] := 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 


16
Задание 19 № 16822

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 5, 4, 2, 7, 4, 3, 1, 2, 6 (т.е. A[0] = 3, A[1] = 5, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 9

s = 0

FOR i = 0 TO N

    IF A(i) < A(N) THEN

        A(i) = A(i) + 1

        A(N) = A(N) − 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(n + 1):

    if A[i] < A[n]:

        A[i] += 1

        A[n] −= 1

        s += 1

 

 

 

ПаскальАлгоритмический язык

N := 9;

s := 0;

for i:=0 to N do begin

    if A[i] < A[N] then begin

        A[i] := A[i] + 1;

        A[N] := A[N] − 1;

        s := s + 1;

    end;

end;

 

N := 9

s := 0

нц для i от 0 до N

    если A[i] < A[N] то

        A[i] := A[i] + 1

        A[N] := A[N] − 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 0; i <= n; ++i) {

    if (A[i] < A[n]) {

        A[i] = A[i] + 1;

        A[n] = A[n] − 1;

        s = s + 1;

    }

}

 


17
Задание 19 № 16895

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 8, 6, 1, 7, 2, 3, 2, 7 (т.е. A[0] = 2, A[1] = 4, …, A[9] = 7). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 9

s = 0

FOR i = 0 TO N

    IF A(i) < A(N) THEN

        A(i) = A(i) + 1

        A(N) = A(N) − 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(n + 1):

    if A[i] < A[n]:

        A[i] += 1

        A[n] −= 1

        s += 1

 

 

 

ПаскальАлгоритмический язык

N := 9;

s := 0;

for i:=0 to N do begin

    if A[i] < A[N] then begin

        A[i] := A[i] + 1;

        A[N] := A[N] − 1;

        s := s + 1;

    end;

end;

 

N := 9

s := 0

нц для i от 0 до N

    если A[i] < A[N] то

        A[i] := A[i] + 1

        A[N] := A[N] − 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 0; i <= n; ++i) {

    if (A[i] < A[n]) {

        A[i] = A[i] + 1;

        A[n] = A[n] − 1;

        s = s + 1;

    }

}