СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Варианты заданий

Преобразование пройденных элементов массива

Версия для печати и копирования в MS Word
1
Задание 19 № 9654

В программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т. е. A[1] = 7; A[2] = 3 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикПаскаль

j = 0

FOR k = 2 TO 10

  IF A(k) <= A(1) THEN

    A(1) = A(k)

    j = j + k

  END IF

NEXT k

j := 0;

for k := 2 to 10 do

begin

  if A[k] <= A[1] then

    begin

      A[1] := A[k];

      j := j + k

    end

end;

Си++Алгоритмический язык

j = 0;

for (k = 2; k<= 10; k++) {

  if (A[k] <= A[1]) {

    A[1] = A[k];

    j = j + k;

  }

}

j := 0

нц для k от 2 до 10

  если A[k] <= A[1] то

    A[1] := A[k]

    j := j+k

  все

кц

Python

j = 0

for k in range(2, 11):

    if A[k] <= A[1]:

        A[1] = A[k]

        j = j + k

 


Аналоги к заданию № 9654: 9700 Все


2
Задание 19 № 3357

Значения элементов двух массивов А и В размером 1 х 100 задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = 50 - i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i) + 49;

NEXT i

 

 

for i in range(1, 101):

    A[i] = 50 - i

for i in range(1, 101):

    B[i] = A[i] + 49

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = 50 - i;

for i : = 1 to 100 do begin

    B[i]:= A[i] + 49;

end;

 

нц для i от 1 до 100

    A[i] : = 50 - i

кц

нц для i от 1 до 100

    B[i]:=A[i] + 49

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = 50 - i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i] + 49;

}

 

 

Сколько элементов массива В будут иметь отрицательные значения?


3
Задание 19 № 3358

Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR n = 1 TO 100

    A(n) = n - 10

NEXT n

FOR n = 1 TO 100

    B(n) = A(n)*n;

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 10

for n in range(1, 101):

    B[n] = A[n]*n

ПаскальАлгоритмический язык

 

for n : = 1 to 100

    do A[n] : = n - 10;

for n : = 1 to 100 do begin

    B[n]:= A[n]*n;

end;

 

нц для n от 1 до 100

    A[n] : = n - 10

кц

нц для n от 1 до 100

    B[n]:=A[n]*n

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 10;

}

for (n = 1; n <= 100; n++) {

    B[n] = A[n]*n;

}

 

 

Сколько элементов массива B будут иметь положительные значения?

 

Примечание. Нуль является ни положительным, ни отрицательным числом.


Аналоги к заданию № 3358: 3360 Все


4
Задание 19 № 3394

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = i*i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i)-100

NEXT i

 

 

for i in range(1, 101):

    A[i] = i*i

for i in range(1, 101):

    B[i] = A[i]-100

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = i*i;

for i : = 1 to 100 do begin

    B[i] : = A[i]-100;

end;

 

нц для i от 1 до 100

    A[i] : = i*i

кц

нц для i от 1 до 100

    B[i] : = A[i]-100

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = i*i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i]-100;

}

 

 

Сколько положительных значений будет в массиве B?

Пояснение · ·

5
Задание 19 № 6772

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

БейсикПаскаль

n = 10

FOR i = 0 TO n

    K = A(i)

    A(K) = 0

NEXT i

n:=10;

for i:=0 to n do begin

    K := A[i];

    A[K] := 0;

end;

Си++Алгоритмический язык

n=10;

for (i = 0; i <= n; i++){

    K = A[i];

    A[K] = 0;

}

n:=10

нц для i от 0 до n

    K := A[i]

    A[K] := 0

кц

Python

n = 10

for i in range(0, n+1):

    K = A[i];

    A[K] = 0

 

 

В начале выполнения этого фрагмента в массиве находились числа 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 10, A[1] = 9 и т. д. Сколько элементов массива после выполнения программы будут иметь ненулевые значения?


Аналоги к заданию № 6772: 6804 Все


6
Задание 19 № 7301

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 25.

 

БейсикПаскаль

n = 25

A(1) = 2

FOR i = 2 TO n

    A(i) = 2*A(i–1) MOD 10

NEXT i

n:=25;

A[1]:=2;

for i:= 2 to n do begin

    A[i] := 2*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=25;

A[1] = 2;

for (i = 2; i <= n; i++) {

    A[i] = 2*A[i–1] % 10;

}

n:=25

A[1] := 2

нц для i от 2 до n

    A[i] = mod (2*A[i–1], 10)

кц

Python

n = 25

A[1] = 2

for i in range(2, n+1):

    A[i] = 2*A[i–1] % 10

 

 

Чему будет равно значение элемента A[25] (то есть элемента массива с индексом 25) после выполнения фрагмента программы?


7
Задание 19 № 7333

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 24.

 

БейсикПаскаль

n = 24

A(1) = 4

FOR i = 2 TO n

    A(i) = 4*A(i–1) MOD 10

NEXT i

n:=24;

A[1]:=4;

for i:= 2 to n do begin

    A[i] := 4*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=24;

A[1] = 4;

for (i = 2; i <= n; i++) {

    A[i] = 4*A[i–1] % 10;

}

n:=24

A[1] := 4

нц для i от 2 до n

    A[i] = mod (4*A[i–1], 10)

кц

Python

n = 24

A[1] = 4

for i in range(2, n+1):

    A[i] = 4*A[i–1] % 10

 

 

Чему будет равно значение элемента A[24] (то есть элемента массива с индексом 24) после выполнения фрагмента программы?


8
Задание 19 № 14705

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 8, 10, 7, 4, 6, 12, 15 (т.е. A[1] = 2, A[2] = 3, …, A[10] = 15).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10203

9
Задание 19 № 14780

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 8, 13, 19 (т.е. A[1] = 7, A[2] = 4, …, A[10] = 19).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 


10
Задание 19 № 15114

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 10, 7, 4, 6, 12, 9 (т. е. A[1] = 2, A[2] = 3, …, A[10] = 9). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


11
Задание 19 № 15141

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 3, 13, 10 (т. е. A[1] = 7, A[2] = 4, …, A[10] = 10). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


12
Задание 19 № 15929

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 3, 6, 6, 6, 6, 1, 3, 2 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 2). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(1,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

n := 9;

s := 0;

for i:=1 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i-1] + 1

        s := s + 1

    end

end;

 

n := 9

s := 0

нц для i от 1 до n

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 1; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 


13
Задание 19 № 15956

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 9, 8, 1, 2, 3, 3, 10, 8, 6 (т. е. A[0] = 7, A[1] = 9, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

s = 0

for i in range(1, 10):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

s := 0;

for i:=1 to 9 do begin

    if A[i-1] < A[i] then begin

        A[i] = A[i-1] + 1

        s := s + 1

    end

end;

 

s := 0

нц для i от 1 до 9

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

s = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 


14
Задание 19 № 16394

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 1, 6, 2, 7, 3, 2, 2, 1 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] := 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] := 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 


15
Задание 19 № 16448

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 1, 1, 5, 2, 9, 4, 3, 2, 1 (т. е. A[0] = 3, A[1] = 1, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] := 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] := 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 

Обсчёт массива с накопителем

Версия для печати и копирования в MS Word
1
Задание 19 № 7676

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-3

    s = s+A(i)-A(i+2)

NEXT i

s = 0

n = 10

for i in range(0,n-2):

    s = s + A[i] - A[i+2]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:=0 to n-3 do begin

    s:=s+A[i]-A[i+2]

end;

s:=0

n:=10

нц для i от 0 до n-3

    s:=s+A[i]-A[i+2]

кц

Си++

s = 0;

n=10;

for (i = 0; i <= n-3; i++) {

    s=s+A[i]-A[i+2];

}

 

В начале выполнения этого фрагмента в массиве находились трёхзначные натуральные числа. Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все


2
Задание 19 № 9203

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10.

 

Бейсик Python

s = 27

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)+2

NEXT i

s = 27

n = 10

for i in range(0,n):

    s = s + A[i] - A[i+1]+2

Алгоритмический язык Паскаль

s := 27

n := 10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]+2

кц

s := 27;

n := 10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1]+2

end;

Си++

s = 27;

n = 10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1]+2;

}

 

Известно, что в начале выполнения этого фрагмента в массиве находилась возрастающая последовательность чисел, то есть A[0] < A[1] < … < A[10].

Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 9203: 9311 Все


3
Задание 19 № 4842

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    IF i = n - i THEN

        s = s + A(i) + A (i + 1)

    END IF

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

    begin

        if i = n - i then

            s : = s + A[i] + A[i + 1];

    end

Си++Алгоритмический язык
s = 0;

n = 10;

for (i = 1; i <= n; i++){

    if (i == n - i)

        s = s + A[i] + A[i + 1];

}

s: = 0

n : = 10

нц для i от 1 до n

если i = n - i

    то s := s + A[i] + A[i + 1]

все

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    if i == n - i:

        s = s + A[i] + A[i + 1];

 

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. элемент А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


4
Задание 19 № 4930

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования,фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s=0

n = 10

FOR i = 0 TO n

    IF A(n − i)-A(i) > A(i) THEN

        s = s + A(i)

    END IF

NEXT i

s := 0;

n := 10;

for i:=0 to n do begin

    if A[n - i] - A[i] > A[i] then

        s := s + A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 0; i <= n; i++ ) {

    if(A[n - i]-A[i] > A[i]) {

        s = s+ A[i];

    }

}

s := 0

n:=10

нц для i от 0 до n

    если A[n - i] - A[i] > A[i]

        то s := s + A[i]

все

кц

Python

s = 0

n = 10

for i in range(0, n+1):

    if A[n - i]-A[i] > A[i]:

        s = s+ A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 4930: 4971 Все


5
Задание 19 № 6182

В программе описан одномерный целочисленный массив с индексами от 0 до 12. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s = 0

n = 12

FOR i = 0 TO n

    IF A(n–i) – A(i) = A(i) THEN

        s = s+2*A(i)

    END IF

NEXT i

s := 0;

n := 12;

for i:=0 to n do begin

    if A[n–i] – A[i] = A[i] then

        s:=s+2*A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 12;

for (i = 0; i <= n; i++) {

    if (A[n–i] – A[i] == A[i])

        s = s+2*A[i];

}

s := 0

n := 12

нц для i от 0 до n

    если A[n–i] – A[i] = A[i]

        то s := s+2*A[i]

все

кц

Python

s = 0

n = 12

for i in range(0, n+1):

    if A[n–i] – A[i] == A[i]:

        s = s+2*A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, т. е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6182: 6227 Все


6
Задание 19 № 4685

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i - 1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++){

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е. А[0]=0, А[1]=10 и т.д. Чему будет равно значение переменной s после выполнения данной программы?


7
Задание 19 № 4717

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i-1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++) {

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


8
Задание 19 № 6886

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s:=0;

n:=10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1];

end;

Си++Алгоритмический язык

s = 0;

n=10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1];

}

s:=0

n:=10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]

кц

Python

s = 0

n = 10

for i in range(0, n):

    s=s+A[i]-A[i+1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 15, 10, 5, 0, 5, 10, 15, 10, 5, 0, 5, т. е. A[0]=15, A[1]=10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6886: 6918 Все

Пояснение · ·

9
Задание 19 № 6951

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 21.

 

БейсикПаскаль

s = 0

n = 21

FOR i = 2 TO n

    s = s+2*(A(i)-A(i-1))

NEXT i

s:=0;

n:=21;

for i:= 2 to n do begin

    s:=s+2*(A[i]-A[i-1]);

end;

Си++Алгоритмический язык

s = 0;

n = 21;

for (i = 2; i <= n; i++) {

    s=s+2*(A[i]-A[i-1]);

}

s:=0

n:=21

нц для i от 2 до n

    s:= s+2*(A[i]-A[i-1])

кц

Python

s = 0

n = 21

for i in range(2, n+1):

     s=s+2*(A[i]-A[i-1])

 

 

В начале выполнения этого фрагмента в элементе массива с индексом i находилось число i (i = 1, …, 21), т. е. A[1] = 1, A[2] = 2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6951: 6983 Все


10
Задание 19 № 10322

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

  s = s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

  s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

  s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

  s:=s + A[i]*A[i]-A[i-1]*A[i-1]

кц

Си++

s = 0;

n=10;

for (i = 2; i < n+1; i++) {

  s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

В начале выполнения этого фрагмента в массиве находились числа 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, то есть A[1] = 1, A[2] = 2 и так далее Чему будет равно значение переменной s после выполнения данной программы?


11
Задание 19 № 13365

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент этой программы.

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s = 0

n = 10

for i in range(n):

    s = s + A[i] – A[i+1]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=0 to n-1 do begin

  s := s + A[i] - A[i+1];

end;

s := 0

n := 10

нц для i от 0 до n-1

  s := s + A[i] - A[i+1]

кц

Си++

s = 0;

n = 10;

for (i = 0; i < n; i++) {

  s = s + A[i] - A[i+1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 27, 17, 7, 0, 7, 17, 27, 17, 10, 7, 0, т.е. A[0] = 27, A[1] = 17 и т. д. Чему будет равно значение переменной s после выполнения данного фрагмента программы?

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

12
Задание 19 № 13415

В программе используется фрагмент одномерного целочисленного массива A с индексами от 1 до 10. Значения элементов равны 6, 7, 3, 8, 4, 1, 2, 0, 9, 5 соответственно, т. е. A[1] = 6, A[2] = 7 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

13
Задание 19 № 13468

В программе используется фрагмент одномерного целочисленного массив A с индексами от 1 до 10. Значения элементов равны 3, 14, 15, 92, 6, 2, 7, 18, 28, 17 соответственно, т. е. A[1] = 3, A[2] = 14 и т. д.

Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

14
Задание 19 № 13603

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, т. е. A[1]=1, A[2]=12 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

15
Задание 19 № 13630

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 11, 22, 33, 44, 55, 66, 77, 88, 99, т. е. A[1]=1, A[2]=11 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

16
Задание 19 № 15635

Ниже представлен фрагмент программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9; 5 соответственно, т. е. A[0]=5; A[1]=1 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы.

 

БейсикPython

S = 0

FOR i = 0 TO 9

    S = S + A(i+1) – A(i);

NEXT i

s = 0

for i in range(10):

     s = s + A[i+1] - A[i]

ПаскальАлгоритмический язык

s := 0;

for i:=0 to 9 do begin

    s := s + A[i+1] - A[i]

end;

s := 0

нц для i от 0 до 9

     s := s + A[i+1] - A[i]

     все

кц

Си++

s = 0;

for (i=0; i<10; i++)

      s = s + A[i+1] - A[i];

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

Анализ и изменение массива

Версия для печати и копирования в MS Word