≡ информатика
сайты - меню - вход - новости




Варианты заданий

Арифметическая прогрессия

Версия для печати и копирования в MS Word
1
Задание 8 № 3199

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 1

WHILE S < 66

    K = K + 3

    S = S + K

WEND

PRINT K

s = 0

k = 1

while s < 66:

    k += 3

    s += k

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=1;

      while s < 66 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 1

    нц пока s < 66

        k := k + 3

        s := s + k

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 1;

    while (s < 66) {

        k = k + 3;

        s = s + k;

    }

    cout << k << endl;

    return 0;

}

 


2
Задание 8 № 9643

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 20

b = 15

b = 3 * b - a

IF a > b THEN

c = 2 * a + b

ELSE

c = 2 * a - b

END IF

a := 20;

b := 15;

b := 3 * b - a;

if a > b then

c := 2 * a + b

else

c := 2 * a - b;

Си++Алгоритмический язык

a = 20;

b = 15;

b = 3 * b - a;

if (a > b)

c = 2 * a + b;

else

c = 2 * a - b;

a := 20

b := 15

b := 3 * b - a

если a > b

то c := 2 * a + b

иначе c := 2 * a - b

все

Python

a = 20

b = 15

b = 3 * b - a

if a > b:

    c = 2 * a + b

else:

    c = 2 * a - b

 


3
Задание 8 № 9689

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 17

b = 20

a = 3 * a - b

IF a > b THEN

  c = 5 * a - b

ELSE

  c = 5 * a + b

END IF

a := 17;

b := 20;

a := 3 * a - b;

if a > b then

  c := 5 * a - b

else

  c := 5 * a + b;

Си++Алгоритмический язык

a = 17;

b = 20;

a = 3 * a - b;

if (a > b)

  c = 5 * a - b;

else

  c = 5 * a + b;

a := 17

b := 20

a := 3 * a - b

если a > b

  то c := 5 * a - b

  иначе c := 5 * a + b

все

Python

a = 17

b = 20

a = 3 * a - b

if a > b:

    c = 5 * a - b

else:

    c = 5 * a + b

 


4
Задание 8 № 3239

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 30

    K = K + 3

    S = S + K

WEND

PRINT S

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 30 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 30

        k := k + 3

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


5
Задание 8 № 3240

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 1

K = 0

WHILE K < 13

    S = S + 2 * K

    K = K + 4

WEND

PRINT K+S

s = 1

k = 0

while k < 13:

    s += 2*k

    k += 4

print(k+s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=1;

       k:=0;

      while k < 13 do begin

            s:=s+2*k;

             k:=k+4;

       end;

      write(s+k);

end.

алг

нач

    цел k, s

    s := 1

    k := 0

    нц пока k < 13

        s := s + 2 * k

        k := k + 4

    кц

    вывод s+k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 1, k = 0;

    while (k < 13) {

        s = s + 2 * k;

        k = k + 4;

    }

    cout << s+k << endl;

    return 0;

}

 


6
Задание 8 № 3247

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 5

K = 0

WHILE K < 15

    K = K + 2

    S = S + K

WEND

PRINT S

s = 5

k = 0

while k < 15:

    k += 2

    s += k

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=5;

       k:=0;

      while k < 15 do begin

            k:=k+2;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 5

    k := 0

    нц пока k < 15

        k := k + 2

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 5, k = 0;

    while (k < 15) {

        k = k + 2;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


7
Задание 8 № 3249

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + N

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s := s + n;

        n := n + 1;

    }

    cout << s << endl;

    return 0;

}

 


8
Задание 8 № 3250

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 100

    S = S + K

    K = K + 4

WEND

PRINT K

s = 0

k = 0

while s < 100:

    s += k

    k += 4

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 100 do begin

            s:=s+k;

            k:=k+4;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 100

        s := s + k

        k := k + 4

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 100) {

        s = s + k;

        k = k + 4;

    }

    cout << k << endl;

    return 0;

}

 


9
Задание 8 № 3255

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 2

K = 2

WHILE S < 50

    S = S + K

    K = K + 2

WEND

PRINT K

s = 2

k = 2

while s < 50:

    s += k

    k += 2

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=2;

       k:=2;

      while s < 50 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 2

    k := 2

    нц пока s < 50

        s := s + k

        k := k + 2

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 2, k = 2;

    while (s < 50) {

        s = s + k;

        k = k + 2;

    }

    cout << k << endl;

    return 0;

}

 


10
Задание 8 № 3772

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 3

K = 1

WHILE K < 25

    S = S + K

    K = K + 2

WEND

PRINT S

s = 3

k = 1

while k < 25:

    s += k

    k += 2

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=3;

       k:=1;

      while k < 25 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 3

    k := 1

    нц пока k < 25

        s := s + k

        k := k + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 3, k = 1;

    while (k < 25) {

        s = s + k;

        k = k + 2;

    }

    cout << s << endl;

    return 0;

}

 


11
Задание 8 № 3507

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 3;

    s = 0;

    while (n <= 7)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 3

s := 0

нц пока n <= 7

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

 


12
Задание 8 № 3513

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

 


13
Задание 8 № 3529

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

Dim s, k As Integer

s = 0

k = 1

while k < 11

    s = s + k

    k = k + 1

End While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=1;

    while k<11 do

    begin

        s:=s+k;

        k:=k+1;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 1;

    while (k < 11) {

        s = s + k;

        k = k + 1;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=1

нц пока k < 11

    s:=s+k; k:=k+1

кц

вывод s

кон

Python

s = 0

k = 1

while k < 11:

    s += k

    k += 1

print(s)

 


14
Задание 8 № 3538

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

БейсикПаскаль

DIM s, k As Integer

s = 0

k = 0

WHILE k < 30

    k = k + 3

    s = s + k

END While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=0;

    while k < 30 do

    begin

        k:=k+3;

        s:=s+k;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=0

нц пока k < 30

    k:=k+3; s:=s+k

кц

вывод s

кон

Python

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

 

Условие выполнения цикла while

Версия для печати и копирования в MS Word
1
Задание 8 № 2001

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2001: 2004 Все


2
Задание 8 № 2002

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2002: 2003 2005 Все


3
Задание 8 № 2006

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


Аналоги к заданию № 2006: 2007 Все


4
Задание 8 № 2008

Запишите значение переменной b после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


5
Задание 8 № 2010

Запишите значение переменной а после выполнения фрагмента алгоритма:

 

*Примечание: знаком := обозначена операция присваивания. В бланк ответов впишите только число.


6
Задание 8 № 7753

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 47

N = 1

WHILE S > 0

S = S - 9

N = N + 4

WEND

PRINT(N)

s = 47

n = 1

while s > 0:

    s = s - 9

    n = n + 4

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 47;

    n := 1;

    while s > 0 do

    begin

        s := s - 9;

        n := n + 4

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 47

n := 1

нц пока s > 0

    s := s - 9

    n := n + 4

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s, n;

    s = 47;

    n = 1;

    while (s > 0) {

        s = s – 9;

        n = n + 4;

    }

    cout << n << endl;

}

 

Пояснение · ·

7
Задание 8 № 7780

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 42

N = 1

WHILE S > 0

S = S – 5

N = N + 3

WEND

PRINT(N)

s = 42

n = 1

while s > 0:

    s = s - 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 42;

    n := 1;

    while s > 0 do

    begin

        s := s – 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 42

n := 1

нц пока s > 0

    s := s — 5

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s, n;

    s = 42;

    n = 1;

    while (s > 0) {

        s = s – 5;

        n = n + 3;

    }

    cout << n << endl;

}

 


8
Задание 8 № 7919

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 3

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 3

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 3;

    }

    cout « s « endl;

    return 0;

}

 


9
Задание 8 № 7984

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

 N = 1

 S = 0

 WHILE N <= 300

    S = S + 30

    N = N * 3

 WEND

 PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

{

    s = s + 30;

    n = n * 3;

}

    cout « s « endl;

return 0;

}

 


10
Задание 8 № 8096

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

    s = s - 10

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 301;

    n := 0;

    while s > 0 do

    begin

        s := s - 10;

        n := n + 2;

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 301

    n := 0

    нц пока s > 0

        s := s - 10

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 301, n = 0;

    while (s > 0) {

        s = s - 10;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

11
Задание 8 № 8656

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 78

N = 0

WHILE N < 12

    S = S – 8

    N = N + 2

WEND

PRINT(S)

s = 78

n = 0

while n < 12:

    s = s - 8

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 78;

    n := 0;

    while n < 12 do

    begin

        s := s – 8;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 78

    n := 0

    нц пока n < 12

        s := s — 8

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 78;

    n = 0;

    while (n < 12) {

        s = s – 8;

        n = n + 2;

    }

    cout << s << endl;

}

 


12
Задание 8 № 9160

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 56

N = 0

WHILE n < 15

    S = S - 6

    N = N + 3

WEND

PRINT(S)

s = 56

n = 0

while n < 15:

    s = s - 6

    n = n + 3

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 56;

    n := 0;

    while n < 15 do

    begin

        s := s - 6;

        n := n + 3;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 56

    n := 0

    нц пока n < 15

        s := s - 6

        n := n + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 56;

    n = 0;

    while (n < 15) {

        s = s - 6;

        n = n + 3;

    }

    cout << s << endl;

}

 


13
Задание 8 № 9192

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 650

    S = S + 20

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 650:

    s = s + 20

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 650 do

    begin

        s := s + 20;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 650

        s := s + 20

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 650)

    {

        s = s + 20;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 


14
Задание 8 № 9300

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 300

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

    {

        s = s + 30;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 


15
Задание 8 № 9359

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

16
Задание 8 № 9758

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 3*S < 111

   S = S + 8

   N = N + 2

WEND

PRINT N

s = 0

n = 0

while 3*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 3*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 3*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

  while (3*s < 111) { s = s + 8; n = n + 2; }

  cout << n << endl;

  return 0;

}

 


17
Задание 8 № 9794

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S < 111

  S = S + 8

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s < 111:

  s = s + 8

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s < 111 do

  begin

    s := s + 8;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s < 111

    s := s + 8

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (2*s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 


18
Задание 8 № 3241

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

    S = S + 7

    N = N + 1

WEND

PRINT S

n = 1

s = 0

while n <= 101:

    s += 7

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 101 do

    begin

        s := s + 7;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 101

        s := s + 7

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 0;

    while (n <= 101) {

        s = s + 7;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


19
Задание 8 № 3242

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 2

S = 35

WHILE N <= 25

    S = S + 20

    N = N + 5

WEND

PRINT S

n = 2

s = 35

while n <= 25:

    s += 20

    n += 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 2;

    s := 35;

    while n <= 25 do

    begin

        s := s + 20;

        n := n + 5;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 2

    s := 35

    нц пока n <= 25

        s := s + 20

        n := n + 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 2, s = 35;

    while (n <= 25) {

        s = s + 20;

        n = n + 5;

    }

    cout << s << endl;

    return 0;

}

 


20
Задание 8 № 3244

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

    S = S + 20

    N = N + 2

WEND

PRINT S

n = 24

s = 0

while n <= 28:

    s += 20

    n += 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

        n := n + 2;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 24

    s := 0

    нц пока n <= 28

        s := s + 20

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 24, s = 0;

    while (n <= 28) {

        s = s + 20;

        n = n + 2;

    }

    cout << s << endl;

    return 0;

}

 


21
Задание 8 № 3245

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

    S = S + N

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 7

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 7) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


22
Задание 8 № 3248

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 12

S = 5

WHILE N <= 25

    S = S + 12

    N = N + 2

WEND

PRINT S

n = 12

s = 5

while n <= 25:

    s += 12

    n += 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 12;

    s := 5;

    while n <= 25 do

    begin

        s := s + 12;

        n := n + 2;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 12

    s := 5

    нц пока n <= 25

        s := s + 12

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 12, s = 5;

    while (n <= 25) {

        s = s + 12;

        n = n + 2;

    }

    cout << s << endl;

    return 0;

}

 


23
Задание 8 № 3254

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 512;

    while (s >= 0) {

        s = s - 20;

        n = n + 1;

    }

    cout << n << endl;

    return 0;

}

 


24
Задание 8 № 3774

Определите, что будет напечатано в результате выполнения программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 13:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 13

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 13) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


25
Задание 8 № 3775

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 26

    S = S + 6

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 26:

    s += 6

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 26 do

    begin

        s := s + 6;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 26

        s := s + 6

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 26) {

        s = s + 6;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


26
Задание 8 № 3842

Определите, что будет напечатано в результате выполнения программы

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + 15

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += 15

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + 15

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + 15;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.

27
Задание 8 № 3542

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 13

S = S + 15

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 13 do

    begin

        s := s + 15;

    n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 13)

    {

        s = s + 15;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 13

    s := s + 15

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 13:

    s += 15

    n += 1

print(s)

 


28
Задание 8 № 3547

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 20

S = S + 33

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 20 do

    begin

        s := s + 33;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 20)

    {

        s = s + 33;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 20

    s := s + 33

    n := n + 1

кц

вывод s

кон

Python

n = 1

s = 0

while n <= 20:

    s += 33

    n += 1

print(s)

 


29
Задание 8 № 3563

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + 15

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + 15;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + 15;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + 15

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += 15

    n += 1

print(s)

 


30
Задание 8 № 3564

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

S = S - 20

N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

        n := n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 512

нцпока s >= 0

    s := s - 20

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

 


31
Задание 8 № 3565

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 14

S = 0

WHILE N <= 18

S = S + 25

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 14;

    s := 0;

    while n <= 18 do

    begin

        s := s + 25;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 14;

    s = 0;

    while (n <= 18)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 14

s := 0

нцпока n <= 18

    s := s + 25

    n := n + 1

кц

вывод s

кон

Python

n = 14

s = 0

while n <= 18:

    s += 25

    n += 1

print(s)

 


32
Задание 8 № 3566

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 24

S = 0

WHILE N <= 28

S = S + 20

N = N + 2

WEND

PRINT S

var n, s: integer;

begin

    n := 24;

    s := 0;

    while n <= 28 do

    begin

        s := s + 20;

    n := n + 2

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 24;

    s = 0;

    while (n <= 28)

    {

        s = s + 20;

        n = n + 2;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 24

s := 0

нц пока n <= 28

    s := s + 20

    n := n + 2

кц

вывод s

кон

Python

n = 24

s = 0

while n <= 28:

    s += 20

    n += 2

print(s)

 


33
Задание 8 № 3810

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования:

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 101

S = S + 7

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n : = 1;

    s : = 0;

    while n <= 101 do

    begin

        s : = s + 7;

        n : = n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 101)

    {

        s = s + 7;

        n = n + 1;

    }

    cout << s << endl;

}

алг

нач

цел n, s

n : = 1

s : = 0

нц пока n <= 101

    s : = s + 7

    n : = n + 1

кц

вывод s

кон

Python

n = 1

s = 0

while n <= 101:

    s += 7

    n += 1

print(s)

 

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.

34
Задание 8 № 4557

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 35

    N = N + 1

    S = S + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 35 do

    begin

        n := n + 1;

        s := s + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 35)

    {

        n = n + 1;

        s = s + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 35

    n := n + 1

    s := s + 4

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 35:

    n += 1

    s += 4

print(n)

 

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

35
Задание 8 № 4587

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S >= 0

    S = S - 20

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 512;

    while s >= 0 do

    begin

        s := s - 20;

    n := n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s >= 0)

    {

        s = s - 20;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

    цел n, s

    n := 0

    s := 512

    нц пока s >= 0

        s := s - 20

        n := n + 1

    кц

    вывод n

кон

Python

n = 0

s = 512

while s >= 0:

    s -= 20

    n += 1

print(n)

 


36
Задание 8 № 4691

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 50

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 512 do

    begin

        s := s + 50;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0 ;

    s = 0 ;

    while (s <= 512)

    {

        s = s + 50;

        n = n + 1;

}

cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 512

    s := s + 50

    n := n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 512:

    s += 50

    n += 1

print(n)

 


37
Задание 8 № 4723

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 1

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 1

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 1;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 256

    s : = s + 25

    n : = n + 1

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 256:

    s += 25

    n += 1

print(n)

 


38
Задание 8 № 4848

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 33

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 365 do

    begin

        s : = s + 33;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 33;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 0

s : = 0

нц пока s <= 365

    s : = s + 33

    n : = n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 33

    n += 10

print(n)

 


39
Задание 8 № 4936

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 5

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 5

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 5;

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 5

print(n)

 


40
Задание 8 № 4977

Определите, что будет напечатано в результате выполнения следующей программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

While S <= 365

S = S + 36

N = N + 10

WEND

PRINT N

var n, s : integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

    n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 36;

    n := n + 10;

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 10

print(n)

 


41
Задание 8 № 5212

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 30

S = 25

WHILE S < 425

S = S + 40

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 30;

    s : = 25;

    while s < 425 do

    begin

        s : = s + 40;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 25;

    while (s < 425)

    {

        s = s + 40;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 30

s : = 25

нц пока s < 425

    s : = s + 40

    n : = n + 10

кц

вывод n

кон

Python

n = 30

s = 25

while s < 425:

    s += 40

    n += 10

print(n)

 


42
Задание 8 № 5244

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 60

S = 25

WHILE S < 365

S = S + 20

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n : = 60;

    s : = 25;

    while s < 365 do

    begin

        s : = s + 20;

        n : = n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 60;

    s = 25;

    while (s < 365)

    {

        s = s + 20;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 60

s : = 25

нц пока s < 365

    s : = s + 20

    n : = n + 10

кц

вывод n

кон

Python

n = 60

s = 25

while s < 365:

    s += 20

    n += 10

print(n)

 


43
Задание 8 № 5361

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s := s + 10

        n := n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 1.

44
Задание 8 № 5393

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 2.
Пояснение · ·

45
Задание 8 № 5457

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 2;

    }

    cout « n « endl;

}

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 2

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.

46
Задание 8 № 5489

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 325 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 325

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 325:

    s += 10

    n += 3

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 1.

47
Задание 8 № 5521

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 25;

        n := n + 4;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 25

    n += 4

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Даль­ний Восток. Ва­ри­ант 3.

48
Задание 8 № 5553

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 10

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 10;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 10

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Даль­ний Восток. Ва­ри­ант 5.

49
Задание 8 № 5585

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 257

    S = S + 25

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 257 do

    begin

        s : = s + 25;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 257:

    s += 25

    n += 2

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 2.

50
Задание 8 № 5617

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

    S = S + 24

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 249 do

    begin

        s : = s + 24;

        n : = n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 24

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 24

    n += 3

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 3.
Пояснение · ·

51
Задание 8 № 5713

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 256

    S = S + 25

    N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 256 do

    begin

        s : = s + 25;

        n : = n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 256)

    {

        s = s + 25;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 256

        s : = s + 25

        n : = n + 5

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 256:

    s += 25

    n += 5

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 2.

52
Задание 8 № 5745

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 512

    S = S + 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 512 do

    begin

        s : = s + 25;

        n : = n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 512)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 512

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 512:

    s += 25

    n += 4

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

53
Задание 8 № 5809

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 425

    S = S + 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 0;

    while s <= 425 do

    begin

        s : = s + 10;

        n : = n + 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 425)

    {

        s = s + 10;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 425

        s : = s + 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 0

while s <= 425:

    s += 10

    n += 2

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 5.

54
Задание 8 № 5841

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 301

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 301;

    while s > 0 do

    begin

        s : = s - 10;

        n : = n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 301;

    while (s > 0)

    {

        s = s - 10;

        n = n + 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 301

    нц пока s > 0

        s : = s - 10

        n : = n + 2

    кц

вывод n

кон

Python

n = 0

s = 301

while s > 0:

    s -= 10

    n += 2

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 1.

55
Задание 8 № 5873

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 512

WHILE S > 0

    S = S - 25

    N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 512;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 4;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 512;

    while (s > 0)

    {

        s = s - 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 512

    нц пока s > 0

        s : = s - 25

        n : = n + 4

    кц

вывод n

кон

Python

n = 0

s = 512

while s > 0:

    s -= 25

    n += 4

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 2.

56
Задание 8 № 5905

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 256

WHILE S > 0

    S = S - 25

    N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n : = 0;

    s : = 256;

    while s > 0 do

    begin

        s : = s - 25;

        n : = n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

void main()

{

    int n, s;

    n = 0;

    s = 256;

    while (s > 0)

    {

        s = s - 25;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

    n : = 0

    s : = 256

    нц пока s > 0

        s : = s - 25

        n : = n + 3

    кц

вывод n

кон

Python

n = 0

s = 256

while s > 0:

    s -= 25

    n += 3

print(n)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Центр. Ва­ри­ант 3.

57
Задание 8 № 6003

Запишите число, которое будет напечатано в результате выполнения программы (для Вашего удобства программа представлена на четырёх языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 325

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 325 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write (n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main ()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 325)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

целn, s

n := 0

s := 0

нц пока s <= 325

    s := s + 10

    n := n + 3

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 325:

    s += 10

    n += 3

print(n)

 

Источник: Демонстрационная версия ЕГЭ—2014 по информатике.
Пояснение · ·

58
Задание 8 № 6188

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 7

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 7

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 7;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 7

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 7

print(n)

 


59
Задание 8 № 6233

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 36

N = N + 8

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n + 8

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n + 8;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока

s <= 365

    s := s + 36

    n := n + 8

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 36

    n += 8

print(n)

 


60
Задание 8 № 6265

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 267:

    s += 25

    n += 10

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 501.

61
Задание 8 № 6305

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 267

S = S + 25

N = N + 20

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 267 do

    begin

        s := s + 25;

        n := n + 20

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 267)

    {

        s = s + 25;

        n = n + 20;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 267

    s := s + 25

    n := n + 20

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 267:

    s += 25

    n += 20

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.

62
Задание 8 № 6337

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 10

S = 0

WHILE S <= 249

S = S + 24

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 10;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 10;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 10

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 3

кц

вывод n

кон

Python

n = 10

s = 0

while s <= 249:

    s += 24

    n += 3

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 601.

63
Задание 8 № 6422

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 40

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 40;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 40;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 40

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

Python

n = 40

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 602.

64
Задание 8 № 6458

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 20

S = 0

WHILE S <= 257

S = S + 10

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 20;

    s := 0;

    while s <= 257 do

    begin

        s := s + 10;

        n := n + 3

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 20;

    s = 0;

    while (s <= 257)

    {

        s = s + 10;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 20

s := 0

нц пока s <= 257

    s := s + 10

    n := n + 3

кц

вывод n

кон

Python

n = 20

s = 0

while s <= 257:

    s += 10

    n += 3

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 603.

65
Задание 8 № 6500

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

S = S + 24

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 24

    n += 10

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.

66
Задание 8 № 6576

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 15

S = 0

WHILE S <= 257

S = S + 25

N = N + 4

WEND

PRINT N

var n, s: integer;

begin

    n := 15;

    s := 0;

    while s <= 257 do

    begin

        s := s + 25;

        n := n + 4

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 15;

    s = 0;

    while (s <= 257)

    {

        s = s + 25;

        n = n + 4;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 15

s := 0

нц пока s <= 257

    s := s + 25

    n := n + 4

кц

вывод n

кон

Python

n = 15

s = 0

while s <= 257:

    s += 25

    n += 4

print(n)

 

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.

67
Задание 8 № 6778

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 37

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 37;

        n := n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 37;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 37

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 365:

    s += 37

    n *= 2

print(n)

 


68
Задание 8 № 6810

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 365 do

    begin

        s := s + 36;

        n := n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 365

    s := s + 36

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 365:

    s += 36

    n *= 2

print(n)

 


69
Задание 8 № 6892

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 18

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 18;

        n := n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 18;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 18

    n := n + 5

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 18

    n += 5

print(n)

 


70
Задание 8 № 6924

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 365

S = S + 12

N = N + 5

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 365 do

    begin

        s := s + 12;

        n := n + 5

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 365)

    {

        s = s + 12;

        n = n + 5;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 365

    s := s + 12

    n := n + 5

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 365:

    s += 12

    n += 5

print(n)

 


71
Задание 8 № 7202

Определите число, которое будет напечатано в результате выполнения программы.

Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 70

WHILE S > 7

S = S – 7

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 70;

    while s > 7 do

    begin

        s := s – 7;

        i := i + 1

    end;

    writeln(i)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int i, s;

    i = 0;

    s = 70;

    while (s > 7)

    {

        s = s – 7;

        i++;

    }

    cout << i << endl ;

}

алг

нач

цел i, s

i := 0

s := 70

нц пока s > 7

    s := s - 7

    i := i + 1

кц

вывод i

кон

Python

i = 0

s = 70

while s > 7:

    s -= 7

    i += 1

print(i)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

72
Задание 8 № 7269

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 15

WHILE S <= 250

    S = S + 12

    N = N + 2

WEND

PRINT N

n = 4

s = 15

while s <= 250:

    s += 12

    n += 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 15;

    while s <= 250 do

    begin

        s := s + 12;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 4

    s := 15

    нц пока s <= 250

        s := s + 12

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 15;

    while (s <= 250) {

        s = s + 12;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 


73
Задание 8 № 7371

Определите число, которое будет напечатано в результате выполнения программы.

Для Вашего удобства программа представлена на четырёх языках программирования.

 

БейсикПаскаль

DIM I, S AS INTEGER

I = 0

S = 64

WHILE S > 8

S = S – 8

I = I + 1

WEND

PRINT(I)

var i, s: integer;

begin

    i := 0;

    s := 64;

    while s > 8 do

    begin

        s := s – 8;

        i := i + 1

    end;

    writeln(i)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int i, s;

    i = 0;

    s = 64;

    while (s > 8)

    {

        s = s – 8;

        i++;

    }

    cout << i << endl;

}

алг

нач

цел i, s

i := 0

s := 64

нц пока s > 8

    s := s - 8

    i := i + 1

кц

вывод i

кон

Python

i = 0

s = 64

while s > 8:

    s -= 8

    i += 1

print(i)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

74
Задание 8 № 10284

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 3

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 3;

  }

  cout << n << endl;

  return 0;

}

 


75
Задание 8 № 10311

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 123

  S = S + 1

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 123:

  s = s + 1

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while 2*s*s < 123 do

  begin

    s := s + 1;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока 2*s*s < 123

    s := s + 1

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (2*s*s < 123) {

    s = s + 1;

    n = n + 2;

  }

  cout << n << endl;

  return 0;

}

 


76
Задание 8 № 10382

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 3

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 3

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 3;

  }

  cout << n << endl;

  return 0;

}

 


77
Задание 8 № 10409

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 123

  S = S + 12

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 123:

  s = s + 12

  n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 123 do

  begin

    s := s + 12;

    n := n + 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 123) {

    s = s + 12;

    n = n + 2;

  }

  cout « n « endl;

  return 0;

}

 


78
Задание 8 № 10471

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S <= 65

S = S + 5

N = N + 3

WEND

PRINT N

s = 0

n = 0

while s <= 65:

    s = s + 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s <= 65 do

    begin

        s := s + 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел n, s

s := 0

n := 0

нц пока s <= 65

    s := s + 5

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 0;

    while (s <= 65)

    {

        s = s + 5;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 


79
Задание 8 № 10498

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 65

S = S + 6

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 65:

    s = s + 6

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 0;

    while s < 65 do

    begin

        s := s + 6;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

  цел n, s

  s := 0

  n := 0

  нц пока s < 65

    s := s + 6

    n := n + 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 0;

    while (s < 65)

    {

        s = s + 6;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 


80
Задание 8 № 11109

Определите число, которое будет напечатано в результате выполнения программы, записанной ниже на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 251

  S = S + 25

  N = N + 1

WEND

PRINT N

n = 0

s = 0

while s <= 251:

    s = s + 25

    n = n + 1

print(n)

Алгоритмический языкПаскаль

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s <= 251

    s := s + 25

    n := n + 1

  кц

  вывод n

кон

var n, s: integer;

begin

  n := 0;

  s := 0;

  while s <= 251 do

  begin

    s := s + 25;

    n := n + 1

  end;

  write(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int n, s;

  n = 0;

  s = 0;

  while (s <= 251)

  {

    s = s + 25;

    n = n + 1;

  }

  cout « n « endl;

}

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна

81
Задание 8 № 11237

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 5

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 5

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 5

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 5

  end;

  writeln(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 5;

  }

  cout << n << endl;

  return 0;

}

 


82
Задание 8 № 11264

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 165

  S = S + 15

  N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s = s + 15

    n = n + 2

print(n)

Алгоритмический языкПаскаль

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 165

    s := s + 15

    n := n + 2

  кц

  вывод n

кон

var s, n: integer;

begin

  s := 0;

  n := 0;

  while s < 165 do

  begin

    s := s + 15;

    n := n + 2

  end;

  writeln(n)

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0, n = 0;

  while (s < 165) {

    s = s + 15;

    n = n + 2;

  }

  cout << n << endl;

  return 0;

}

 


83
Задание 8 № 11304

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

S = 0

N = 0

WHILE S < 165

    S = S + 15

    N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 165:

    s += 15

    n += 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    s := 0;

    n := 0;

    while s < 165 do

    begin

        s := s + 15;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    s := 0

    n := 0

    нц пока s < 165

        s := s + 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 0;

    while (s < 165) {

        s = s + 15;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

84
Задание 8 № 11344

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 150

    S = S + 30

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 150:

    s = s + 30

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 150 do

    begin

        s := s + 30;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 150

        s := s + 30

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 150)

    {

        s = s + 30;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

85
Задание 8 № 13354

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 71

     S = S + 10

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while s < 71:

    s = s + 10

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 71 do

begin

    s := s + 10;

    n := n + 3

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 71

    s := s + 10

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s < 71) { s = s + 10; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

86
Задание 8 № 13404

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 99

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 99:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 99 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 99

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s*s < 99) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

87
Задание 8 № 13457

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S*S < 101

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while s*s < 101:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s*s < 101 do

begin

    s := s + 1;

    n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s*s < 101

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (s*s < 101) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

88
Задание 8 № 13484

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S <= 10*S

     S = S + 1

     N = N + 3

WEND

PRINT N

s = 0

n = 0

while 2*s*s <= 10*s:

    s = s + 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s <= 10*s do

begin

    s := s + 1;

    n := n + 3;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s <= 10*s

    s := s + 1

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s <= 10*s) { s = s + 1; n = n + 3; }

    cout << n << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

89
Задание 8 № 13511

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 10*S

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 10*s:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s < 10*s do

begin

    s := s + 1;

    n := n + 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s < 10*s

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s < 10*s) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

90
Задание 8 № 13538

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 150

     S = S + 15

     N = N*2

WEND

PRINT N

s = 0

n = 1

while s < 150:

    s = s + 15

    n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 1;

while s < 150 do

begin

    s = s + 15;

    n = n * 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока s < 150

    s = s + 15

    n = n * 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 1;

    while (s < 150) { s = s + 15; n = n * 2; }

    cout << n << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

91
Задание 8 № 13565

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 1

WHILE S < 165

  S = S + 15

  N = N * 2

WEND

PRINT N

s = 0

n = 1

while s < 165:

  s = s + 15

  n = n * 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

  s := 0;

  n := 1;

  while s < 165 do

  begin

    s := s + 15;

    n := n * 2

  end;

  writeln(n)

end.

алг

нач

  цел n, s

  n := 1

  s := 0

  нц пока s < 165

    s = s + 15

    n = n * 2

  кц

  вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int s = 0;

  int n = 1;

  while (s < 165) {

    s = s + 15;

    n = n * 2;

  }

  cout << n << endl;

  return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

92
Задание 8 № 13592

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 3

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

93
Задание 8 № 13619

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 20

N = 0

WHILE 91 < S*S

S = S - 1

N = N + 2

WEND

PRINT N

s = 20

n = 0

while 91 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 20;

    n := 0;

    while 91 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 20

    n := 0

    нц пока 91 < s*s

        s := s - 1

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 20, n = 0;

    while (91 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

94
Задание 8 № 13735

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 0

S = 260

WHILE S > 0

    S = S - 15

    N = N + 2

WEND

PRINT N

n = 0

s = 260

while s > 0:

    s = s - 15

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 0;

    s := 260;

    while s > 0 do

    begin

        s := s - 15;

        n := n + 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 0

    s := 260

    нц пока s > 0

        s := s - 15

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 0, s = 260;

    while (s > 0) {

        s = s - 15;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

95
Задание 8 № 14223

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 3

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 


96
Задание 8 № 14267

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 25

N = 0

WHILE 400 < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while 400 < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while 400 < s*s do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n);

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока 400 < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s = 25, n = 0;

    while (400 < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 


97
Задание 8 № 14694

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 22

N = 0

WHILE S < S*S

    S = S - 1

    N = N + 3

WEND

PRINT N

s = 22

n = 0

while s < s*s:

    s = s - 1

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 22;

    n := 0;

    while s < s*s do begin

        s := s - 1;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    n := 0

    s := 22

    нц пока s < s*s

        s := s - 1;

        n := n + 3

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 22, n = 0;

    while (s < s*s) {

        s = s - 1;

        n = n + 3;

    }

    cout << n << endl;

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10203

98
Задание 8 № 14769

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 0

WHILE S < S*S

    S = S - 1

    N = N + 2

WEND

PRINT N

s = 25

n = 0

while s < s*s:

    s = s - 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 0;

    while s < s*s do begin

        s := s - 1;

        n := n + 2

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    n := 0

    s := 25

    нц пока s < s*s

        s := s - 1;

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 0;

    while (s < s*s) {

        s = s - 1;

        n = n + 2;

    }

    cout << n;

    return 0;

}

 


99
Задание 8 № 15103

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 1

WHILE N < 11

S = S - 1

N = N + 2

WEND

PRINT S

s = 25

n = 1

while n < 11:

    s = s - 1

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 1;

    while n < 11 do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 25

    n := 1

    нц пока n < 11

        s := s - 1

        n := n + 2

    кц

    вывод s

кон

С++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 1;

    while (n < 11) {

        s = s - 1;

        n = n + 2;

    }

    cout << s;

    return 0;

}

 

 


100
Задание 8 № 15130

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 25

N = 1

WHILE N < 21

S = S - 1

N = N + 2

WEND

PRINT S

s = 25

n = 1

while n < 21:

    s = s - 1

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 25;

    n := 1;

    while n < 21 do

    begin

        s := s - 1;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 25

    n := 1

    нц пока n < 21

        s := s - 1

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 25, n = 1;

    while (n < 21) {

        s = s - 1;

        n = n + 2;

    }

    cout << s;

    return 0;

}

 

 


101
Задание 8 № 15624

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 170

WHILE S + N < 325

    S = S + 25

    N = N - 5

WEND

PRINT S

s = 0

n = 170

while s + n < 325:

    s = s + 25

    n = n - 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 170;

while s + n < 325 do

begin

    s := s + 25;

    n := n - 5

end;

writeln(s)

end.

алг

нач

    цел n, s

    s := 0

    n := 170

    нц пока s + n < 325

        s := s + 25

        n := n - 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

int s = 0, n = 170;

while (s + n < 325) {

    s = s + 25;

    n = n - 5;

}

cout << s << endl;

return 0;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

102
Задание 8 № 15793

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 6

WHILE N > 1

S = S + N

N = N − 1

WEND

PRINT S

s = 0

n = 6

while n > 1:

    s = s + n

    n = n − 1

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 6;

    while n > 1 do

    begin

        s := s + n;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 6

    нц пока n > 1

        s := s + n

        n := n − 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 6;

    while (n > 1) {

        s = s + n;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 


103
Задание 8 № 15820

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 5

WHILE N > 0

S = S + N

N = N − 1

WEND

PRINT S

s = 0

n = 5

while n > 0:

    s = s + n

    n = n − 1

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 5;

    while n > 0 do

    begin

        s := s + n;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 5

    нц пока n > 0

        s := s + n

        n := n − 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 5;

    while (n > 0) {

        s = s + n;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 


104
Задание 8 № 15848

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

 DIM S, N AS INTEGER

 S = 150

 N = 0

 WHILE S + N < 300

     S = S − 5

     N = N + 25

 WEND

 PRINT N

s = 150

n = 0

while s + n < 300:

    s = s − 5

    n = n + 25

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 150;

n := 0;

while s + n < 300 do

begin

    s := s − 5;

    n := n + 25

end;

writeln(n)

end.

алг

нач

    цел n, s

    s := 150

    n := 0

    нц пока s + n < 300

        s := s − 5

        n := n + 25

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

int s = 150, n = 0;

while (s + n < 300) {

    s = s − 5;

    n = n + 25;

}

cout << n << endl;

return 0;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

105
Задание 8 № 15918

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 26

WHILE N > S

S = S + 1

N = N − 1

WEND

PRINT S

s = 0

n = 26

while n > s:

    s = s + 1

    n = n − 1

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 26;

    while n > s do

    begin

        s := s + 1;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 26

    нц пока n > s

        s := s + 1

        n := n − 1

    кц

    вывод s

кон

C++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 26;

    while (n > s) {

        s = s + 1;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 


106
Задание 8 № 15945

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 32

WHILE N > S

S = S + 1

N = N − 1

WEND

PRINT N

s = 0

n = 32

while n > s:

    s = s + 1

    n = n − 1

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 32;

    while n > s do

    begin

        s := s + 1;

        n := n − 1;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 0

    n := 32

    нц пока n > s

        s := s + 1

        n := n − 1

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 32;

    while (n > s) {

        s = s + 1;

        n = n − 1;

    }

    cout << n;

    return 0;

}

 

 


107
Задание 8 № 15976

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 80

N = 0

WHILE S + N < 150

S = S − 5

N = N + 15

WEND

PRINT N

s = 80

n = 0

while s + n < 150:

    s = s − 5

    n = n + 15

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 80;

    n := 0;

    while s + n < 150 do

    begin

        s := s − 5;

        n := n + 15;

    end;

    writeln(n)

end.

алг

нач

    цел s, n

    s := 80

    n := 0

    нц пока s + n < 150

        s := s − 5

        n := n + 15

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 80, n = 0;

    while (s + n < 150) {

        s = s − 5;

        n = n + 15;

    }

    cout << n;

    return 0;

}

 

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна, вариант А. Имаева — «Котолис».

108
Задание 8 № 16035

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

S = 0

N = 75

WHILE S + N < 150

    S = S + 15

    N = N − 5

WEND

PRINT N

s = 0

n = 75

while s + n < 150:

    s = s + 15

    n = n − 5

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    s := 0;

    n := 75;

    while s + n < 150 do

    begin

        s := s + 15;

        n := n − 5;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    s := 0

    n := 75

    нц пока s + n < 150

        s := s + 15

        n := n − 5

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    s = 0, n = 75;

    while (s + n < 150) {

        s = s + 15;

        n = n − 5;

    }

    cout << n << endl;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2019 по информатике.

109
Задание 8 № 16383

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 40

WHILE S + N < 100

S = S + 20

N = N − 5

WEND

PRINT S

s = 0

n = 40

while s + n < 100:

    s = s + 20

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 40;

    while s + n < 100 do

    begin

        s := s + 20;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 40

    нц пока s + n < 100

        s := s + 20

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 40;

    while (s + n < 100) {

        s = s + 20;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


110
Задание 8 № 16437

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 40

WHILE S + N < 100

S = S + 25

N = N − 5

WEND

PRINT S

s = 0

n = 40

while s + n < 100:

    s = s + 25

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 40;

    while s + n < 100 do

    begin

        s := s + 25;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 40

    нц пока s + n < 100

        s := s + 25

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 40;

    while (s + n < 100) {

        s = s + 25;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


111
Задание 8 № 16811

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 20

WHILE S + N <= 100

S = S + 25

N = N − 5

WEND

PRINT S

s = 0

n = 20

while s + n <= 100:

    s = s + 25

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 20;

    while s + n <= 100 do

    begin

        s := s + 25;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 20

    нц пока s + n <= 100

        s := s + 25

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 20;

    while (s + n <= 100) {

        s = s + 25;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 


112
Задание 8 № 16884

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 25

WHILE S + N <= 100

S = S + 20

N = N − 5

WEND

PRINT S

s = 0

n = 25

while s + n <= 100:

    s = s + 20

    n = n − 5

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 0;

    n := 25;

    while s + n <= 100 do

    begin

        s := s + 20;

        n := n − 5;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 25

    нц пока s + n <= 100

        s := s + 20

        n := n − 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 25;

    while (s + n <= 100) {

        s = s + 20;

        n = n − 5;

    }

    cout << s;

    return 0;

}

 

 

Геометрическая прогрессия

Версия для печати и копирования в MS Word
1
Задание 8 № 3243

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 80

    S = S + 2*K

    K = K + 4

WEND

PRINT S

s = 0

k = 0

while s < 80:

    s += 2*k

    k += 4

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 80 do begin

            s:=s+2*k;

            k:=k+4;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 80

        s := s + 2*k

        k := k + 4

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 80) {

        s = s + 2*k;

        k = k + 4;

    }

    cout << s << endl;

    return 0;

}

 


2
Задание 8 № 7665

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 2

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 2

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 2;

    }

    cout « s « endl;

}

 


Аналоги к заданию № 7665: 7692 Все


3
Задание 8 № 3253

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 12

    S = S + 2*K

    K = K + 3

WEND

PRINT S

s = 0

k = 0

while k < 12:

    s += 2*k

    k += 3

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 12 do begin

            s:=s+2*k;

            k:=k+3;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 12

        s := s + 2*k

        k := k + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 12) {

        s = s + 2*k;

        k = k + 3;

    }

    cout << s << endl;

    return 0;

}

 


4
Задание 8 № 5088

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 26

WHILE S <= 205

    S = S + 20

    N = N * 2

WEND

PRINT N

n = 1

s = 26

while s <= 205:

    s += 20

    n *= 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 26;

    while s <= 205 do

    begin

        s := s + 20;

        n := n * 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 1

    s := 26

    нц пока s <= 205

        s := s + 20

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 26;

    while (s <= 205) {

        s = s + 20;

        n = n * 2;

    }

    cout << n << endl;

    return 0;

}

 


5
Задание 8 № 5056

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 6

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 1;

    s : = 6;

    while s <= 365 do

    begin

        s : = s + 36;

        n : = n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 6;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 1

s : = 6

нц пока s <= 365

    s : = s + 36

    n : = n * 2

кц

вывод n

кон

Python

n = 1

s = 6

while s <= 365:

    s += 36

    n *= 2

print(n)

 


6
Задание 8 № 5277

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 30

    S = 1

    WHILE S < 500

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n := 30;

    s := 1;

    while s < 500 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 1;

    while (s < 500)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 30

s : = 1

нц пока s < 500

    s := s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 30

s = 1

while s < 500:

    s *= 2

    n += 10

print(n)

 


7
Задание 8 № 5309

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 50

    S = 1

    WHILE S < 1000

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n : = 50;

    s := 1;

    while s < 1000 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 50;

    s = 1;

    while (s < 1000)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 50

s : = 1

нц пока s < 1000

    s : = s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 50

s = 1

while s < 1000:

    s *= 2

    n += 10

print(n)

 


8
Задание 8 № 6957

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 128

N = N * 2

WEND

PRINT N

program B05;

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 128;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 128;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 128

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 128

    n *= 2

print(n)

 


9
Задание 8 № 6989

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 256

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 256;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 256;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 256

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 256

    n *= 2

print(n)

 

Пояснение · ·

10
Задание 8 № 7307

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 2

N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 2;

        n := n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 2;

        n = n + 2;

    }

    cout << n << endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 2

    n := n + 2

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 2

    n += 2

print(n)

 


11
Задание 8 № 7339

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 3

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 3;

        n := n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 3;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 3

    n := n + 3

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 3

    n += 3

print(n)