№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИПИ Справка
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Задания
Задание 19 № 3375

Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR i = 1 TO 5

    FOR j = 1 TO 5

        A(i,j) = i*j

    NEXT j

NEXT i

for i in range(1, 6):

    for j in range(1, 6):

        A[i,j] = i*j

ПаскальАлгоритмический язык

for i:= 1 to 5 do

    for j:=1 to 5 do begin

        A[i,j]:= i*j;

    end;

нц для i от 1 до 5

    нц для j от 1 до 5

        A[i,j]:= i*j

    кц

кц

Си++

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]= i*j;

    }

}

 

 

Сколько элементов массива будут иметь значения больше 10?

Решение.

Элемент A[3,3] = 3 * 3 = 9, 9 < 10, следовательно, нас интересуют элементы, у которых один индекс не меньше 3, а другой больше 3. Обозначим все эти элементы: A[3,4], A[3,5], A[4,3], A[4,4], A[4,5], A[5,3], A[5,4], A[5,5]. Их 8.

· · Видеокурс ·